Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Is it possible to communicate with other VLANS without trunking?

Environment: Packet Tracert

                    Scenario:

                    1 L3 switch

                    5 access switch (Unmanage)

Routing between vlans supposed to work when using trunking right? However given the scenario and resources above i was able to ping other Host on VLANS from a different VLAN without configuring trunk. In this scenario I only have access to 3560 switch, the rest of the switch is unmanage. I havent configured trunking on the oports were other access switches are connected. how is it possible that host from other VLANS are able to ping each other.

Im thingking because the access switch inherits the same Native vlans as to the 3560 switch thats why it works, however if you can see on the below diagram i directly attached a host on the 3560 switch and assign its port on a separate VLAN (VLAN 40) still i am able to ping host from VLANS 1, 10, 20 and 30. Here is the config of the 3560 SW and the land diagram.

Switch#sh run

Building configuration...

Current configuration : 1422 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/1

switchport access vlan 10

!

interface FastEthernet0/2

switchport access vlan 20

!

interface FastEthernet0/3

switchport access vlan 30

!

interface FastEthernet0/4

!

interface FastEthernet0/5

switchport access vlan 40

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 172.16.99.90 255.255.255.0

!

interface Vlan10

ip address 10.0.10.1 255.255.255.0

!

interface Vlan20

ip address 10.0.20.1 255.255.255.0

!

interface Vlan30

ip address 10.0.30.1 255.255.255.0

!

interface Vlan40

ip address 10.0.40.1 255.255.255.0

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

!

end

Switch#  

                     the

4 REPLIES

Re: Is it possible to communicate with other VLANS without trunk

Hi

Your 3560 is a L3 capable device and with the config posted above, is actually acting as both a switch and a router. Communicating between subnets (Vlans) needs a device which is able to 'Route' between them, which is what you 3560 is doing.

Each of the hosts in your Vlans has a default Gateway, i.e the Vlan interfaces you can see. The 3560 considers each of these interfaces as 'Directly Connected' subnets, meaning it can route between them as IP Routing is enabled (which it is) and each of the Vlan interfaces is in and Up Up state (which they must be).

Trunking (from a Cisco perspective) allows a single link to pass traffic for multiple Vlans. The behavior of an Access port is to remove the Vlan tag from the frame before it forwards it to the host. If the port is configured as a trunk, it maintains the Vlan tag on the frame as it forwards it to the host. Trunks tend to be connections to other switches, allowing ports from more than one Vlan to span multiple switches.

Re: Is it possible to communicate with other VLANS without trunk

devil is right, nice description.

Re: Is it possible to communicate with other VLANS without trunk

@ D_Advocate.

Thanks. So this means that the set up i made on packet t will work in real world? I was having doubt since i was simulating it on a packet tracer, i thought it was a bug or something.

Creating VLAN interfaces on the L3 switch and using them as the DG of the host on the specific VLAN then enabling ip-routing would do the trick to allow commuincations between VLANS, so in a way this is an alternative solutions if Trunking is not possible?

Re: Is it possible to communicate with other VLANS without trunk

Trunking and communicating between Vlans are two different things.

Trunking allows traffic from multiple vlans to pass across a single link, it won't allow hosts in one Vlan to communicate with hosts in another Vlan.

A 'Vlan' is a Layer 2 broadcast domain by default meaning if you simply created two Vlan's on a single switch (without a Vlan interface), the hosts would be able to communicate with hosts inside the same Vlan as them but not with hosts on other Vlans. Some switches are Layer 2 only capable, meaning you can create multiple Vlans but there is no way to route between then and some switches are Layer 3 capable, meaning they will let you setup Vlan interfaces (i.e default gateways for the hosts) so traffic can 'Route' between the Vlans.

I would grab a copy of the CCENT/CCNA books and have a look, it will teach you a fair amount of the theory which you can then put into practice

322
Views
0
Helpful
4
Replies
CreatePlease to create content