Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

isdn issues

Hi all, I have just set up a cisco 1700 isdn router to dial to a remote location, for some reason when I try to ping the other end, it doesnt work, I have isdn debugging on but it doesnt even seem to raise the dialer interface, , from the debug I get the following, can anyone help, thanks :

2:00:38: ISDN BR0: RX <- RRp sapi = 0 tei = 64 nr = 0

02:00:163208757248: ISDN BR0: TX -> RRf sapi = 0 tei = 64 nr = 0

9 REPLIES
Silver

Re: isdn issues

Hi carl ,

can you paste the config of the router.Try use the follwing debug and show commands for troubleshooting.

debug isdn q921 and debug isdnq931

sh isdn s bri0

sh isdn a

Thanks,

Satish

New Member

Re: isdn issues

config, looks ok to me

interface FastEthernet0

ip address 10.1.1.30 255.0.0.0

speed auto

full-duplex

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface Dialer1

description CONNECTION TO xxxx

ip unnumbered FastEthernet0

encapsulation ppp

dialer pool 1

dialer remote-name wooldaler1

dialer idle-timeout 30

dialer string xxxxxxxxxxxx

dialer-group 1

ppp authentication chap

ppp chap hostname wooldaler1

ppp chap password 7 112E3C2B3E312421

ip classless

ip route 172.21.247.0 255.255.255.255 Dialer1

access-list 1 permit 172.21.247.0 0.0.0.255

dialer-list 1 protocol ip list 1

here is the sh bri 0 command output

BRI0 is up, line protocol is up (spoofing)

Hardware is PQUICC BRI

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Last input 00:00:05, output never, output hang never

Last clearing of "show interface" counters 02:41:36

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

150 packets input, 721 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

122 packets output, 497 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

5 carrier transitions

Silver

Re: isdn issues

Hi carl ,

Can you change ip route 172.21.247.0 255.255.255.255 Dialer1 to ip route 172.21.247.0 255.255.255.0 Dialer1 and check the issue.

check whether you configured username xxxx password xxx in global config mode for remote end.

Thanks,

satish

New Member

Re: isdn issues

Carl

the standard access-list you have configured looks wrong.

Standard ACL's are based on source address which in your case is the 10 network. Your acl has the destination network in.

Your local traffic will not be classed as interesting and therefore not bring up the line.

A rudimentary change like the one below hopefully will help

access-list 1 permit 10.0.0.0 0.255.255.255

you may want to bolt it down more than this..

hope I'm not way off track here

Stu

Silver

Re: isdn issues

Carl:

From your config you may have a routing issue... What routing protocol are you using for this network? What does your routing table look like?

New Member

Re: isdn issues

I there, sorry i actually wrote that config in, well the route anyway, it is a class C route /24. also the username and password is in global config, for the remote router, Do I need to put the hostname of this router in as the username ?

Silver

Re: isdn issues

Hey Carl,

you have done a mistake..

under dialer interface dialer remote-name should be remote router name.

ppp chap host name should be the hostname of that router.

interface Dialer1

description CONNECTION TO xxxx

ip unnumbered FastEthernet0

encapsulation ppp

dialer pool 1

dialer remote-name wooldaler1 ....must be remote router name....it is wrong.change it....

dialer idle-timeout 30

dialer string xxxxxxxxxxxx

dialer-group 1

ppp authentication chap

ppp chap hostname wooldaler1 ....must be hostname of the router....

ppp chap password 7 112E3C2B3E312421

Thanks,

satish

New Member

Re: isdn issues

Carl

(sorry put this post in the wrong place on Friday!!)

the standard access-list you have configured looks wrong.

Standard ACL's are based on source address which in your case is the 10 network. Your acl has the destination network in.

Your local traffic will not be classed as interesting and therefore not bring up the line.

A rudimentary change like the one below hopefully will help

access-list 1 permit 10.0.0.0 0.255.255.255

you may want to bolt it down more than this..

HTH

Stu

Purple

Re: isdn issues

Also check your isdn interface with the "show isdn status" command , the interface should show "multiple frames established" , if not then you have a isdn connection problem .Should look like below in a idle state. Also check with your provider we always had to use SPIDS on the BRI interface .

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-5ess

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Activated dsl 0 CCBs = 0

177
Views
0
Helpful
9
Replies