Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISR router config with switching module connecting with dual ios-xr switches & Layer 3 connectivity & routing.

I want to create DHCP pool in router for 3 vlans. can i create it?

i want to set up layer 3 connection with 2 switches uplink to router(switching module installed), what would be the config i give?

also, both ios-xr switches on hsrp with those 3 vlans set upto router gatways - 192.168.2.1, 192.168.3.1, 192.168.4.1- what config i can give each switch & Router interface?

can you advise me best way to make understandable this topology? i attached the design.

thanks,

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hello patel!

Hello patel!

- First create a DHCP pool for every vlan, and you need use DHCP relay to point the three vlans to the interface that have that pool.

For the relay this is the command.

Router(Config)#interface gi0/0/0

Router(config-if)#ip helper-address 192.168.1.1

-Second, in the switches you need to convert the interfaces L2 to interface L3 with the next commands.

switch(config)# interface gi 0/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.168.1.3 255.255.255.0

-Third for the configuration of the hsrp you need select the interface of the switches, and use a ip maybe the 192.168.1.2

SwitchA(config-if)#standby 1 ip 192.168.1.2

SwitchA(config-if)#standby 1 priority 110

SwitchB(config-if)#standby 1 ip 192.168.1.2

SwitchB(config-if)#standby 1 priority 100

And you can use te next command to check the HSRP status.

SwitchA#show standby

GigaEthernet0 – Group 1
Local state is Standby, priority 110
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.776
Virtual IP address is 192.168.1.2 configured
Active router is local
Standby router is 192.168.1.4, priority 110 expires in 9.568
1 state changes, last state change 00:00:22

In this case the switch with higher priority is the active, and in the case of a failure the switch con lower priority it´s going to take the active role.

Greetings!

2 REPLIES
Cisco Employee

Hello patel!

Hello patel!

- First create a DHCP pool for every vlan, and you need use DHCP relay to point the three vlans to the interface that have that pool.

For the relay this is the command.

Router(Config)#interface gi0/0/0

Router(config-if)#ip helper-address 192.168.1.1

-Second, in the switches you need to convert the interfaces L2 to interface L3 with the next commands.

switch(config)# interface gi 0/1

switch(config-if)# no switchport

switch(config-if)# ip address 192.168.1.3 255.255.255.0

-Third for the configuration of the hsrp you need select the interface of the switches, and use a ip maybe the 192.168.1.2

SwitchA(config-if)#standby 1 ip 192.168.1.2

SwitchA(config-if)#standby 1 priority 110

SwitchB(config-if)#standby 1 ip 192.168.1.2

SwitchB(config-if)#standby 1 priority 100

And you can use te next command to check the HSRP status.

SwitchA#show standby

GigaEthernet0 – Group 1
Local state is Standby, priority 110
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.776
Virtual IP address is 192.168.1.2 configured
Active router is local
Standby router is 192.168.1.4, priority 110 expires in 9.568
1 state changes, last state change 00:00:22

In this case the switch with higher priority is the active, and in the case of a failure the switch con lower priority it´s going to take the active role.

Greetings!

New Member

Thanks for reply joselgo2!

Thanks for reply joselgo2!

Done part:-

1) dhcp scope on router which is below:-

ip dhcp pool vlan2
network 192.168.2.0 255.255.255.0
default-GW 192.168.2.1


ip dhcp pool vlan4
network 192.168.4.0 255.255.255.0
default-GW 192.168.4.1

ip dhcp pool vlan8
network 192.168.8.0 255.255.255.0
default-GW 192.168.8.1

-------------------------------------------------------------------------------------------------------------------------

2) SW1# svi interface done:

interface vlan 2
description Voice Network
ip address 192.168.2.2 255.255.255.0
standby 2 ip 192.168.2.10
standby 2 preempt
ip helper-address 192.168.1.1
no shutdown
exit

!
interface vlan 4
description DATA Network
ip address 192.168.4.2 255.255.255.0
standby 5 ip 192.168.4.10
standby 5 preempt
ip helper-address 192.168.1.1
no shutdown
exit
!
interface vlan 8
description WIFI-Guest Network
ip address 192.168.8.2 255.255.255.0
standby 8 ip 192.168.8.10
standby 8 preempt
ip helper-address 192.168.1.1
no shutdown

----------------------------------------------------------------------------------------------------------------------

3)SW3# svi interface done

interface vlan 2
description Voice Network
ip address 192.168.2.3 255.255.255.0
standby 2 ip 192.168.2.10
standby 2 preempt
ip helper-address 192.168.1.1
no shutdown
exit

!
interface vlan 4
description DATA Network
ip address 192.168.4.3 255.255.255.0
standby 5 ip 192.168.4.10
standby 5 preempt
ip helper-address 192.168.1.1
no shutdown
exit
!
interface vlan 8
description WIFI-Guest Network
ip address 192.168.8.3 255.255.255.0
standby 8 ip 192.168.8.10
standby 8 preempt
ip helper-address 192.168.1.1
no shutdown

--------------------------------------------------------------------------------------------------------------------------------

Question1: My Router has L2 4port NIC, What configuration i give to both interface to gi0/1/0(sw1#) and gi0/1/1(sw2#) ?

note: sw1# int gi1/0/49                                                           swi2# int gi1/0/49

    description to Router                                                       description to Router     

no switchport                                                                       no switchport

ip address 192.168.1.2 /24                                  ip address 192.168.1.3/24

6
Views
0
Helpful
2
Replies