Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

issue about local dhcp and a remote PXE server

hi anybody got a idea what i must change

I have a 3560-24 on my location with a local dhcp scope in it, and my PXE server is placed in my campus

in between i have a mpls net (100mbit)

i can see my router/switch is offering a dhcp adresse but my client wouldn't accept it

but when i shut down my local scope and move it to a windows another dhcp server in campus (ip helper on the vlan) it works, but

i will have the ip control on the routerm becourse i would like to use my blade enviromet

my user vlan is a simple setup

interface Vlan10

description *** LAN Data ***

ip address 10.x.x.1

ip helper-address 10.y.y.y (campus ip)

my wan vlan interface Vlan860

description *** ISP MPLS ***

ip address

no ip redirects

ip directed-broadcast


i have tried to change ip forward protocol udp bootpc ...

allso have I tried in the dhcp scope

tried to use option 60/67/68/43

ip dhcp pool DHCP-Data

network 10.x.x.0

default-router 10.x.x.1


dns-server dns1 dns2

option 66 ip 10.y.y.y

option 43 hex 0104.0000.0000.ff

option 60 ascii "PXEClient"

the switch is running


does anybody have a idea

thanks in advance


Re: issue about local dhcp and a remote PXE server

Suggest you to do a packet capture on both working and not-working case to see what the difference is.

Make sure you have those options setup correctly.

Community Member

Re: issue about local dhcp and a remote PXE server

It sounds like we have a similar scenario. Campus based DHCP and a centralized PXE server. We use Microsoft DHCP servers, but the PXE server is the old 3Com application (don't ask why). First I just added the additional ip helper-address for the PXE server, but I never see the DHCP OFFER from PXE. In addition I noticed that when PXE booting, the client would not DHCP, though packet captures show a valid DHCP OFFER. I finally tried adding just option 66 (PXE Server name) and 67 (the name of the bootfile). This worked for one site, will be trying another site soon. I did not need to set option 60, in fact I removed it.

CreatePlease to create content