Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issue regarding nexus topology

Hi guys,

Iam having some trouble managing the nexus topology.

i have 2 nexus 7010

i have 2 nexus 5k

and i have 6 nexus 2k connected to the 5k as a fex fabric.

Now ,

The 5k connected and they are doing vpc connectivity between them (vpc keep-alive,and such).

We want to connect the nexus 7k to the nexus 5k with vpc.

The nexus 7k got vpc between them (vpc keep-alive , and such)

everytime i set up the vpc vs the port-channel the ports shut down and cause the nexus`s to lose connectivity.

here is the configuration regarding this senario:

N7K-1

interface ethernet 1/1

channel-group 50 mode on

!

interface port-channel50

switchport

switchport mode trunk

vpc 50

N7K-2

interface ethernet 1/1

channel-group 50 mode on

!

interface port-channel50

switchport

switchport mode trunk

vpc 50

*** for couple of seconds it stays up and running and suddenly it shuts.

allso i tryed to configure it with spanning-tree port type network but it didnt help.

Somone have idea?

Regards,

3 REPLIES
New Member

Re: Issue regarding nexus topology

is it possible for you to post the sh vpc brief, sh vpc role, and sh vpc peer-keepalive

New Member

Re: Issue regarding nexus topology

Do you have any Active vlan's going across the VPC Ports from the 5K's to the 7K's?

New Member

Issue regarding nexus topology

Hi,

yea i do have active vlan accross the VPC ports.

here is the show commands you asked for;

OTV_L2_VERED-1-VERED-DC-1# show vpc

Legend:

                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 2  

Peer status                       : peer adjacency formed ok     

vPC keep-alive status             : peer is alive                

Configuration consistency status  : success

Per-vlan consistency status       : success                      

Type-2 consistency status         : success

vPC role                          : primary                      

Number of vPCs configured         : 3  

Peer Gateway                      : Disabled

Dual-active excluded VLANs        : -

Graceful Consistency Check        : Enabled

Auto-recovery status              : Disabled

vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans   

--   ----   ------ --------------------------------------------------

1    Po1    up     1,4-7,11,208,300,997,999,2052-2054,2134               

vPC status

----------------------------------------------------------------------

id   Port   Status Consistency Reason                     Active vlans

--   ----   ------ ----------- ------                     ------------

11   Po11   up     success     success                    1,4-7,11,20    

                                                          8,300,997,9    

                                                          99,2052-205    

                                                          4,2134         

12   Po12   up     success     success                    1,4-7,11,20    

                                                          8,300,997,9    

                                                          99,2052-205    

                                                          4,2134         

50   Po50   down*  success     success                    -              

------------------------------------------------------------------------------------

OTV_L2_VERED-1-VERED-DC-1# show vpc peer-keepalive

vPC keep-alive status             : peer is alive                

--Peer is alive for             : (5476) seconds, (283) msec

--Send status                   : Success

--Last send at                  : 2012.09.03 02:48:33 583 ms

--Sent on interface             : Eth3/4

--Receive status                : Success

--Last receive at               : 2012.09.03 02:48:33 693 ms

--Received on interface         : Eth3/4

--Last update from peer         : (0) seconds, (526) msec

vPC Keep-alive parameters

--Destination                   : 10.0.10.2

--Keepalive interval            : 1000 msec

--Keepalive timeout             : 5 seconds

--Keepalive hold timeout        : 3 seconds

--Keepalive vrf                 : default

--Keepalive udp port            : 3200

--Keepalive tos                 : 192

---------------------------------------------------------------------------------------

2nd

--------------------------------------------------------------------------------------

vPC domain id                     : 2  

Peer status                       : peer adjacency formed ok     

vPC keep-alive status             : peer is alive                

Configuration consistency status  : success

Per-vlan consistency status       : success                      

Type-2 consistency status         : success

vPC role                          : secondary                    

Number of vPCs configured         : 3  

Peer Gateway                      : Disabled

Dual-active excluded VLANs        : -

Graceful Consistency Check        : Enabled

Auto-recovery status              : Disabled

vPC Peer-link status

---------------------------------------------------------------------

id   Port   Status Active vlans   

--   ----   ------ --------------------------------------------------

1    Po1    up     1,4-7,11,208,300,997,999,2052-2054,2134               

vPC status

----------------------------------------------------------------------

id   Port   Status Consistency Reason                     Active vlans

--   ----   ------ ----------- ------                     ------------

11   Po11   up     success     success                    1,4-7,11,20    

                                                          8,300,997,9    

                                                          99,2052-205    

                                                          4,2134         

12   Po12   up     success     success                    1,4-7,11,20    

                                                          8,300,997,9    

                                                          99,2052-205    

                                                          4,2134         

50   Po50   down*  success     success                    -          

-----------------------------------------------------------------------------------

OTV_L2_VERED-1-VERED-DC-2# show vpc pee

vPC keep-alive status             : peer is alive                

--Peer is alive for             : (5544) seconds, (301) msec

--Send status                   : Success

--Last send at                  : 2012.09.03 02:49:42 576 ms

--Sent on interface             : Eth3/8

--Receive status                : Success

--Last receive at               : 2012.09.03 02:49:42 342 ms

--Received on interface         : Eth3/8

--Last update from peer         : (0) seconds, (786) msec

vPC Keep-alive parameters

--Destination                   : 10.0.10.1

--Keepalive interval            : 1000 msec

--Keepalive timeout             : 5 seconds

--Keepalive hold timeout        : 3 seconds

--Keepalive vrf                 : default

--Keepalive udp port            : 3200

--Keepalive tos                 : 192

----------------------------------------------------------------------------

On the Nexus 5000

I have just a port-channel configured as;

interface port-channel50

  switchport mode trunk

  spanning-tree port type network

  speed 10000

  storm-control broadcast level 0.50

  storm-control multicast level 0.50

234
Views
0
Helpful
3
Replies
CreatePlease login to create content