Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issue with Cisco 3560 and HP 2605DN

Hi guys,

Appreciate this may not be the most appropriate location for this request/problem but thought I would post regardless as I can't find anything more suitable!

We have several HP 2605DN printers that keep dropping off then re-attaching to the network. The printers drop for about 20 seconds then come back online.

I have tried the usual hardcoding the speed and duplex at both ends, looking into flow control, upgrading the firmware on the printers, etc but am still having no joy.

The issue has been logged with our print company and even escalated to HP who still are yet to find a solution.

I have forwarded them the config of the switch and the dump from 'sh tech-support' but still no joy.

I really want to fix this problem as the errors are filling my syslog server!

As a workaround on one of the printers I have installed a Netgear print server in between the switch and printer and this has resolved the problem. I really dont want to go down this route though for the other devices as it is another device to manage on the network and you are unable to monitor them.

Any ideas? Thanks chaps as always,

Darren

6 REPLIES

Re: Issue with Cisco 3560 and HP 2605DN

Given that the printers drop for ~20 seconds it sounds like STP is reconverging on these ports. I would check to see if the ports themselves are bouncing. If this is the case, I'd check the NIC cards on the printer, or make the ports on the switch portfast as a workaround.

Bronze

Re: Issue with Cisco 3560 and HP 2605DN

Darren,

Can you please let me know the following information:

+ Are the printers all on a separate VLAN to your other traffic? If they are, this will help to isolate any traffic problems

+ When the issue happens - if you do a show interface on that port, do the input and output counters increment? Or just one counter?

+ Can you do a show spanning-tree vlan x detail after the issue happens and check the "last topology change" timestamp to see if it correlates with an outage?

+ Can you pinpoint a specific date/time they occur, or is it totally random? Also, do the printers get their IP via DHCP or statically configured?

Thanks,

Michael

New Member

Re: Issue with Cisco 3560 and HP 2605DN

Hi Michael,

Apologies for the late reply.

To answer your questions

+ the printers sadly are not on a seperate VLAN

+ after clearing the counters here is the result after the interface went up/down

256105: Nov 24 10:13:38.201: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014#

256106: Nov 24 10:13:40.214: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

SW014#sh int g 0/44

GigabitEthernet0/44 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0021.d79e.faac (bia 0021.d79e.faac)

Description: PR128 R2-080

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:01:58

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 4000 bits/sec, 6 packets/sec

22 packets input, 3667 bytes, 0 no buffer

Received 2 broadcasts (2 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 2 multicast, 0 pause input

0 input packets with dribble condition detected

819 packets output, 69007 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

SW014#

+ spanning tree does not correlate with an outage

+ printers are given a static IP address

Regardsm

Darren

New Member

Re: Issue with Cisco 3560 and HP 2605DN

I should also add that this is the running-config of the switchport in question

Current configuration : 274 bytes

!

interface GigabitEthernet0/44

description PR128 R2-080

switchport mode access

switchport port-security

switchport port-security mac-address sticky

switchport port-security mac-address sticky xxx.xxxx.xxxx

spanning-tree portfast

spanning-tree bpduguard enable

end

New Member

Re: Issue with Cisco 3560 and HP 2605DN

These are the intervals at which the switchport is going up and down

SW014(config)#

256155: Nov 24 11:18:13.085: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014(config)#

256156: Nov 24 11:18:15.098: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

SW014(config)#

256157: Nov 24 11:19:38.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014(config)#

256158: Nov 24 11:19:40.796: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

SW014(config)#

256159: Nov 24 11:21:43.840: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014(config)#

256160: Nov 24 11:21:45.853: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

SW014(config)#

256161: Nov 24 11:23:44.787: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014(config)#

256162: Nov 24 11:23:46.792: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

SW014(config)#

256163: Nov 24 11:26:28.642: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down

SW014(config)#

256164: Nov 24 11:26:30.655: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up

New Member

Issue with Cisco 3560 and HP 2605DN

Any followup to this issue?

572
Views
0
Helpful
6
Replies