Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Issue with configuring Port-channel on CISCO3750G-Stacked

Facing a issue with configuring Port-Channel between stacked switches. (Two CISCO3750G)

After configured Port-channel, While both Interfaces are up, I'm unable to ping the host (connected in configured ports).

If we remove any one cable, we are getting connection to host.

(We have tried with reload the switches - No result)

Requesting help regarding this

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Issue with configuring Port-channel on CISCO3750G-Stacked

i wouldn't change it to active if you are not sure if the compter on the other side supports LACP

11 REPLIES
New Member

Issue with configuring Port-channel on CISCO3750G-Stacked

What I understand is that you have a port channel using ports in differents switches of the same stack

what does the "show etherchannel summary" command shows? that can give you an idea of the problem.

Kind regards

VIP Purple

Re: Issue with configuring Port-channel on CISCO3750G-Stacked

Hi Ramesh,

1. Can you please post the config of both port and port channel.
2. Put all result of : sh int port-channel ?
Sh int port1
Sh int port 2

Regards

Sent from Cisco Technical Support iPhone App

Issue with configuring Port-channel on CISCO3750G-Stacked

Yes. Port channel in different switches of the same stack.

SW#sh etherchannel summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 16

Number of aggregators:           16

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------

21     Po21(SU)         -        Gi1/0/2(P)  Gi2/0/2(D)

22     Po22(SU)         -        Gi1/0/1(P)  Gi2/0/1(D)

24     Po24(SU)         -        Gi1/0/4(P)  Gi2/0/4(P)

25     Po25(SU)        LACP      Gi1/0/5(P)  Gi2/0/5(P)

26     Po26(SU)        LACP      Gi1/0/6(P)  Gi2/0/6(P)

27     Po27(SU)        LACP      Gi1/0/7(P)  Gi2/0/7(P)

28     Po28(SU)        LACP      Gi1/0/8(P)  Gi2/0/8(P)

################

interface Port-channel21

switchport access vlan 20

switchport mode access

interface GigabitEthernet2/0/2

switchport access vlan 20

switchport mode access

shutdown                 

speed 1000

duplex full

channel-group 21 mode on

spanning-tree portfast

interface GigabitEthernet1/0/2

switchport access vlan 20

switchport mode access

speed 1000

duplex full

channel-group 21 mode on

spanning-tree portfast

#######################

SICDC_L3_001#sh int gigabitEthernet 1/0/2

GigabitEthernet1/0/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is b414.890c.df82 (bia b414.890c.df82)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:51, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 59000 bits/sec, 37 packets/sec

  5 minute output rate 65000 bits/sec, 35 packets/sec

     2353816 packets input, 362034061 bytes, 0 no buffer

     Received 92183 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     2223667 packets output, 360707963 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

###########################################################

SICDC_L3_001#sh int gigabitEthernet 2/0/2

GigabitEthernet2/0/2 is administratively down, line protocol is down (disabled)

  Hardware is Gigabit Ethernet, address is 0023.0530.8b02 (bia 0023.0530.8b02)

  Description: Portchannel-PLATINUM

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

###########################################################

Note: currently I have manually shutdown the interface Gi2/0/2. For server  availability. If I put 'no sh' command in Gi2/0/2, server connectivity  will be lost.

VIP Purple

Re: Issue with configuring Port-channel on CISCO3750G-Stacked

Hi Ramesh,

Can you try to use channel-group 21 mode active on both ports.

Regards

Sent from Cisco Technical Support iPhone App

New Member

Re: Issue with configuring Port-channel on CISCO3750G-Stacked

i wouldn't change it to active if you are not sure if the compter on the other side supports LACP

Hall of Fame Super Gold

Re: Issue with configuring Port-channel on CISCO3750G-Stacked

interface Port-channel21

switchport access vlan 20

switchport mode access

interface GigabitEthernet2/0/2

switchport access vlan 20

switchport mode access

shutdown

speed 1000

duplex full

channel-group 21 mode on

spanning-tree portfast

interface GigabitEthernet1/0/2

switchport access vlan 20

switchport mode access

speed 1000

duplex full

channel-group 21 mode on

spanning-tree portfast

Maybe this is the reason why Gig 2/0/2 is not joining the Port-Channel 21.

New Member

Issue with configuring Port-channel on CISCO3750G-Stacked

What do you have on the other side of the etherchannel?

Can the computer on the other side of the etherchannel have any problem with the network teaming?

Can the other side supports LACP (better because you will get LACP keep alives)

i will write spanning-tree protfast on the portchannel, the config should be the same from the physical and the portchannel.

Change that and check if the port forwards traffic.

Kind regards

Issue with configuring Port-channel on CISCO3750G-Stacked

Can you post the config from the two ports on the other side of the link?

New Member

Issue with configuring Port-channel on CISCO3750G-Stacked

its the same, two ports with the same config and channel-grup #### mode active (could be active one side and passive in the other or both active, personally I prefer active active)

and then you configure the interface port-channel ###

once you have the port-channel you mustn't deal with physical interfaces, all config must be done on the port-channel interface.

Kind regards

Cisco Employee

Issue with configuring Port-channel on CISCO3750G-Stacked

To confirm its an issue with cros stack port-channel issue, can you move both the interface to the same switch in the stack and bundle it?

Thanks & Regards,
Karthick Murugan
CCIE#39285

Thanks & Regards, Karthick Murugan CCIE#39285

Issue with configuring Port-channel on CISCO3750G-Stacked

Hi All,

This issue is resolved now.

1) I have changed Server's Binding mode to support LACP.

2) Changed the Switch Interfaces configuration with channel-group 22 mode passive

Thank you for support.

Regards,

Ramesh Balachandran

347
Views
0
Helpful
11
Replies