cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1649
Views
0
Helpful
0
Replies

Issue with Dhcp binding static ip to a mac address

AngranYang
Level 1
Level 1

Hi,

I have currently a problem with binding a static IP address to a mac address, my code is like below:

router#show running-config
Building configuration...

Current configuration : 2998 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5

!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 10.1.1.1 10.1.1.54
ip dhcp excluded-address 10.1.1.56 10.1.1.100
!
ip dhcp pool test
   host 10.1.1.55 255.255.255.0
   hardware-address 0015.582d.9377 ieee802
   default-router 10.1.1.1
   dns-server 8.8.8.8
!
ip dhcp pool pool1
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   dns-server 8.8.8.8

!
!
no ip domain lookup
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
!!
!
archive
log config
  hidekeys
!!
!
!

interface FastEthernet0/1
no ip address
ip virtual-reassembly
duplex full
speed 100
!
interface FastEthernet0/1.1
description data
encapsulation dot1Q 1 native
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly

interface FastEthernet0/1.2
description voice
encapsulation dot1Q 2
ip address 10.1.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!        
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface FastEthernet0/0 overload
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.2.0 0.0.0.255
snmp-server community public RO
!
control-plane
!
!
line con 0
exec-timeout 5 30
logging synchronous
!

scheduler allocate 20000 1000
no process cpu extended
no process cpu autoprofile hog
end

However, after I rebooted my computer and the router, I still get a dhcp ip address which is not my desired one (10.1.1.55)..

router#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.1.1.1                -   2893.fe7a.4a71  ARPA   FastEthernet0/1.1

Internet  10.1.1.215              6   0015.582d.9377  ARPA   FastEthernet0/1.1

Please help to point out if I did something wrong... thanks in advance.

Angran

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco