Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issue with Iomega NAS connected to LACP Port-Channel

Hi,

I have configured my Iomega Ix4-200d NAS wth 2 x aggregated 802.3ad nics and the switch appears to be configured as I expect with an LACP port-channel. However, I am unable to ping my NAS devices IP address (192.168.2.100) from any clients on my network, I can ping this from the switch itself.

I have a linksys wireless router that acts as my router and this is running DD-WRT firmware, the router has a static route configure for the vLANs I use. The NAS device is on vLAN 3 and the static route on the router is

Destination LAN Net: 192.168.2.0

SM: 255.255.255.0

DG: 192.168.0.10 - (This is the IP address of my switch)

I have a Cisco 3750G switch running Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEE2 and this my config.

NAS device IP config:

IP: 192.168.2.100

SM: 255.255.255.0

DG: 192.168.2.0

Switch Port Config:

> sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 6
Number of aggregators:           6

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)          -
2      Po2(SD)          -
5      Po5(SD)         PAgP      Gi1/0/12(D)
10     Po10(SD)         -
12     Po12(SD)        LACP      Gi1/0/11(P) Gi1/0/13(P)
20     Po20(SD)         -        Gi1/0/19(D)

>sh run int port-channel 12
Building configuration...

Current configuration : 149 bytes
!
interface Port-channel12
description IOMEGA NAS Gi/1/0/11_Gi1/0/13
switchport access vlan 3
switchport mode access
switchport nonegotiate
end

>sh run int gi1/0/11
Building configuration...

Current configuration : 200 bytes
!
interface GigabitEthernet1/0/11
switchport access vlan 3
switchport mode access
switchport nonegotiate
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable
end

sh run int gi1/0/13
Building configuration...

Current configuration : 226 bytes
!
interface GigabitEthernet1/0/13

switchport access vlan 3
switchport mode access
switchport nonegotiate
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable
end

>sh int port-channel 12

Port-channel12 is up, line protocol is up (connected)

  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

  Description: IOMEGA NAS Gi/1/0/11_Gi1/0/13

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

>sh int gi1/0/11

GigabitEthernet1/0/11 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 001b.0cff.060b (bia 001b.0cff.060b)

  MTU 9000 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

>sh int gi1/0/13

GigabitEthernet1/0/13 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 001b.0cff.060d (bia 001b.0cff.060d)

  Description: esx1 Vlan 10

  MTU 9000 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Can someone please help me out.

Many Thanks

Scott

2 REPLIES
VIP Super Bronze

Issue with Iomega NAS connected to LACP Port-Channel

Hi,

Can you clarify a couple of things?

first:

Destination LAN Net: 192.168.2.0

SM: 255.255.255.0

DG: 192.168.0.10 - (This is the IP address of my switch)

The default gateway is not in the same subnet as the LAN Net

second:

NAS device IP config:

IP: 192.168.2.100

SM: 255.255.255.0

DG: 192.168.2.0

the default gateway cannot be 192.168.2.0

HTH

New Member

Re: Issue with Iomega NAS connected to LACP Port-Channel

Hi Reza,

Thanks for the reply.

Before I begin I need you to know that I am not a network engineer and I did not configure my switch, this was done by a friend of mine who works in networks.

The config works fine if the switchports are joined to to vLAN 3 only and the NAS device runs on a single nic.

If I change the static route to have a DG: 192.168.2.1 I cannot ping 192.168.2.100 even when the nics are in the vLAN 3 only and not configured in an LACP port-channel.

I assume that my friend must have configured my switch to be a router as well if everything works and the DG of my static route is 192.168.0.10.

What information do you need me to provide to troubleshoot this please.

This is the routing info.

GARGRAVE-SW1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

C    192.168.0.0/24 is directly connected, Vlan1
S*   0.0.0.0/0 [1/0] via 192.168.0.1

192.168.0.1 is the ip address of my Linksys - DD-WRT wireless router.

Thanks

Scott

1845
Views
0
Helpful
2
Replies
CreatePlease to create content