Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Issue with Vlan

Hey everyone,

I am new to the forums. I have been a "lurker" for a while as far as getting info from the forums but now I have a question to ask that I couldn't find an answer to. 

I have worked with cisco equipment in one off situations for small businesses and such. However my new job is all cisco as far as routing, switching, wireless etc.

Anyways, as for my question. I was tasked with creating a new SSID on which employees can get on to do various testing with that separates it from the rest of the network.

I started with creating a new VLAN, and this may be where I'm getting hung up. I first did config t, and vlan 640, gave it a name and then hit end. I then did config t, int vlan 640, assigned it the IP of .1 for that subnet, followed by the mask and then I inclueded an IP helper address to point it to our DHCP server. From what I understand I had to do both the vlan 640 and it vlan 640 that way. Maybe I'm wrong about that.  I also did a no shut on both the VLAN and int VLAN after creating them. 

Our setup is such that we have a layer 3 switch/stack(the one I added the vlan to) that connects to the WLC, Servers, and out to our ISP. We use prime, so I have been configuring this new SSID via prime, which I have only worked with on a basic level before. I created the SSID on both our main and backup controller as all others on our network have been created(before I was hired). This SSID is set up to authenticate to a radius server.

 I then created a new interface for this test group as well in prime. I have it set up to point to vlan 640, assigned it to a .2 address, and pointed it to the gateway .1 address(on the layer 3). The trunk between the layer 3 and the WLC is set up to pass all VLANs.

Here's where my issue is. I tested the SSID at the building I am stationed in(also where the layer 3, WLC, etc are stationed) so I could verify it worked before I deployed it to all buildings. When I connect, it asks for my credentials to connect which authenticates as stated above. When I enter my credentials they work as they should and it connects me, but then it sits for a while and i end up with a self assigned IP. I am lost as to where this is not working. It may be my inexperience with Cisco specific devices  at this level that is confusing me, but from what i understand everything looks right as far as I can tell. I would appreciate any information or tips on this. 

Thanks. 

  • LAN Switching and Routing
35
Views
0
Helpful
0
Replies
This widget could not be displayed.