Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issue with voice vlan on 3560G-48PS code 12.2(35)SE5

I have an issue where I will add switchport voice vlan x on to the switchport, the ip phone (polycom talking cdp) will work fine on some occasions but not others. If I reboot switch the vlans will not come up automatically on the voice vlan, however if I add the voice vlan one interface at a time they will work but only after the reboot. If a phone gets disconnected for any reason, it will only pick up the data vlan! Also, it wont seem to work if I use the range command, I have to do it one at a time. As you can see results are not consistent. A sho arp on the mac will tell you it has mapped the mac with the new address on the voice vlan but I wont be able to ping it and it is down.

The config is :-

interface GigabitEthernet0/1

description data/phones

switchport access vlan 2

switchport mode access

switchport voice vlan 4

mls qos vlan-based

spanning-tree portfast

I also have tried clear the arp cache doesnt make any difference.

3 REPLIES
Bronze

Re: Issue with voice vlan on 3560G-48PS code 12.2(35)SE5

I experienced something similar in the past with a 3550 and polycom ip phones and at that time I had to upgrade the firmware of the ip phones to resolve my problem.

New Member

Re: Issue with voice vlan on 3560G-48PS code 12.2(35)SE5

I have checked and the firmware is the same in any other site where it works. They are also using 3560. Although slightly more recent code.

New Member

Re: Issue with voice vlan on 3560G-48PS code 12.2(35)SE5

Does anyone know of any code issues with what I have mentioned?

164
Views
0
Helpful
3
Replies
CreatePlease login to create content