Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Issues getting more than 2 DHCP addresses from switch

I currently have a the following configuration and am unable to get more than 2 DHCP addresses for the devices connected to the Cisco new SG 100-16 Switch.

SCF diagram - 2010 - New Switch - 2.jpg

The AP's have no trouble handing out DHCP to the wireless clients, but we are unable to get the SG 100-16 to be able to do the same thing to wired clients.  It is currently connected to the 2960-8 in port 1.  We can get 2 devices connected without a problem, but the 3rd machine and beyond do not work.  Also, setting up a static IP does not work.  Using a static will not even allow us to ping or tracert back to any devices beyond the SG 100-16.

Any insight or assistance would be greatly appreciated.

7 REPLIES
Purple

Issues getting more than 2 DHCP addresses from switch

Hi,

could you post the sanitized running config from the 2811 and the 2960.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Issues getting more than 2 DHCP addresses from switch

Placing into 2 seperate posts.

2960 Config

switch_ware#sh run
Building configuration...

Current configuration : 6963 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname switch_ware
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$zvIx$32kaNIKa56NdR.2HY9t6B/
!
username admin privilege 15 password 7 010005025A0F0B062F
no aaa new-model
system mtu routing 1500
udld aggressive

ip subnet-zero
!
no ip domain-lookup
!
mls qos map policed-dscp  24 26 46 to 0
mls qos map cos-dscp 0 8 16 24 32 46 46 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
macro global description cisco-global
!
!
!
errdisable recovery cause link-flap
errdisable recovery interval 60
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
class-map match-all AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-all AutoQoS-VoIP-Control-Trust
match ip dscp cs3  af31
!
!
policy-map AutoQoS-Police-CiscoPhone
class AutoQoS-VoIP-RTP-Trust
  set dscp ef
  police 1000000 8000 exceed-action policed-dscp-transmit
class AutoQoS-VoIP-Control-Trust
  set dscp cs3
  police 1000000 8000 exceed-action policed-dscp-transmit
!
!
!
interface FastEthernet0/1
switchport trunk allowed vlan 2,12
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust dscp
macro description cisco-router
auto qos voip trust
spanning-tree portfast trunk
spanning-tree bpduguard enable
!
interface FastEthernet0/2
switchport access vlan 2
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 2
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 2
switchport voice vlan 12
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 2
switchport mode access
switchport voice vlan 12
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/6
switchport access vlan 2
switchport mode access
switchport voice vlan 12
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
switchport voice vlan 12
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
switchport voice vlan 12
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
priority-queue out
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet0/1
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan2
ip address 192.168.2.210 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.2.1
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
logging synchronous
line vty 0 4
login local
line vty 5 15
login
!
end

switch_ware#
switch_ware#sh ver
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(44)SE6, RELEASE SOFTWARE (fc1)

New Member

Issues getting more than 2 DHCP addresses from switch

2811 Config

SCFwarehouse#sh run
Building configuration...

Current configuration : 1527 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SCFwarehouse
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$VX9y$95tprbnwK5OmCuNQE/Lcy0
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.0 192.168.2.127
ip dhcp excluded-address 192.168.2.192 192.168.2.255
!
ip dhcp pool warehouse
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 192.168.1.1
   lease 24
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
username admin privilege 15 password 7 0317580D070B2C4540
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description Wireless_Link_1310
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description Wireless_Link_1410
bandwidth 90000
ip address 10.1.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0/0.2
description Warehouse_Data_Vlan
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0/0.12
description Warehouse_Voice_Vlan
encapsulation dot1Q 12
ip address 192.168.12.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
network 192.168.0.0 0.0.255.255
auto-summary
!
ip forward-protocol nd
!
!
ip http server
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login local
!
scheduler allocate 20000 1000
!
end

New Member

Issues getting more than 2 DHCP addresses from switch

The SG100 is an unmanaged switch, so i doubt that it would be trunk aware. On the 2960 Switch, change the trunk to a access port in vlan 2 see if that helps.

Green

Issues getting more than 2 DHCP addresses from switch

Hi,

Which port on the 2960 connects to the SG100-16

Ports fas0/5, 6 , 7 ,8

All have

switchport port-security maximum 2

This supports only 2 MAC addresses on each of these ports

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Issues getting more than 2 DHCP addresses from switch

The switch is plugged into FastEthernet0/1, which does not appear to have any Port-Security settings on it.

Purple

Issues getting more than 2 DHCP addresses from switch

Hi,

Can you post output of sh interface f0/1 switchport

Regards.

Alain

Don't forget to rate helpful posts.
1183
Views
0
Helpful
7
Replies
CreatePlease to create content