Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

L2 Failover Plan for Point to Point

We have 2 point to point links from 2 different ISP's for the purpose of connecting to our data center from our office. We would like to configure a failover scenario using these two P2P links.

I have been trying with the sTP method but for some reason we could not succeed in this, could be because of the distance.

Please help me to implement a failover P2P conectivity usign this two links.

4 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

L2 Failover Plan for Point to Point

Hello,

Is there a specific reason you are using Layer 2 between sites? If the links are the same bandwidth you could create a port-channel - where both physical links become one logical link, this is ideal because the fail-over is seamless without losing any connectivity and is far superior to spanning-tree.

To configure this:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/1

description Link to ISP1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode active

interface GigabitEthernet1/0/2

description Link to ISP2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode active

This could also be accomplished with IP routing. you can can configure the interfaces as layer 3 ports and setup a routing protocol between sites - Like EIGRP. EIGRP can do equal and unequal cost load balancing or simply route all traffic via one link and automatically route via the other if the primary went down.

If you provide more data I could offer more assitance with design and configuration.

New Member

Re: L2 Failover Plan for Point to Point

Hi!

Correct,

If the 2 links are different speeds the costs would be different and would choose the best path to route traffic (no need for manually configuring costs), the secondary higher cost link would be used only in the event of a failure as OSPF does not support unequal cost load balancing.

Also, depending on the difference in speeds between the 2 links, (lets say P2P Link 1 is 1Gbps and

P2P Link 2 is 100Mbps) - trying to implement unequal cost load balancing may not yeild great results as the

secondary link may account for only 10% of overall bandwidth; it Would be more simple to use the lower bandwidth link as

failover only.

New Member

L2 Failover Plan for Point to Point

I have an idea, is that possible? to configure HSRP between each other (connect two link to two separate switch for switch redundancy in each location) and keep separate traffic in separate VFR, I hope that will work fine, if you going with PortChannel concept you haven’t get switch redundancy, if you want switch redundancy you have to configure either stack or VSS, my suggestion will support both link redundancy and switch redundancy,

Looking forward to hear from you!

Purple

L2 Failover Plan for Point to Point

Hi,

if you are connected to 2 different L2 devices  then you can't do a port-channel( all links in a port-channel must connect to the same devices).

QinQ is only performed in the ISP cloud so I don't think it should be an issue for you.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
16 REPLIES
New Member

L2 Failover Plan for Point to Point

Hello,

Is there a specific reason you are using Layer 2 between sites? If the links are the same bandwidth you could create a port-channel - where both physical links become one logical link, this is ideal because the fail-over is seamless without losing any connectivity and is far superior to spanning-tree.

To configure this:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/1

description Link to ISP1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode active

interface GigabitEthernet1/0/2

description Link to ISP2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode active

This could also be accomplished with IP routing. you can can configure the interfaces as layer 3 ports and setup a routing protocol between sites - Like EIGRP. EIGRP can do equal and unequal cost load balancing or simply route all traffic via one link and automatically route via the other if the primary went down.

If you provide more data I could offer more assitance with design and configuration.

New Member

Re: L2 Failover Plan for Point to Point

What if using Ospf ? And have 2 point to point links of different bandwidths , would you set the failover using cost ?

Sent from Cisco Technical Support iPad App

New Member

Re: L2 Failover Plan for Point to Point

Hi!

Correct,

If the 2 links are different speeds the costs would be different and would choose the best path to route traffic (no need for manually configuring costs), the secondary higher cost link would be used only in the event of a failure as OSPF does not support unequal cost load balancing.

Also, depending on the difference in speeds between the 2 links, (lets say P2P Link 1 is 1Gbps and

P2P Link 2 is 100Mbps) - trying to implement unequal cost load balancing may not yeild great results as the

secondary link may account for only 10% of overall bandwidth; it Would be more simple to use the lower bandwidth link as

failover only.

New Member

L2 Failover Plan for Point to Point

Jason,

Thanks for the detailed explanation.

Actually we had planned for either STP or Port channel as options to achieve the failover connectivity at L2 layer. The initial impression was that the port channel option might not be supported in a scenario where two different ISP's are enagaged. Now we are in a situation where the STP option is not applicable. Do you see any issue in achieving the port channel when we have two separate ISP ? Will the port channel works in case if ISP using Q-in-Q tagging at their side of the link. ?

Purple

L2 Failover Plan for Point to Point

Hi,

if you are connected to 2 different L2 devices  then you can't do a port-channel( all links in a port-channel must connect to the same devices).

QinQ is only performed in the ISP cloud so I don't think it should be an issue for you.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

L2 Failover Plan for Point to Point

I have an idea, is that possible? to configure HSRP between each other (connect two link to two separate switch for switch redundancy in each location) and keep separate traffic in separate VFR, I hope that will work fine, if you going with PortChannel concept you haven’t get switch redundancy, if you want switch redundancy you have to configure either stack or VSS, my suggestion will support both link redundancy and switch redundancy,

Looking forward to hear from you!

New Member

L2 Failover Plan for Point to Point

Alain,

Thanks for your query.

Thats not a problem, we will be connecting the links to the same L2 device at both side.

New Member

L2 Failover Plan for Point to Point

Sharon,

I am new to HSRP on switch, have done with the routers. But again not sure with L2. Does HSRP work on L2 switch ?

Anyway at this moment we are not looking for switch redundancy, we will just accomplish the link redundancy.

New Member

L2 Failover Plan for Point to Point

Hi VAbr

please attach your topology, maybe we can find the solution thx

Regards,

Habibi

Regards, Habibi
New Member

Re: L2 Failover Plan for Point to Point

Yusuf,

The topology is simple. We are planning to have a point to point connectivity to the datacenter from our office. For redundancy purpose we are looking for a failover scenario by using two point to point links.

New Member

Re: L2 Failover Plan for Point to Point

VAbr,

as long as is connection using layer 2, the stp method can be used.

but for some reason we could not succeed in this, could be because of the distance.

you can using fiber optic for the link connection

in my office having connection to data center with L2

Regards,

Habibi

Regards, Habibi
New Member

Re: L2 Failover Plan for Point to Point

HSRP for L3 only, I still have a doubt about, l2/l3 redundancy is you looking about?

New Member

Re: L2 Failover Plan for Point to Point

Sharon,

We are using the L2 switches at both sides of the link.

New Member

Re: L2 Failover Plan for Point to Point

Yusuf,

We are using fiber connectivity only. The distance between the two sites is more than 5 Kms and we are using the shared ring loop network of two ISP's using the Q-in-Q mechanism to reach the other site.

New Member

Re: L2 Failover Plan for Point to Point

By tuning the cost and port priority you can make it bundle, else loop will be occur because of spanning tree issue

New Member

Re: L2 Failover Plan for Point to Point

We have tried the STP option but having issues at ISP side and therefore the link was fluctuating. We are now concentrating on port channel and seeing the possibility of implementing it.I understand from all those folks posted here, it is surely an option that would help us to achieve both load balancing as well as failover.

1092
Views
0
Helpful
16
Replies
CreatePlease to create content