Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L2 trunk and L3 on same switch

Hi..

I am wondering if something is posible to achive. I have two core switcher. They are running L3 between them and L3 down to distro switches.

Then I also have vlan 1000 on both that are both connected to pix?s that are running active/standby. this need to be in same lan so I also need to trunk between the switches. Is this posible?. Do I really need to trunk at all?..

same config on both switches :

interface Port-channel1

description ### Ethercannel til L-3Core#1 ###

ip address 10.0.14.2 255.255.255.0

!

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 1000

switchport mode trunk

switchport nonegotiate

interface Vlan1000

description ### Mot Internett firewall#2 ###

ip address 10.0.1.2 255.255.255.0

I have to use this trunk, right?.. But is this a problem to do on the same switches that I have a L3 between for routing?

Jens

3 REPLIES
New Member

Re: L2 trunk and L3 on same switch

Here is an diagram of how this looks..

Anybody that knows if this is OK to trunk on those switches even if I have a L3 between them?.. I need the uplinks to both pix?s to be in same LAN.

Any other idea`s here?

J

New Member

Re: L2 trunk and L3 on same switch

Yes you can trunk on the the interface, but I have a couple of quetions. You say you have a L3 interface between the switches. Does this mean you have routing rturned on and seperated vlans setup or do you have them setup with Ip address assigne to the interfaces coming off them.

If you want to keep L3 on the switches that is fine. I would set up VLANS and assign Ip addresses to them. Then set up trunks between all the switches. You can then turnk the 1000 vlan without any problem.

New Member

Re: L2 trunk and L3 on same switch

look at my config.. yes, there is a L3 inteface (etherchannel) between the switches that are handeling the routing between all my L3 distr switches... The L2 trunk I need for making a subnet between my firewalls.. (look at the diagram).. there is no other vlan on these switches. Only L3 routed links..

You need to have one subnet between the firewalls, that is why I am asking about the trunk, and how this trunk will work in a failover situation... The vlan 1000 is also in the routing domain (ospf)...

Jensp

246
Views
0
Helpful
3
Replies