Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

L3 - L2 connection

Hi All,

I have one L3 switch 3560 and 2 L2 2950 switches connected to it.

1. Trunk enabled on both sides (L3->L2 & L2->L3)
2. Configured Vlan1 on L2 switches (IP: 10.28.1.2)
3. Default gateway on L2 switches is 10.28.1.1 (one of the Vlan IP in L3 switch)
4. Checked Vlan status in L3 is active and connected one PC directly to L3 switch and its able to ping the GW (10.28.1.1)

But I am not able to ping from L2 switches to the default gateway which is one of the Vlan IP in L3 switch.

Is there anything need to check in the configuration or something?


Thanks & Regards,
Naidu.

11 REPLIES
Hall of Fame Super Blue

Re: L3 - L2 connection

naiduccnp wrote:

Hi All,

I have one L3 switch 3560 and 2 L2 2950 switches connected to it.

1. Trunk enabled on both sides (L3->L2 & L2->L3)
2. Configured Vlan1 on L2 switches (IP: 10.28.1.2)
3. Default gateway on L2 switches is 10.28.1.1 (one of the Vlan IP in L3 switch)
4. Checked Vlan status in L3 is active and connected one PC directly to L3 switch and its able to ping the GW (10.28.1.1)

But I am not able to ping from L2 switches to the default gateway which is one of the Vlan IP in L3 switch.

Is there anything need to check in the configuration or something?


Thanks & Regards,
Naidu.

Naidu

Is 10.28.1.1 assigned to vlan 1 on the L3 switch ?

Can you post the following output from all 3 switches

sh ip int brief

sh int trunk

sh ip route

Jon

Re: L3 - L2 connection

Hi Jon,

Thanks for your quick response.

10.28.1.1 is assigned to Vlan 101 on L3 switch.

sh int trunk & sh ip route not working on L2 switches.

L3 switch output:

Coreswitch - 10.26.6.1#sh ip int bri
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/1        unassigned      YES manual up                    up

FastEthernet0/2        unassigned      YES manual up                    up

FastEthernet0/3        unassigned      YES manual up                    up

FastEthernet0/4        unassigned      YES manual up                    up

FastEthernet0/5        unassigned      YES manual up                    up

FastEthernet0/6        unassigned      YES manual down                  down

FastEthernet0/7        unassigned      YES manual down                  down

FastEthernet0/8        unassigned      YES manual down                  down

FastEthernet0/9        unassigned      YES manual down                  down

FastEthernet0/10       unassigned      YES manual down                  down

FastEthernet0/11       unassigned      YES manual down                  down

FastEthernet0/12       unassigned      YES manual down                  down

FastEthernet0/13       unassigned      YES manual down                  down

FastEthernet0/14       unassigned      YES manual down                  down

FastEthernet0/15       unassigned      YES manual down                  down

FastEthernet0/16       unassigned      YES manual down                  down

FastEthernet0/17       unassigned      YES manual down                  down

FastEthernet0/18       unassigned      YES manual down                  down

FastEthernet0/19       unassigned      YES manual down                  down

FastEthernet0/20       unassigned      YES manual down                  down

FastEthernet0/21       unassigned      YES manual down                  down

FastEthernet0/22       unassigned      YES manual down                  down

FastEthernet0/23       unassigned      YES manual down                  down

FastEthernet0/24       unassigned      YES manual down                  down

GigabitEthernet0/1     unassigned      YES manual up                    up

GigabitEthernet0/2     unassigned      YES manual up                    up

Vlan1                  unassigned      YES manual up                    up

Vlan100                10.26.6.1      YES manual up                    up

Vlan101                10.28.1.1       YES manual up                    up

Vlan999                192.16.19.1   YES manual up                    up

Coreswitch - 10.26.6.1#sh int tru
Coreswitch - 10.26.6.1#sh int trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005
Fa0/2       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1,99,100,101,999
Fa0/2       1,99,100,101,999

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,99,100,101,999
Fa0/2       1,99,100,101,999
Coreswitch - 10.26.6.1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.28.1.0 is directly connected, Vlan101
C       10.26.6.0 is directly connected, Vlan100
C    192.16.19.0/24 is directly connected, Vlan999

1 L2 Switch Output:

Switch-02#sh ip int bri
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/1        unassigned      YES manual up                    up

FastEthernet0/2        unassigned      YES manual up                    up

FastEthernet0/3        unassigned      YES manual down                  down

FastEthernet0/4        unassigned      YES manual down                  down

FastEthernet0/5        unassigned      YES manual down                  down

FastEthernet0/6        unassigned      YES manual down                  down

FastEthernet0/7        unassigned      YES manual down                  down

FastEthernet0/8        unassigned      YES manual down                  down

FastEthernet0/9        unassigned      YES manual down                  down

FastEthernet0/10       unassigned      YES manual down                  down

FastEthernet0/11       unassigned      YES manual down                  down

FastEthernet0/12       unassigned      YES manual down                  down

FastEthernet0/13       unassigned      YES manual down                  down

FastEthernet0/14       unassigned      YES manual down                  down

FastEthernet0/15       unassigned      YES manual down                  down

FastEthernet0/16       unassigned      YES manual down                  down

FastEthernet0/17       unassigned      YES manual down                  down

FastEthernet0/18       unassigned      YES manual down                  down

FastEthernet0/19       unassigned      YES manual down                  down

FastEthernet0/20       unassigned      YES manual down                  down

FastEthernet0/21       unassigned      YES manual down                  down

FastEthernet0/22       unassigned      YES manual down                  down

FastEthernet0/23       unassigned      YES manual down                  down

FastEthernet0/24       unassigned      YES manual down                  down

Vlan1                  10.28.1.3       YES manual up                    up

2 L2 Switch Output:

Switch - 10.28.1.2#sh ip int bri
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/1        unassigned      YES manual up                    up

FastEthernet0/2        unassigned      YES manual up                    up

FastEthernet0/3        unassigned      YES manual down                  down

FastEthernet0/4        unassigned      YES manual down                  down

FastEthernet0/5        unassigned      YES manual down                  down

FastEthernet0/6        unassigned      YES manual down                  down

FastEthernet0/7        unassigned      YES manual down                  down

FastEthernet0/8        unassigned      YES manual down                  down

FastEthernet0/9        unassigned      YES manual down                  down

FastEthernet0/10       unassigned      YES manual down                  down

FastEthernet0/11       unassigned      YES manual down                  down

FastEthernet0/12       unassigned      YES manual down                  down

FastEthernet0/13       unassigned      YES manual down                  down

FastEthernet0/14       unassigned      YES manual down                  down

FastEthernet0/15       unassigned      YES manual down                  down

FastEthernet0/16       unassigned      YES manual down                  down

FastEthernet0/17       unassigned      YES manual down                  down

FastEthernet0/18       unassigned      YES manual down                  down

FastEthernet0/19       unassigned      YES manual down                  down

FastEthernet0/20       unassigned      YES manual down                  down

FastEthernet0/21       unassigned      YES manual down                  down

FastEthernet0/22       unassigned      YES manual down                  down

FastEthernet0/23       unassigned      YES manual down                  down

FastEthernet0/24       unassigned      YES manual down                  down

Vlan1                  10.28.1.2       YES manual up                    up

Thanks & Regards,

Naidu.

Hall of Fame Super Blue

Re: L3 - L2 connection

Naidu

Your problem is that you have used vlan 1 on the switches but vlan 101 on the L3 switch. You can't do this. You either need to

1) on the L3 switch bring up vlan 1 interface and give it the address that is assigned to vlan 101

OR

2) a better solution is to shutdown vlan 1 interface on each L2 switch. Create a vlan 101 L3 interface and give it the IP address you have currently assigned to vlan 1 eg.

2950(config)# int vlan 1

2950(config-if)# no ip address

2950(config-if)# shut

2950(config)# int vlan 101

2950(config-if)# ip address 10.28.1.2 255.255.255.0

2950(config-if)# no shut

Jon

Re: L3 - L2 connection

Hi Jon,

What I through really is the Vlan1 on L2 switches as a Management IP for them.

And one of the Vlan IP on L3 switch used as a DG for L2 switches

Is that wrong?

As you guided, I shutdowned the Vlan1 in L2 switches and creaed one Vlan101 (10.28.1.2) Still I am unable to ping from L2 switches to their DG.

DG is one of the Vlan IP on L3 switch.

Please find the below confing of one of the L2 switch:

Switch - 10.28.1.2#sh run
Building configuration...

Current configuration : 1183 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname "Switch - 10.28.1.2"
!
ip name-server 0.0.0.0
!
!
interface FastEthernet0/1
description connected to Coreswitch-01
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 101
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 10.28.1.2 255.255.255.0
shutdown
!
interface Vlan101
ip address 10.28.1.2 255.255.255.0
!
ip default-gateway 10.28.1.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Thanks & Regards,

Naidu.

Hall of Fame Super Blue

Re: L3 - L2 connection

Naidu

What I through really is the Vlan1 on L2 switches as a Management IP for them.

And one of the Vlan IP on L3 switch used as a DG for L2 switches

Is that wrong?

Yes, it is wrong. The switches send their traffic in vlan 1 but on the L3 switch you have used vlan 101 for the same subnet so this traffic will never get through. If you are using subnet 10.28.1.0/24 then all switches must agree on the vlan used for it.

On your 2950 switch

int vlan 1

no ip address

then can you post

"sh ip interface brief"

"sh interface trunk"

"sh vlan"

from that 2950.

Jon

Re: L3 - L2 connection

Hi Jon,

I removed the IP address for Vlan 1

Please find the below required details and config of one of the switch.

Switch-02#sh run
Building configuration...

Current configuration : 1103 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch-02
!
!
!
interface FastEthernet0/1
description connected to Coreswitch-01
switchport mode trunk
duplex full
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
!
interface Vlan101
ip address 10.28.1.2 255.255.255.0
!
ip default-gateway 10.28.1.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Switch-02#sh ip int bri
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/1        unassigned      YES manual up                    up

FastEthernet0/2        unassigned      YES manual up                    up

FastEthernet0/3        unassigned      YES manual down                  down

FastEthernet0/4        unassigned      YES manual down                  down

FastEthernet0/5        unassigned      YES manual down                  down

FastEthernet0/6        unassigned      YES manual down                  down

FastEthernet0/7        unassigned      YES manual down                  down

FastEthernet0/8        unassigned      YES manual down                  down

FastEthernet0/9        unassigned      YES manual down                  down

FastEthernet0/10       unassigned      YES manual down                  down

FastEthernet0/11       unassigned      YES manual down                  down

FastEthernet0/12       unassigned      YES manual down                  down

FastEthernet0/13       unassigned      YES manual down                  down

FastEthernet0/14       unassigned      YES manual down                  down

FastEthernet0/15       unassigned      YES manual down                  down

FastEthernet0/16       unassigned      YES manual down                  down

FastEthernet0/17       unassigned      YES manual down                  down

FastEthernet0/18       unassigned      YES manual down                  down

FastEthernet0/19       unassigned      YES manual down                  down

FastEthernet0/20       unassigned      YES manual down                  down

FastEthernet0/21       unassigned      YES manual down                  down

FastEthernet0/22       unassigned      YES manual down                  down

FastEthernet0/23       unassigned      YES manual down                  down

FastEthernet0/24       unassigned      YES manual down                  down

Vlan1                  unassigned      YES manual up                    up

Vlan101                10.28.1.2       YES manual up                    up

Switch-02#sh interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1,101

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1

Switch-02#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
101  VLAN0101                         active    Fa0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
101  enet  100101     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    -        0      0  
1004 fdnet 101004     1500  -      -      -        ieee -        0      0  
1005 trnet 101005     1500  -      -      -        ibm  -        0      0 

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Thanks & Regards,

Naidu.

Hall of Fame Super Blue

Re: L3 - L2 connection

Naidu

Can you still not ping the gateway 10.28.1.1 ?

Jon

Re: L3 - L2 connection

From your output

Switch-02#sh interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1,101

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1

Did you create vlan 101 on the L3 switch? Is it allowed on the other side?

I've first to review your config. Maybe it's in there

Can you post a show run int fasx/x of the connected interface at the l3 switch?

Hall of Fame Super Blue

Re: L3 - L2 connection

davy.timmermans wrote:

From your output

Switch-02#sh interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1,101

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1

Did you create vlan 101 on the L3 switch? Is it allowed on the other side?

I've first to review your config. Maybe it's in there

Can you post a show run int fasx/x of the connected interface at the l3 switch?

Davy

Good spot, i missed that

Jon

Re: L3 - L2 connection

Hi Jon,

Yes I have created vlan 101 in L3 switch and in L2 switch.

Please find the below running config of L2 switch:

Switch-02#sh run
Building configuration...

Current configuration : 1120 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch-02
!
!
!
interface FastEthernet0/1
description Connected to L3
switchport mode trunk
duplex full
!
interface FastEthernet0/2
switchport access vlan 101
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
!
interface Vlan101
ip address 10.28.1.2 255.255.255.0
!
ip default-gateway 10.28.1.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Please find the below vlan info in L3 switch and the interface config which was connected to L2 switch:

interface FastEthernet0/2
description Connected to Switch-02
switchport mode trunk
duplex full

Coreswitch - 10.16.6.1#sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
99   VLAN0099                         active   
100  VLAN0100                         active    Fa0/4
101  VLAN0101                         active    Fa0/3
999  VLAN0999                         active    Fa0/5, Gig0/1, Gig0/2
1002 fddi-default                     active   
1003 token-ring-default               active   
1004 fddinet-default                  active   
1005 trnet-default                    active  

Regards,

Naidu.

Re: L3 - L2 connection

Hi Jon,

Any findings on my previous post. I am eagerly waiting for the solution.

Regards,

Naidu.

735
Views
5
Helpful
11
Replies