Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L3 subinterfaces between two switches

Hello,

I have two C4506 switches and I would like to create two L3 links between them by using only one physical link.

I will then assign each L3 link to a different VRF.

I think I have two choices but I'm not sure however that the second one is possible...

Does someone have an idea about this?

---------------

1st choice: creating two VLANs and two SVIs on each switch

interface Vlan10

ip address 10.10.10.1 255.255.255.252

ip vrf forwarding vrf1

interface Vlan20

ip address 10.10.10.5 255.255.255..252

ip vrf forwarding vrf2

interface GigabitEthernet0/0

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20

2nd choice: using dot1q subinterfaces

interface GigabitEthernet0/0

no switchport

interface GigabitEthernet0/0.10

encapsulation dot1q 10

ip address 10.10.10.1 255.255.255.252

ip vrf forwarding vrf1

interface GigabitEthernet0/0.20

encapsulation dot1q 20

ip address 10.10.10.5 255.255.255.252

ip vrf forwarding vrf2

1 REPLY
VIP Super Bronze

L3 subinterfaces between two switches

Hi,

You can only use your 1st choice, as the 4500 series switches don't support sub-interfaces.

BTW, your config looks good:

A Catalyst 4500 series switch does not support subinterfaces or the encapsulation keyword on Layer 3 Fast Ethernet or Gigabit Ethernet interfaces.

for more info refer to the config guide:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/37sg/configuration/guides/l3_int.html

HTH

3296
Views
5
Helpful
1
Replies