Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LACP channel strangeness?

Yesterday I setup my first LACP(mode active) etherchannels to a Netapp NAS. Usually I am a "mode on" type of guy. After I got the channels and ports configured the devices can ping and pass traffic fine, however a "show ip int br" shows the ports and channels as "down down". and the "show interface xx" shows "not connect" on the interfaces. But they pass traffic. What gives? Is this normal?

Here is an example of one of the ports and the channel it belongs to, these are on a 6500 with VSS.

interface GigabitEthernet1/8/44

description DC-NetApp-CIFS-2

switchport

switchport access vlan 682

switchport mode access

flowcontrol receive on

flowcontrol send on

spanning-tree portfast

channel-group 51 mode active

interface Port-channel51

description DC-NetApp-CIFS-2

switchport

switchport access vlan 682

switchport mode access

flowcontrol receive on

flowcontrol send on

spanning-tree portfast

This may be completely normal, I admit I dont have a lot of experience with LACP etherchannels.

thanks in advance

e-

1 ACCEPTED SOLUTION

Accepted Solutions

Re: LACP channel strangeness?

Okay, so if I'm looking at your config correctly, the OP that you posted has channel-group 51, but the config that you posted has channel-group 50.

You may want to change your group to passive to see if it will come up. The netapp may send lacp packets to try to negotiate the etherchannel.

You can also, although I don't think it makes a difference, specify the protocol:

channel-protocol lacp

Putting your switchport's etherchannel in passive tells the switch to use lacp for that connection.

Oh, and if the netapp doesn't support lacp (which most non-cisco devices do), then you'll have to switch it to pagp. (I strongly doubt this is the case though.)

HTH,

John

HTH, John *** Please rate all useful posts ***
10 REPLIES

Re: LACP channel strangeness?

as long show down down

do to the port channel and do no shut

try on the physicl interfaces as well

no shut

good lcul

HTH

Purple

Re: LACP channel strangeness?

To be honest they can't be passing traffic if the interfaces and the port channel shows down/down . Not connect means there isn't even a layer 1 connection . Possible you may be looking at the wrong ports ?? Not sure what g1/8/44 is . Are these 3750's stacks ? Possible you have them connected into different ports than you think . You would have to see how they wired together in the stack . If it comes down to tracing find out what the mac of the device then do a "show mac address | incl .

New Member

Re: LACP channel strangeness?

Ok so I have attached a detailed description of what I am seeing, I'll walk through it.

This is on a 6500 with VSS

The two ports involved in the channel are 1/8/43 and 2/8/43

In the first screen it shows that VLAN682 is up with the IP of 10.90.36.1, and Port-channel 50 is down down.

Next the show int po50, shows that its down and notconnect

Next is a show etherchannel sum, so we can see that 1/8/43 and 2/8/43 are in the portchannel 50. Their status is stand alone.

Next are the show conf's for those two interfaces showing they are in channel-group 50 with mode active (lacp) and they are part of vlan682.

I know from working with the Netapp SE that he has two IP's in that range 10.90.36.2 and 3. I can ping both of these IP's from the 6500, which you think would imply that the port-channel and associated ports would show "up up". But they dont.

I'm confused.

e-

****EDIT: forgot to mention, link lights on the 6500 are green. Not sure if that matters. Also show lacp internal shows the following ( attached ).

New Member

Re: LACP channel strangeness?

show lacp internal

Re: LACP channel strangeness?

Okay, so if I'm looking at your config correctly, the OP that you posted has channel-group 51, but the config that you posted has channel-group 50.

You may want to change your group to passive to see if it will come up. The netapp may send lacp packets to try to negotiate the etherchannel.

You can also, although I don't think it makes a difference, specify the protocol:

channel-protocol lacp

Putting your switchport's etherchannel in passive tells the switch to use lacp for that connection.

Oh, and if the netapp doesn't support lacp (which most non-cisco devices do), then you'll have to switch it to pagp. (I strongly doubt this is the case though.)

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: LACP channel strangeness?

Ok I tried those things but didnt seem to have any luck, also tried the pagp but honestly didnt expect that to work either(and it didnt). So I told the Netapp people they get static etherchannels. Switched all the channel-groups to "mode on" and now everything shows "up up".

The only explination I can think of as to why they were able to ping is that the interfaces were never bundled and they were all on one link.

Thanks for the help, sorry for the 50/51 confusion.

e-

Purple

Re: LACP channel strangeness?

I would check the channels again if you forced them on as they will show up no matter what when you force them on and yet they might not be working. Do a show etherchannel summ . Do they have a "P" next to them now ?

New Member

Re: LACP channel strangeness?

Yes they do, looks peachy.

thanks

Eric(P)

Re: LACP channel strangeness?

how did you solved it please ?

New Member

Re: LACP channel strangeness?

NetApp devices support LACP with the channel-group mode active command only. The corresponding NetApp config would be vif create lacp (name) -b ip e0a e0b e0c e0d

NOTE: I am using 4 interfaces but you use the number you intend.

If you don't want to use LACP then NetApp supports static etherchannels which would use the channel-group mode on command. This would require the equivalent Netapp config of vif create multi (name) -b ip e0a e0b e0c e0d.

This is well documented from both a Cisco and NetApp perspective on NetApp's website at the following link.

http://communities.netapp.com/blogs/ethernetstorageguy

1609
Views
5
Helpful
10
Replies