Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

LACP Configuration

Hi,

We have Dell M6220 blade server that server is connected to cisco 3750 switch. I am trying to configure LACP in 3750 for two port which are connected to Dell M6220 server switch. The channel-group 2 mode  active commande is not taking then its showing the error protocol mismatch and if i run show int port-channel 2 command the port channel status is showing down. The Dell server switch is on simple mode. below i have attached the required details. Please help me on this.

Switch#show int port-channel 2

Port-channel2 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Switch#

interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/21

description ****Connected to Dell Blade****

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-group 2 mode desirable

interface GigabitEthernet1/0/38

description ****Connected to Dell Blade****

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

channel-group 2 mode desirable

Switch(config)#int gi1/0/21

Switch(config-if)#no channel-group 2 mode desirable

Switch(config-if)#channel-protocol lacp

Switch(config-if)#channel-group 2 mode active

Command rejected (Channel protocol mismatch for interface Gi1/0/21 in group 2): the interface can not be added to the channel group

Switch(config-if)#

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: LACP Configuration

you have to configure both members at the same time. With your config the first member stays on PAgP, but the second member tries to use LACP.

Switch(config)#interface range gig 1/0/21, gig 1/0/38

Switch(config-if-range)#no channel-group 2 mode desirable

Switch(config-if-range)#channel-protocol lacp

Switch(config-if-range)#channel-group 2 mode active

2 REPLIES
VIP Purple

Re: LACP Configuration

you have to configure both members at the same time. With your config the first member stays on PAgP, but the second member tries to use LACP.

Switch(config)#interface range gig 1/0/21, gig 1/0/38

Switch(config-if-range)#no channel-group 2 mode desirable

Switch(config-if-range)#channel-protocol lacp

Switch(config-if-range)#channel-group 2 mode active

LACP Configuration

Thank you  karsten. it's working fine.

Karthik

2869
Views
0
Helpful
2
Replies
CreatePlease to create content