Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LACP Ethert-Channel and HP Network TEAM

I have a HP Server that I want to setup to use an etherchannel for 2Gbs bandwidth. I keep having the same problem, one of the NIC's will only negotiate 100mbs/full and the other will negotiate the full 1000mbs/full. I have had this issue on 2 HP servers now and I cant seem to figure out the problem. I have followed this guide with no success. Also if I try to statically set the speed/duplex it acts like the network cable is disconnected.

javascript:newWin('http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml')

Here is my configuration and some show information....

rmprodsw01#sh run int g2/27

Building configuration...

Current configuration : 203 bytes

!

interface GigabitEthernet2/27

description RMSTAGEBACKUP01-A-Po2

switchport

switchport access vlan 51

switchport mode access

no ip address

spanning-tree portfast

channel-group 2 mode active

end

rmprodsw01#sh run int g2/39

Building configuration...

Current configuration : 203 bytes

!

interface GigabitEthernet2/39

description RMSTAGEBACKUP01-B-Po2

switchport

switchport access vlan 51

switchport mode access

no ip address

spanning-tree portfast

channel-group 2 mode active

end

rmprodsw01#sh run int po2

Building configuration...

Current configuration : 101 bytes

!

interface Port-channel2

description PORT_CHANNEL_TO_STAGEBACKUP01

switchport

no ip address

end

rmprodsw01#sh int status | inc STAGEBACK

Gi2/27 RMSTAGEBACKUP01-A- connected 51 a-full a-100 10/100/1000BaseT

Gi2/39 RMSTAGEBACKUP01-B- connected 51 a-full a-1000 10/100/1000BaseT

rmprodsw01#sh ether summary

Flags: D - down P - bundled in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

M - not in use, minimum links not met

u - unsuitable for bundling

w - waiting to be aggregated

Number of channel-groups in use: 4

Number of aggregators: 5

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

2 Po2(SD) LACP Gi2/27(I)

2 Po2A(SU) LACP Gi2/39(P)

4 REPLIES

Re: LACP Ethert-Channel and HP Network TEAM

HP/Broadcom NICs and Cisco switches don't negotiate well. Hard set the switch ports and the NIC's to 100/full.

Hope that helps.

Purple

Re: LACP Ethert-Channel and HP Network TEAM

I would check your cable . Gigabit speed needs all 8 wires to be in good in order to run gigabit so if its negotiating 100 meg then maybe 1 or more wires are faulty in your cable path .

New Member

Re: LACP Ethert-Channel and HP Network TEAM

Have you tried to remove LACP and just use mode on ? and see what happens?

I have seen problems like this before and doing that worked out.

channel-group 2 mode on

Perhaps, the HP server isn't being able to negotiate with the switch using LACP as it should.

New Member

Re: LACP Ethert-Channel and HP Network TEAM

Thanks for all your replies, I did try to hard set the speed/duplex but that only resulted in the network card thinking the cable was disconnected. I replaced all the network cables and tried "channel-group 2 mode on", all with no resolution. I upgraded all the firmware on the card and all drivers, and still nothing. At this point Im thinking this is a hardware problem (even though it seems weird the card would just stop working at 1000Mbs). I tried the same configuration on another HP server and it worked just fine, and I know this working on this particular server in the past.

1603
Views
0
Helpful
4
Replies