Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LACP fast updates on Cisco 3750s

I've got LACP-enabled port-channels between a Cisco 3750 stack and a few different switches (some Cisco 3750s and some Juniper EX2200s).  The Ciscos are all sending slow LACP updates, the Junipers are sending fast LACP updates (but the Cisco they connect with is responding with slow LACP updates).

I have a couple of questions:

1) what are the pros and cons of slow vs fast updates?  my research has led me to the conclusion that fast updates are better for network resiliency as long as you have plenty of bandwidth overhead (which I do at the moment).  is there anything to add to this conclusion?

2) is there any way to configure the Cisco 3750s for fast updates?

Thanks in advance for any advice!

Everyone's tags (4)
5 REPLIES
New Member

LACP fast updates on Cisco 3750s

Hi Mate,

AFAIK cisco does support fast LACP packets. you might want issue show lacp internal.

Also if its feasible a debug.

Thanks,

vibs

ccie-dash.blogspot.com

New Member

LACP fast updates on Cisco 3750s

Here's all the relevant configuration information.  Notice how the 'show lacp internal' shows the switch requesting slow LACP updates and the 'show lacp neighbor' shows the neighbor switch requesting fast updates.  I haven't been able to find any way to set the Cisco switch to request fast LACP updates.

switch#show run int gi1/0/9

Building configuration...

Current configuration : 184 bytes

!

interface GigabitEthernet1/0/9

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 10 mode active

end

switch#show run int po10

Building configuration...

Current configuration : 166 bytes

!

interface Port-channel10

switchport trunk encapsulation dot1q

switchport mode trunk

end

switch#show lacp 10 int

switch#show lacp 10 internal

Flags:  S - Device is requesting Slow LACPDUs

        F - Device is requesting Fast LACPDUs

        A - Device is in Active mode       P - Device is in Passive mode

Channel group 10

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi1/0/9   SA      bndl      32768         0xA       0xA     0x10A       0x3D

Gi2/0/9   SA      bndl      32768         0xA       0xA     0x20A       0x3D

switch#show lacp 10 nei

switch#show lacp 10 neighbor

Flags:  S - Device is requesting Slow LACPDUs

        F - Device is requesting Fast LACPDUs

        A - Device is in Active mode       P - Device is in Passive mode

Channel group 10 neighbors

Partner's information:

                  LACP port                        Admin  Oper   Port    Port

Port      Flags   Priority  Dev ID          Age    key    Key    Number  State

Gi1/0/9   FA      127       a8d0.e5bc.d780   7s    0x0    0x1    0x1     0x3F

Gi2/0/9   FA      127       a8d0.e5bc.d780   7s    0x0    0x1    0x2     0x3F

New Member

LACP fast updates on Cisco 3750s

Cool

please use the following

conf t

interface GigabitEthernet1/0/9

lacp rate fast

end

Hope this helps

New Member

I realize this thread is 4

I realize this thread is 4 years old, however I had this same issue, and hope this information will help somebody else.

The 3750 only supports slow LACP. The rate for this is every 30 seconds.

The 6500 series will support a "Fast" or 1 second LACP rate.

Bronze

Fyi the "lacp rate fast"

FYI "lacp rate fast" is supported on the 15.2(4)E software train:

Switch#sh ver
Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 15.2(4)E4, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2017 by Cisco Systems, Inc.
Compiled Wed 05-Apr-17 04:22 by prod_rel_team
Switch#sh run int Gi1/1/1
interface GigabitEthernet1/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 load-interval 30
 mls qos trust dscp
 lacp rate fast
 channel-group 1 mode active

"lacp rate fast" in Catalyst 3750?

LACP with Palo Alto Firewalls

9245
Views
5
Helpful
5
Replies