Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LACP issue when PAgP enabled on a 3750-X Stack

Dear all,

1. Description

We have a Stack of 3x c3750-X with 12.2(58)SE IOS version. We use port-channels in mode PAgP (same switch, known limitation) and mode ON (on different switches, MEC).

We use this Stack for Dual-active detection of a 4500x VSS with an ePAgP port-channel.

Additionnally, we also use 2x Port-channels in mode ON.

No problem so far...

2. Issue with LACP

Finally, I wanted to configure a port-channel in LACP for server dual-attachment. But obviously, LACP mode is not accepted by IOS while this limitation is actually involved by PAgP (known limitation on same single switch). The error message is related to PAgP while configuring LACP !?

Personnally I am pretty sure it is a bug, can you confirm ? Is it a known issue? any known workaround?

3. Error Messages

Please find the error messages related to LACP Port-channel creation

---------------------------------------------------------------------------------------------------------------------------------------

SW012(config)#int range gi 2/0/1, gi 3/0/1

SW012(config-if-range)#channel-group 10 mode ?

  active     Enable LACP unconditionally

  auto       Enable PAgP only if a PAgP device is detected

  desirable  Enable PAgP unconditionally

  on         Enable Etherchannel only

  passive    Enable LACP only if a LACP device is detected

SW012(config-if-range)#channel-group 10 mode active ?

  <cr>

W012(config-if-range)#channel-group 10 mode active

%With PAgP enabled, all ports in the Channel should belong to the same switch

Command rejected (Port-channel10, Gi2/0/1): Invalid etherchnl mode

SW012(config-if-range)#int gi 2/0/1

SW012(config-if)#channel-group 10 mode active

%With PAgP enabled, all ports in the Channel should belong to the same switch

Command rejected (Port-channel10, Gi2/0/1): Invalid etherchnl mode

SW012(config-if)#int gi 3/0/1

SW012(config-if)#channel-group 10 mode active

%With PAgP enabled, all ports in the Channel should belong to the same switch

Command rejected (Port-channel10, Gi3/0/1): Invalid etherchnl mode

---------------------------------------------------------------------------------------------------------------------------------------

Let me know

Laurent

Everyone's tags (3)
3 REPLIES
New Member

Re: LACP issue when PAgP enabled on a 3750-X Stack

what does your switch stack look like? Im just curious.

Re: LACP issue when PAgP enabled on a 3750-X Stack

Hello Laurent

Could you try the following:

1.

no interface port-channel 10

2.

int gi 2/0/1

channel-group 10 mode active

int gi 3/0/1

channel-group 10 mode active

- Gabriel

New Member

Re: LACP issue when PAgP enabled on a 3750-X Stack

Only with LACP can you bundle network ports from different physical switches in a stack configuration.  I would follow Gabriel's advice and remove the interfaces from the port-channel they are in currently and then add them back as LACP.  Be sure that at least one side is using active mode for negotiation to properly take place.  If the other side is not using a form of LACP then I don't think it will work but most non-Cisco switches should support LACP configuration since it's non-proprietary.

1243
Views
0
Helpful
3
Replies