Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LACP with Sun CP3140 Switch (Port-Channel won't come up)

Group,

I am trying to setup a Port-Channel between Cisco 7600 and Sun CT900 which has CP3140 switch, but it is not working.

It seems that Sun switch is sending "Fast" LACPDUs while Cisco 7600 is sending "Slow" LACPDUs (as shown below).

Is there a way to force Cisco 7600 to send "fast" LACPDUs.

C7606-1#show lacp 11 neighbor

Flags: S - Device is requesting Slow LACPDUs

F - Device is requesting Fast LACPDUs

A - Device is in Active mode P - Device is in Passive mode

Channel group 11 neighbors

Partner's information:

Partner Partner LACP Partner Partner Partner Partner Partner

Port Flags State Port Priority Admin Key Oper Key Port Number Port State

Gi3/2 FA - 128 0x0 0x4A 0x12 0x77

Gi3/4 FA - 128 0x0 0x4A 0x14 0x77

C7606-1#show lacp 11 internal

Flags: S - Device is requesting Slow LACPDUs

F - Device is requesting Fast LACPDUs

A - Device is in Active mode P - Device is in Passive mode

Channel group 11

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi3/2 SA - 32768 0xB 0xB 0x302 0x5

Gi3/4 SA - 32768 0xB 0xB 0x304 0x5

C7606-1#

Configuration on Cisco 7600 is:

-------------------------------

!

interface Port-channel11

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 1220

switchport trunk allowed vlan 1220,1240

switchport mode trunk

no ip address

end

!

interface GigabitEthernet3/2

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 1220

switchport trunk allowed vlan 1220,1240

switchport mode trunk

no ip address

speed 1000

duplex full

channel-protocol lacp

channel-group 11 mode active

end

!

interface GigabitEthernet3/4

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 1220

switchport trunk allowed vlan 1220,1240

switchport mode trunk

no ip address

speed 1000

duplex full

channel-protocol lacp

channel-group 11 mode active

end

1 REPLY
Bronze

Re: LACP with Sun CP3140 Switch (Port-Channel won't come up)

On 7600 with version 12.2(18)SXE1, once the port-channel is applied to the interface, the links need to be shut and no shut in order to bring the port channel up on the links or interface. And LACP with Sun CP3140 Switch is not possible.

567
Views
0
Helpful
1
Replies