Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LAG/Trunk Configuration between 3560 and SG300-24P

A client of ours has installed an SG300-24P switch and would like to setup a LAG between the SG300 and the 3560 switch we manage for them. They would like the LAG to also pass the voice and two data VLANs currently in use; 5, 10, and 100 respectively. I configured the two ports as an Etherchannel with trunking on the logical port, but no luck. I reconfigured as follows:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

end

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

end

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

I see no output when I do show lacp nei. At this point the client is looking to use for the configurations to use as he does not know how to setup the SG300 and it is a switch I have never dealt with. I have found some configurations that I believe  would allow a single VLAN across, but nothing I believe will allow the LAG to pass all the VLAN's.

I cannot find any documentation about this type of setup when searching the Cisco and Netpro forums. Any help woudl be appreicated.

7 REPLIES
VIP Super Bronze

LAG/Trunk Configuration between 3560 and SG300-24P

Your 3560 config looks correct.

I have never used SG300 switches, but according to the data sheet they do support vlan trunking and LACP

Support for IEEE 802.3ad Link Aggregation Control Protocol (LACP)

• Up to 8 groups

• Up to 8 ports per group with 16 candidate ports for each (dynamic) 802.3ad link aggregation

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps10898/data_sheet_c78-610061.html

Can you post the config from SG300?

HTH

Green

LAG/Trunk Configuration between 3560 and SG300-24P

Hi Erik,

The SG300 supports 2 commands for the lag, channel-group mode on or auto. On is the static lag, auto is LACP.

I suspect there is probably spanning tree issue using the active command.

I would recommend to configure the 3560 using a static lag then run the channel-group 1 mode on - on the SX300 switch, should work fine after.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

LAG/Trunk Configuration between 3560 and SG300-24P

I am not familiar with the SG300 setup myself and do not have access to the switch. I do not remember the SG300 having an option to trunk and use dot1q encapsulation. It seems the settings were tagged or untagged VLAN's. I take this as when I am setting up the trunk on the Po1 interface I should use the allowed VLANs option instead of trunking everything?

VIP Purple

LAG/Trunk Configuration between 3560 and SG300-24P

Hi Erik,

Two types of LAGs are supported:

Static—A LAG is static if the LACP (Link Aggregation Control Protocol) is

disabled. You configure a static LAG with a group of ports that are always

active members of the LAG.

  Dynamic—A LAG is dynamic if it is LACP-enabled. You define a group of

ports as candidate ports of a dynamic LAG. The LACP determines which

candidate ports from the LAG are active member ports. The non-active

member ports are standby ports ready to replace any failing active member

ports

You need to be careful when making the channel connections between sg300 and 3560  however. Make sure to run the exact same commands otherwise spanning-tree will loop the switch and likely crash the SG 300.

A simple channel-group mode on command on both switch will work fine.  Do not mess with any LACP setting. Also notice, if you're having issues with the SG 300 getting loops it may be because of the auto edge port.

If you do a show spanning-tree active, check to see if port fast negotiated on the links within the channel group. If it has, you need to go to the interfaces and do a no spanning-tree portfast.

This should resolve any problems.

Regards

Please rate if it helps.

Green

LAG/Trunk Configuration between 3560 and SG300-24P

Erik, the small business switches support dot1q ports. It is "general port". The difference between a trunk port and general port is that a general port may have ingress filtering disabled. Trunk port may not. A trunk port can act in any way you, if you want all vlan tag to the port, including the default vlan, you can use a default vlan tagged command.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

LAG/Trunk Configuration between 3560 and SG300-24P

I've come to find out there are two transparent wireless bridges involved in this setup. I see both ports join the LAG on the 3560, then it immediately crashes. It runs just fine when one of the ports is up so I am assuming it is the STP issue. I disabled the SG300 ports as edge ports as suggested, but that made no difference. Any thoughts?

Green

Re: LAG/Trunk Configuration between 3560 and SG300-24P

Hi Erik, there won't be a resolution for this. A wireless bridge is like a wireless ethernet cable. If you have the bridge wired to the network and a link between the switches, it makes a network loop.

You have a some options;

First option is to disable spanning tree and live with a broadcast storm - highly not recommended

Second option, if you have some sort of VLAN allocation, you may be able to use MSTP in conjunction with the PVST+ options and try to structure your VLANs to separate the spanning tree instances to avoid the network looping

Lastly, if it is fine working with 1 link but not 2 within the lag, it means you have a setting mismatch on the lag. The configuration for the lag has already been answered above.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
5003
Views
5
Helpful
7
Replies