Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LAN issues with Vlans

Hello All,

I've configured a Cisco Catalyst 3550 L3 Switch with the below configs. We have a router that is setup by our ISP with is 192.168.1.1 and the L3 switch is set to 192.168.1.2 /24. When I put users in vlans, they will have access with no issue and can access all devices, but every thursday morning, users in the 2 vlans 10 & 11 loose their ip address, and get a 169.x.x.x ip address. I perform ipconfig /release and renew, and still no luck of getting the ip address to renew its lease. In order to receive another leased address i have to physically reboot the switch. Can someone help me with this to where I don't have to reboot my switch, and to where the computers will not loose their lease.

Regards,

no aaa new-model

ip subnet-zero

ip routing

ip dhcp excluded-address 192.168.10.1 192.168.10.20

ip dhcp excluded-address 192.168.11.1 192.168.11.20

!

ip dhcp pool SALES

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   dns-server 192.168.1.206

!

ip dhcp pool CORPORATE

   network 192.168.11.0 255.255.255.0

   default-router 192.168.11.1

   dns-server 192.168.1.206

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan11

ip address 192.168.11.1 255.255.255.0

ip default-gateway 192.168.1.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip http server

!

!

control-plane

!

!

line con 0

line vty 0 4

no login

line vty 5 15

no login

!

end

  • LAN Switching and Routing
5 REPLIES
VIP Purple

LAN issues with Vlans

Hi ,

This address range(169.xxx.xxx.xxx) is due to a built in function of windows called automatic private IP address(APIPA). When your computer is configured to get an IP address from a DHCP server, but is unable to find a DHCP server the APIPA service will assign itself a 169.x.x.x IP address, and checks for a DHCP server periodically.

Can you add this command under your both dhcp pool and try:

ip dhcp pool SALES

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   dns-server 192.168.1.206

   lease infinite


ip dhcp pool CORPORATE

   network 192.168.11.0 255.255.255.0

   default-router 192.168.11.1

   dns-server 192.168.1.206

lease infinite

Hope it helps

Reagrds

LAN issues with Vlans

What Sandeep suggests will help the clients keep the address that they do receive, and their lease won't have an expiration time assigned to them. This would keep the host from requesting another address. The other suggestion that I have is maybe update the IOS if you're a few versions lower than the latest.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

LAN issues with Vlans

Hello John,

thanks for the reply I'll update the to the latest IOS.

Regards,

New Member

LAN issues with Vlans

Thankyou sandeepchoudhary21,

I'll try that, also, I have another question, on one of the ports in our company, I have on the other end a 5 port d-link switch that has 2 computers and a network printer attached to it, which goes into fa0/36 on the cisco switch. when I put that port into a vlan, I'm able to access networking components and print but we also have a camera system that we access via, the network which is 192.168.1.20, and I cannot access the cameras when I'm in another vlan other than vlan 1. its strange because I don't have any ACL's preventing that, and I can also ping the 192.168.1.0 subnet, from the other vlans. but I can't ping the 192.168.1.20 DVR to access

LAN issues with Vlans

You'll need to enable routing on the switch to route between vlans. From the cli, type "ip routing", and you should be able to get to your cameras.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
134
Views
0
Helpful
5
Replies