Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LAN Routing Problem

I have 2 4506's and a 3845 MPLS router. I'm attaching the diagram. I'm trying to figure out why when I do a traceroute from a remote site it is going to the 10.1.1.5 to the 10.1.1.4.

Here's the EIGRP info for one of our networks.

Routing entry for 10.90.6.0/24

Known via "eigrp 201", distance 90, metric 3072, type internal

Redistributing via eigrp 201, bgp 64512

Advertised by bgp 64512

Last update from 10.1.1.5 on GigabitEthernet0/0, 22:03:43 ago

Routing Descriptor Blocks:

* 10.1.1.5, from 10.1.1.5, 22:03:43 ago, via GigabitEthernet0/0

Route metric is 3072, traffic share count is 1

Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1

10.1.1.4, from 10.1.1.4, 22:03:43 ago, via GigabitEthernet0/0

Route metric is 3072, traffic share count is 1

Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 5/255, Hops 1

Not sure why the Loading is higher for the 10.1.1.4 route.

Any help would be appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: LAN Routing Problem

Jobe

Funnily enough i was about to suggest you connect up the 3825 to 10.1.1.5 directly for added redundancy.

In answer to your question no it won't because you can't have the 2 interfaces on the 3825 in the same subnet, it's not allowed.

The recommended way would be to use 2 P2P routed links from the 3825 to the 4500's ie.

3825

int gi0/1 (connected to 10.1.1.5 switch)

ip address 192.168.5.1 255.255.255.252

int gi0/2 (connected to 10.1.1.4 switch)

ip address 192.168.5.5 255.255.255.252

4506 (10.1.1.5 switch)

int gi0/1

no switchport

ip address 192.168.5.2 255.255.255.252

4506 (10.1.1.4 switch)

int gi0/1

no switchport

ip address 192.168.5.6 255.255.255.252

then the 3825 will have 2 equal cost paths to all networks on the 4500 but the next-hops will be different.

Jon

8 REPLIES
New Member

Re: LAN Routing Problem

Here's the configs from the 4506's and 3845.

10.1.1.4

router eigrp 201

redistribute static

network 10.0.0.0

network 192.168.1.0

no auto-summary

eigrp router-id 220.220.220.220

10.1.1.5

router eigrp 201

redistribute static

network 10.0.0.0

network 192.168.1.0

no auto-summary

10.1.1.3

router eigrp 201

redistribute static

redistribute bgp 64512

network 10.0.0.0

network 192.168.1.0

default-metric 10000 100 255 100 1500

no auto-summary

Hall of Fame Super Blue

Re: LAN Routing Problem

Jobe

"I'm trying to figure out why when I do a traceroute from a remote site it is going to the 10.1.1.5 to the 10.1.1.4."

Could you clarify what you mean by that ?

Also can you repost the .jpg - have a look it only has an IP address in it.

Jon

New Member

Re: LAN Routing Problem

Ok I've reposted the .jpg.

It looks like my traffic instead of hitting a server say hanging off the 10.1.1.4 switch is bouncing to 10.1.1.5 first and then back to 10.1.1.4. The drawing should help.

Hall of Fame Super Blue

Re: LAN Routing Problem

Jobe

The traceroute - can you post it ?

Also, in your first post you show a routing entry for 10.90.6.0/24. Is this from the 3825 ?

Bear in mind that if there are 2 equal cost paths to a destination a traceroute will use them both.

Jon

New Member

Re: LAN Routing Problem

Sure here you. The 4506's are using HSRP also.

Yes the traceroute is from the 3845.

Tracing the route to ho1mail.ad.burns-wilcox.com (10.90.6.55)

1 10.1.1.5 0 msec

10.1.1.4 4 msec

10.1.1.5 4 msec

2 ho1mail.ad.burns-wilcox.com (10.90.6.55) 0 msec 4 msec 0 msec

BW-3845-HQ#sh ip route 10.90.6.0

Routing entry for 10.90.6.0/24

Known via "eigrp 201", distance 90, metric 3072, type internal

Redistributing via eigrp 201, bgp 64512

Advertised by bgp 64512

Last update from 10.1.1.5 on GigabitEthernet0/0, 1d00h ago

Routing Descriptor Blocks:

* 10.1.1.5, from 10.1.1.5, 1d00h ago, via GigabitEthernet0/0

Route metric is 3072, traffic share count is 1

Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1

10.1.1.4, from 10.1.1.4, 1d00h ago, via GigabitEthernet0/0

Route metric is 3072, traffic share count is 1

Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 5/255, Hops 1

Hall of Fame Super Blue

Re: LAN Routing Problem

Jobe

It's not bouncing over to 10.1.1.5 and then back again. If it was then you would see it as different numbered entries ie.

1 10.1.1.4

2 10.1.1.5

3 10.1.1.4

4 ho1mail.ad.burns-wilcox.com (10.90.6.55) 0 msec 4 msec 0 msec

but your entry is

1 1 10.1.1.5 0 msec

10.1.1.4 4 msec

10.1.1.5 4 msec

2 ho1mail.ad.burns-wilcox.com (10.90.6.55) 0 msec 4 msec 0 msec

ie it is only 2 hops. If there are 2 equal cost paths to a destination in the routing table then when you do a traceroute it will always send packets to both.

It's nothing to worry about.

Jon

New Member

Re: LAN Routing Problem

Jon that does make sense. Would the traceroute still look the same if I added the second NIC to the 3845 and hook it to 10.1.1.5? Then I'll have complete redundancy.

Hall of Fame Super Blue

Re: LAN Routing Problem

Jobe

Funnily enough i was about to suggest you connect up the 3825 to 10.1.1.5 directly for added redundancy.

In answer to your question no it won't because you can't have the 2 interfaces on the 3825 in the same subnet, it's not allowed.

The recommended way would be to use 2 P2P routed links from the 3825 to the 4500's ie.

3825

int gi0/1 (connected to 10.1.1.5 switch)

ip address 192.168.5.1 255.255.255.252

int gi0/2 (connected to 10.1.1.4 switch)

ip address 192.168.5.5 255.255.255.252

4506 (10.1.1.5 switch)

int gi0/1

no switchport

ip address 192.168.5.2 255.255.255.252

4506 (10.1.1.4 switch)

int gi0/1

no switchport

ip address 192.168.5.6 255.255.255.252

then the 3825 will have 2 equal cost paths to all networks on the 4500 but the next-hops will be different.

Jon

142
Views
0
Helpful
8
Replies
CreatePlease to create content