Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LAN, Switching and Routing

Hi all! Is it possible to creat Vlans between a cisco switch and a non cisco switch e.g Extrem switch.?

We need to exten a lan to a little lan that is running on an Extrem switch.We are using the 802.1q on the cisco switches.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: LAN, Switching and Routing

Hi Kgabo

Can I ask if the Extreme switch is running purely as an L2 switch or has it been licensed to run as an L3 switch? I just ask because of the number of VLAN's configured on the Extreme.

Also can I ask what the configuration line "configure vr VR-Default add ports 1-50" is doing? I am not familiar with this.

Finally, if you want to have traffic from VALN 133 and VLAN 134 pass between the Extreme and the Cisco you will need to create a trunk port on the Extreme. I see from the configurations posted above that you have designated port Fast Ethernet 0/4 on the Cisco as a trunk and allowed VLAN 133 & 134 on this trunk.

Now on the Extreme, which ever port the Cisco will connect to, run the following (assuming Cisco linked ot port 24 on Extreme)

configure vlan 133 add port 24 tagged

configure vlan 134 add port 24 tagged

This would enable port 24 as a IEEE 802.1Q trunk with traffic for VLAN's 133 & 134 allowed across the trunk. Substitute port 24 for the port the Cisco connects to.

HTH

Best Regards,

Michael

3 REPLIES

Re: LAN, Switching and Routing

yes it is. Vlans are standard dot1q. The method of tagging frames with vlan ids is standard.

http://www.math.uwaterloo.ca/mfcf/internal/procedures/networks/manuals/Extreme_quick_ref.htm

Community Member

Re: LAN, Switching and Routing

Hi Matt!

Thanx for the Url site. It does not help much as im a cisco guy. Maybe have a look at configs Xtreme and Cisco maybe you can sport the probelm. Pliz Pay attesion to Vlan133 n 134.

Im running EIGRP on my net and he is running OSPF.

EXTREME

GABORSS01.4 # sh configuration

#

# Module devmgr configuration.

#

configure snmp sysName "GABORSS01"

configure snmp sysContact "support@extremenetworks.com, +1 888 257 3000"

configure timezone name GMT 120 noautodst

configure slot 1 module X450a-48tdc

configure sys-recovery-level switch reset

#

# Module vlan configuration.

#

enable mirroring to port 41

configure vr VR-Default add ports 1-50

create vlan "ADC"

configure vlan ADC tag 123

create vlan "CHARG_FDT"

configure vlan CHARG_FDT tag 134

create vlan "CHARG_INTOM"

configure vlan CHARG_INTOM tag 227

create vlan "CHARG_RAD"

configure vlan CHARG_RAD tag 240

create vlan "CHARG_RDT"

configure vlan CHARG_RDT tag 133

create vlan "CN_SS7_1"

configure vlan CN_SS7_1 tag 125

configure vlan Default tag 1

create vlan "eDNS"

configure vlan eDNS tag 100

create vlan "EMA_VLAN"

configure vlan EMA_VLAN tag 229

create vlan "Gi_FW"

configure vlan Gi_FW tag 105

create vlan "Gi_l"

configure vlan Gi_l tag 104

create vlan "Gn_FW"

configure vlan Gn_FW tag 102

create vlan "Gn_l"

configure vlan Gn_l tag 101

create vlan "Gom_l"

configure vlan Gom_l tag 120

create vlan "Gp"

configure vlan Gp tag 110

create vlan "iDNS"

configure vlan iDNS tag 103

create vlan "INT_SW_VLAN"

configure vlan INT_SW_VLAN tag 124

create vlan "Internet_VLAN"

configure vlan Internet_VLAN tag 107

create vlan "MIEP"

configure vlan MIEP tag 121

create vlan "OAM_CPC_VLAN"

configure vlan OAM_CPC_VLAN tag 122

create vlan "OAM_MPBN"

configure vlan OAM_MPBN tag 108

create vlan "RADIUS_VLAN"

configure vlan RADIUS_VLAN tag 106

create vlan "RSG_VLAN"

configure vlan RSG_VLAN tag 228

create vlan "SMS_VMS_VLAN"

configure vlan SMS_VMS_VLAN tag 119

create vlan "SS7_l"

configure vlan SS7_l tag 109

................

CISCO

Current configuration : 1245 bytes

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

enable secret xxx

!

ip subnet-zero

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

switchport mode trunk

no ip address

!

interface FastEthernet0/2

switchport access vlan 128

no ip address

!

interface FastEthernet0/3

switchport access vlan 128

no ip address

!

interface FastEthernet0/4

switchport trunk allowed vlan 133,134

switchport mode trunk

no ip address

!

interface FastEthernet0/5

switchport access vlan 134

no ip address

!

interface FastEthernet0/6

switchport access vlan 133

no ip address

!

interface FastEthernet0/7

switchport access vlan 133

no ip address

!

interface FastEthernet0/8

switchport access vlan 135

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface Vlan1

ip address 10.1.31.205 255.255.240.0

no ip route-cache

!

no ip http server

!

!

line con 0

password

login

line vty 0 4

password

login

line vty 5 15

login

!

end

Switch#

Switch#

Switch#

Switch#

Silver

Re: LAN, Switching and Routing

Hi Kgabo

Can I ask if the Extreme switch is running purely as an L2 switch or has it been licensed to run as an L3 switch? I just ask because of the number of VLAN's configured on the Extreme.

Also can I ask what the configuration line "configure vr VR-Default add ports 1-50" is doing? I am not familiar with this.

Finally, if you want to have traffic from VALN 133 and VLAN 134 pass between the Extreme and the Cisco you will need to create a trunk port on the Extreme. I see from the configurations posted above that you have designated port Fast Ethernet 0/4 on the Cisco as a trunk and allowed VLAN 133 & 134 on this trunk.

Now on the Extreme, which ever port the Cisco will connect to, run the following (assuming Cisco linked ot port 24 on Extreme)

configure vlan 133 add port 24 tagged

configure vlan 134 add port 24 tagged

This would enable port 24 as a IEEE 802.1Q trunk with traffic for VLAN's 133 & 134 allowed across the trunk. Substitute port 24 for the port the Cisco connects to.

HTH

Best Regards,

Michael

219
Views
0
Helpful
3
Replies
CreatePlease to create content