Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Lan to internet conection

Hello everyone,

First of all sorry for my english, i'll probably will make some grammar mistakes, but i think we could understand

I'm newbie with cisco routers (I have only done The CCNA-1 and 2) And I'm having some troubles when I want to connect my router 881W to my ADSL and give internet to my lan.

By the moment this is my configuration:

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

!        

!

!

!

!

ip cef

no ipv6 cef

!

!

license udi pid CISCO881W-GN-E-K9 sn FCZ1617C502

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!        

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

ip address dhcp

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

no ip address

shutdown

arp timeout 0

!        

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface Vlan1

no ip address

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1 254

!

!

!

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

line vty 0 4

login

transport input all

!

end

I just want to have internet connection from the Fast Ethernet 0 to 3. Right know I only have internet from the Fast Ethernet 4 (The Wlan) pinging from the router to outside.

Thanks for all.

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Purple

Lan to internet conection

Hi,

Supposing the fa4 is connected to a modem/router and that you only want as of now only wired machines in your LAN to access the internet:

no ip dhcp conflict

ip dhcp pool LAN_POOL

network 192.168.2.0 /24

default-router 192.168.2.254

dns-server 8.8.8.8

access-list 1 permit 192.168.2.0 0.0.0.255

ip nat inside source list 1 interface fa4

int vlan 1

ip address 192.168.2.254 255.255.255.0

ip nat inside

int fa4

ip nat outside

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Purple

Lan to internet conection

Hi,

the values you provided  supposing a mask of 255.255.255.0 are not valid ip addresses but network addresses.

What do you want to do exactly? give the same IP everytime to same device with DHCP or have some devices with a ststic IP  ?

Also the default-gateway is a machine in the same subnet as the hosts so if your machines are in the 192.168.2.0/24 your default-gateway must be in the same subnet and it is the ip address of the corresponding vlan interface on the router.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
4 REPLIES
Purple

Lan to internet conection

Hi,

Supposing the fa4 is connected to a modem/router and that you only want as of now only wired machines in your LAN to access the internet:

no ip dhcp conflict

ip dhcp pool LAN_POOL

network 192.168.2.0 /24

default-router 192.168.2.254

dns-server 8.8.8.8

access-list 1 permit 192.168.2.0 0.0.0.255

ip nat inside source list 1 interface fa4

int vlan 1

ip address 192.168.2.254 255.255.255.0

ip nat inside

int fa4

ip nat outside

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Lan to internet conection

Rate it with the maximum value!

A lot of thanks, it works

But now I have a problem,

If I want to have fixed ip in my Lan for example:

-network 192.168.3.0

-network 192.168.4.0

-network 192.168.25.0

What i need to do?

I have to specify the default gateway as the 192.168.2.254?

Thanks!

Purple

Lan to internet conection

Hi,

the values you provided  supposing a mask of 255.255.255.0 are not valid ip addresses but network addresses.

What do you want to do exactly? give the same IP everytime to same device with DHCP or have some devices with a ststic IP  ?

Also the default-gateway is a machine in the same subnet as the hosts so if your machines are in the 192.168.2.0/24 your default-gateway must be in the same subnet and it is the ip address of the corresponding vlan interface on the router.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Lan to internet conection

Hi,

I got confused and I though that I would have some kind of problem with different LANs, but this LANs are concected to a Zentyal server, and Zentyal server to Cisco, so, It doesn't matter because they go to the cisco router as the Zentyal IP.

I tested and everything works fine.

A lot of thanks.

208
Views
0
Helpful
4
Replies
CreatePlease to create content