Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Lan to Internet traffic

                 We have confirmed all internal traffic trying to access the internet getting to the Cisco 3750 stack but nothing leaving going through external interface to the internet.

We have an MPLS router with external interface configured with static Ip and able to ping the internet 4.2.2.2, we have an interface fa0/0/0 directly connected to the Cisco 3750 switch and both passing traffic. when our users try to use the internet traffic hits the 3750 stack but not able to use the internet. I'm trying to ping 4.2.2.2 from my 3750 stack and not able to and not sure why, as I'm able to pint the external interface on the MPLS routing that connects to the internet

I need your help as what is the problem.

Thank you

  • LAN Switching and Routing
Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: Lan to Internet traffic

the ip default-gateway command u set up there, is for times that u consider ur switches to act as a HOST. in other words; routing disabled, it just sends the local traffic to a gateway. it doesnt do routing. the ip route u just set does the routing.

HTH,

plz Rate if it helped.

Soroush.

Hope it Helps, Soroush.
8 REPLIES
Gold

Lan to Internet traffic

Hi,

if your hosts are setup with a default gateway, then I think you havent set proper routing in ur network. does your stack works in layer 3?

pingin external interface in ur own network from the switch doesnt mean u have correct setup.

HTH,


Soroush.

Hope it Helps, Soroush.
New Member

Lan to Internet traffic

I'm on my Cisco 3750 stack trying to ping google.com at 4.2.2.2 through my default gayteway the MPLS router and no replay, we have IP routing setup on the 3750 stack - ping will not work or connect to the inter.

Thanks

Gold

Lan to Internet traffic

does your cisco 3750 works at layer 3? what's the ip address of the F0/0/0 on MPLS router? is this set as your default gateway?

HTH,

Soroush.

Hope it Helps, Soroush.
VIP Super Bronze

Lan to Internet traffic

Can you post "sh run" from the 3750?

New Member

Lan to Internet traffic

The sh ru

Current configuration : 21545 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AIKENDRSW00

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$xwGc$3jmMu8cGriv2.cgwezyS7.

enable password 7 04585B0829604B5B1B4A

!

!

!

no aaa new-model

clock timezone EST -5

switch 1 provision ws-c3750g-48ps

switch 2 provision ws-c3750g-48ps

switch 3 provision ws-c3750g-48ps

system mtu routing 1500

ip routing

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree vlan 110,120 priority 4096

!

vlan internal allocation policy ascending

interface GigabitEthernet3/0/48

switchport access vlan 555

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet3/0/49

!

interface GigabitEthernet3/0/50

!

interface GigabitEthernet3/0/51

!

interface GigabitEthernet3/0/52

!

interface Vlan1

ip address 10.1.2.1 255.255.255.0

!

interface Vlan2

description dr vmotion

no ip address

!

interface Vlan3

ip address 172.16.3.1 255.255.255.0

!

interface Vlan4

description dr vmotion

no ip address

!

interface Vlan5

description <**Aiken_DR_192.168.10_Network**>

ip address 192.168.10.2 255.255.255.0

!

interface Vlan110

ip address 10.10.10.254 255.255.255.0

!

interface Vlan120

ip address 10.10.20.254 255.255.255.0

!

interface Vlan140

ip address 10.10.40.254 255.255.255.0

!

interface Vlan172

no ip address

!

interface Vlan173

ip address 172.16.10.3 255.255.255.0

interface Vlan174

ip address 172.16.20.3 255.255.255.0

!

interface Vlan555

description Aiken_Internet

ip address 184.95.133.254 255.255.255.0

!

ip default-gateway 184.95.133.1

ip classless

ip route 10.1.1.0 255.255.255.0 10.1.2.42

ip route 10.10.1.0 255.255.255.0 10.1.2.42

ip route 10.10.2.0 255.255.255.0 10.1.2.42

ip route 10.10.4.0 255.255.255.0 10.1.2.42

ip route 172.16.1.0 255.255.255.0 10.1.2.42

ip route 192.168.0.0 255.255.255.0 10.1.2.42

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

Current configuration : 21545 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AIKENDRSW00

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$xwGc$3jmMu8cGriv2.cgwezyS7.

enable password 7 04585B0829604B5B1B4A

!

!

!

no aaa new-model

clock timezone EST -5

switch 1 provision ws-c3750g-48ps

switch 2 provision ws-c3750g-48ps

switch 3 provision ws-c3750g-48ps

system mtu routing 1500

ip routing

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 110,120 priority 4096
!
vlan internal allocation policy ascending

All interfaces here

then

interface GigabitEthernet3/0/48
switchport access vlan 555
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet3/0/49
!
interface GigabitEthernet3/0/50
!
interface GigabitEthernet3/0/51
!
interface GigabitEthernet3/0/52
!
interface Vlan1
ip address 10.1.2.1 255.255.255.0
!
interface Vlan2
description dr vmotion
no ip address
!
interface Vlan3
ip address 172.16.3.1 255.255.255.0
!
interface Vlan4
description dr vmotion
no ip address
!
interface Vlan5
description <**Aiken_DR_192.168.10_Network**>
ip address 192.168.10.2 255.255.255.0
!
interface Vlan110
ip address 10.10.10.254 255.255.255.0
!
interface Vlan120
ip address 10.10.20.254 255.255.255.0
!
interface Vlan140
ip address 10.10.40.254 255.255.255.0
!
interface Vlan172
no ip address
!
interface Vlan173
ip address 172.16.10.3 255.255.255.0

interface Vlan174
ip address 172.16.20.3 255.255.255.0
!
interface Vlan555
description Aiken_Internet
ip address 184.95.133.254 255.255.255.0
!
ip default-gateway 184.95.133.1
ip classless
ip route 10.1.1.0 255.255.255.0 10.1.2.42
ip route 10.10.1.0 255.255.255.0 10.1.2.42
ip route 10.10.2.0 255.255.255.0 10.1.2.42
ip route 10.10.4.0 255.255.255.0 10.1.2.42
ip route 172.16.1.0 255.255.255.0 10.1.2.42
ip route 192.168.0.0 255.255.255.0 10.1.2.42
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!

IP default-gateway is the MPLS external interface - able to ping the external IP from 3750 switch

Gold

Re: Lan to Internet traffic

EDIT:

Look, the default gateway here u set is not what takes the internet traffic from hosts to the gateway router. for internet traffic to go to router and out, u have to set a default route using ip route. that is if there is a traffic comming in which ur switch doesnt know where to send it, it sends it to the mpls router. that will include traffic from hosts to internet.

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
New Member

Lan to Internet traffic

I"m trying to figure this out so I added this route IP route 0.0.0.0 0.0.0.0 x.x.x.x the X is the external interface on the MPLS router and all works now, can someone tell me why the default gateway being set to the external IP address is not enough

Thanks

Gold

Re: Lan to Internet traffic

the ip default-gateway command u set up there, is for times that u consider ur switches to act as a HOST. in other words; routing disabled, it just sends the local traffic to a gateway. it doesnt do routing. the ip route u just set does the routing.

HTH,

plz Rate if it helped.

Soroush.

Hope it Helps, Soroush.
609
Views
0
Helpful
8
Replies
This widget could not be displayed.