cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4169
Views
0
Helpful
8
Replies

Layer 2 / Layer 3 routing problem

Carl Williams
Level 1
Level 1

I have two switches and I'm trying to get a basic network working, for some reason ESW2 switch has configured as a layer 2 router. With a default route is not routing traffic properly to the layer 3 switch 3.

The issue is between the layer 2 and the layer 3 switch routing can someone assist me in this area.

I'm unable to ping the layer 3 switch gateway IP vlan 10 from the PC's can someone explain where i'm going wrong here cause it can't see it.

LAYER 2 SWITCH


ESW2#show run
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/4
 description Trunk link layer3 switch
 switchport mode trunk
 duplex full
!
interface FastEthernet1/7
 description vlan 20 accounts
 switchport access vlan 20
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet1/11
 description vlan10 traders
 switchport access vlan 10
 duplex full
 speed 100
 spanning-tree portfast
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan10
 description management
 ip address 10.10.10.2 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.10.10.1

########

LAYER 3 SWITCH

hostname ESW1
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no switchport
 ip address 172.16.10.1 255.255.255.0
 duplex full
 speed 100
!
interface FastEthernet1/1
 description trunk to layer 2 switch
 switchport mode trunk
 duplex full
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.10.1 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.0 0.0.0.255 area 0
 network 172.16.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.255 area 0
 default-information originate

####

Layer 3 WAN router


hostname R1
!
interface FastEthernet2/0
 description connection to L3 switch
 ip address 172.16.10.2 255.255.255.0
 duplex full
!
interface GigabitEthernet3/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial4/0
 ip address 10.10.11.1 255.255.255.0
 serial restart-delay 0
!
!
router ospf 1
 log-adjacency-changes
 redistribute bgp 6500 subnets
 network 172.16.10.0 0.0.0.255 area 0
!
router bgp 6500
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 match internal external 2
 neighbor 10.10.11.2 remote-as 65009
 no auto-summary
!

8 Replies 8

Peter Paluch
Cisco Employee
Cisco Employee

Hi Carl,

From your description, you're saying that when you try pinging 10.10.10.1 from PCs in either VLAN10 or VLAN20, you are getting no responses. Is that correct?

Let's go step by step, and please try to answer every question including any outputs from your topology you can provide as an evidence:

  1. When you enter show vlan brief on the L2 and the L3 switches, are VLANs 10 and 20 created? (Due to the fact that you're using a switching module, you might need to use show vlan-sw brief command instead.)
  2. When you enter show ip int brief vlan10 and show ip int brief vlan20 on the L3 switch, is the interface reported as "status up, protocol up"?
  3. When you run show cdp neighbor on the L2 switch, do you see the L3 switch, and vice versa?
  4. When you run show mac address-table on the L2 switch, do you see the MAC addresses of the hosts in VLAN10 and VLAN20 being learned?
  5. When you run show mac address-table on the L3 switch, do you see the MAC addresses of the hosts in VLAN10 and VLAN20 being learned?
  6. Can hosts in VLAN20 ping 192.168.10.1? What IP addresses are used for hosts in VLAN20?
  7. What default gateway are hosts in VLAN20 using?

Thanks! Looking forward to hearing from you.

Best regards,
Peter

PC1 - IP 10.10.10.10

PC2 - IP 10.10.10.11

PC3 - IP 192.168.10.10

PC4 - IP 192.168.10.11

ESW2#show mac
ESW2#show mac-address-table
Destination Address  Address Type  VLAN  Destination Port
-------------------  ------------  ----  --------------------
c406.250c.0000          Self          1     Vlan1
c406.250c.0000          Self         10     Vlan10

Layer 3 switch

ESW1#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.10.10.1              -   c405.169c.0000  ARPA   Vlan10
Internet  192.168.10.1            -   c405.169c.0000  ARPA   Vlan20
Internet  172.16.10.2            18   ca02.1020.0038  ARPA   FastEthernet1/0
Internet  172.16.10.1             -   c405.0a8c.f100  ARPA   FastEthernet1/0

ESW1#show vlan-switch
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/2, Fa1/3, Fa1/4, Fa1/5
                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/11, Fa1/12, Fa1/13
                                                Fa1/14, Fa1/15, Fa3/0, Fa3/1
                                                Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12, Fa3/13
                                                Fa3/14, Fa3/15
10   traders                          active
20   accounts                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
ESW1#
the topology looks quiet simple I am unable to even ping vlan 10 and vlan 20 from the PC's even though they are set up with the correct gateway IP's.

ESW1# show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R1               Fas 1/0            168          R        7206VXR   Fas 2/0
ESW2             Fas 1/1            127         S I       3745      Fas 1/4
ESW1#

ESW2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
ESW1             Fas 1/4            130        R S I      3745      Fas 1/1

Hi Carl,

Your ESW2 is not learning any MAC addresses from attached hosts. It seems like the frames from the PCs are not even reaching ESW2.

Let's continue the troubleshooting. From ESW2, please post the complete output of the following commands:

show interface status
show interface trunk
show vlan-sw brief

Also, can PC1 ping PC2, and can PC3 ping PC4?

Best regards,
Peter

ESW2#show interface status
Port    Name               Status       Vlan       Duplex Speed Type
Fa1/0                      notconnect   1            auto    auto 10/100BaseTX
Fa1/1                      notconnect   1            auto    auto 10/100BaseTX
Fa1/2                      notconnect   1            auto    auto 10/100BaseTX
Fa1/3                      notconnect   1            auto    auto 10/100BaseTX
Fa1/4   Trunk link layer3  connected    trunk        full   a-100 10/100BaseTX
Fa1/5                      notconnect   1            auto    auto 10/100BaseTX
Fa1/6                      notconnect   1            auto    auto 10/100BaseTX
Fa1/7   vlan 20 accounts   connected    20           full     100 10/100BaseTX
Fa1/8                      notconnect   1            auto    auto 10/100BaseTX
Fa1/9                      notconnect   1            auto    auto 10/100BaseTX
Fa1/10                     notconnect   1            auto    auto 10/100BaseTX
Fa1/11  vlan10 traders     connected    10           full     100 10/100BaseTX
Fa1/12                     notconnect   1            auto    auto 10/100BaseTX
Fa1/13                     notconnect   1            auto    auto 10/100BaseTX
Fa1/14                     notconnect   1            auto    auto 10/100BaseTX
Fa1/15                     notconnect   1            auto    auto 10/100BaseTX
Fa3/0                      notconnect   1            auto    auto 10/100BaseTX
Fa3/1                      notconnect   1            auto    auto 10/100BaseTX
Fa3/2                      notconnect   1            auto    auto 10/100BaseTX
Fa3/3                      notconnect   1            auto    auto 10/100BaseTX
Fa3/4                      notconnect   1            auto    auto 10/100BaseTX
Port    Name               Status       Vlan       Duplex Speed Type
Fa3/5                      notconnect   1            auto    auto 10/100BaseTX
Fa3/6                      notconnect   1            auto    auto 10/100BaseTX
Fa3/7                      notconnect   1            auto    auto 10/100BaseTX
Fa3/8                      notconnect   1            auto    auto 10/100BaseTX
Fa3/9                      notconnect   1            auto    auto 10/100BaseTX
Fa3/10                     notconnect   1            auto    auto 10/100BaseTX
Fa3/11                     notconnect   1            auto    auto 10/100BaseTX
Fa3/12                     notconnect   1            auto    auto 10/100BaseTX
Fa3/13                     notconnect   1            auto    auto 10/100BaseTX
Fa3/14                     notconnect   1            auto    auto 10/100BaseTX
Fa3/15                     notconnect   1            auto    auto 10/100BaseTX
ESW2#   show int trunk
Port      Mode         Encapsulation  Status        Native vlan
Fa1/4     on           802.1q         trunking      1
Port      Vlans allowed on trunk
Fa1/4     1-1005
Port      Vlans allowed and active in management domain
Fa1/4     1,10,20
Port      Vlans in spanning tree forwarding state and not pruned
Fa1/4     1,10,20
ESW2#show vlan-sw brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/5, Fa1/6, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/12, Fa1/13, Fa1/14
                                                Fa1/15, Fa3/0, Fa3/1, Fa3/2
                                                Fa3/3, Fa3/4, Fa3/5, Fa3/6
                                                Fa3/7, Fa3/8, Fa3/9, Fa3/10
                                                Fa3/11, Fa3/12, Fa3/13, Fa3/14
                                                Fa3/15
10   traders                          active    Fa1/11
20   accounts                         active    Fa1/7
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

Hi Also can't ping between the VLANs

Hello

In addition to peters post , Please make sure ip routing is disabled on the L2 switch

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: