Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

layer 2 multicast packets on the 2950?

I manage a network, which includes about 40 switches of these model: 6500, 3550, 3500, 2950 and 1924. I have a television-video application which is implemented by layer 2 multicast(all the video devices are in the same vlan). I find that if there are 2 multicast flows go through the uplink of the 2950, all of the 2950 switches (WS-C2950T-48-SI) will drop lots of multicast packets, and at the same time, I can't ping the management ip addresses of these 2950s. The other type switches (even the 1924) are ok with no problem.

I guess that as to the 2950 switch, the layer 2 multicast packets is processed by the cpu processor, and not by the asic, is it right? and how to solve the multicast problem?

Thanks.

The following information is on the uplink of the 2950.

GigabitEthernet0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0012.8067.0471 (bia 0012.8067.0471)

MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 12/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is RJ45

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 1/75/36355/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 5074000 bits/sec, 917 packets/sec

5 minute output rate 7000 bits/sec, 6 packets/sec

3819237995 packets input, 2828109978 bytes, 0 no buffer

Received 2379228604 broadcasts (0 multicast)

7919 runts, 0 giants, 0 throttles

40562787 input errors, 21299023 CRC, 19146089 frame, 0 overrun, 199936840 ignored

0 watchdog, 2235358008 multicast, 0 pause input

0 input packets with dribble condition detected

748436823 packets output, 3325518953 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

7 REPLIES
New Member

Re: layer 2 multicast packets on the 2950?

From the interface information i can make out that there are lots of error on the interface. You need to fix these errors first (40562787 input errors, 21299023 CRC, 19146089 frame, 0 overrun, 199936840 ignored

) CRC can be caused by cable faults and interference etc. Then you should be able to ping the Managment IP address, but that will depend on how you have configured the network i.e. whats how many vlans you have? uplinks are trunk or access links? you have configured L3 routing etc. then once these issues are fixed then you need to check the Multicast issue.

New Member

Re: layer 2 multicast packets on the 2950?

Hi, s.jafar:

Thanks for your help. I have resolved the interface problem by migrating the giga port to a fastethernet port, but the multicast problem still there. These is the statistic information for the new port ( about 5 minutes). There are just 5 vlans on the 2950

and on the uplink. The uplink (now is the 0/24) is a dot1q trunk, connecting to the core switch(catalyst 6506,the igmp snoop feature is closed on the 6506, and opened on the 2950).

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0012.8067.0458 (bia 0012.8067.0458)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 21/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:07, output hang never

Last clearing of "show interface" counters never

Input queue: 1/75/21/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 8239000 bits/sec, 1053 packets/sec

5 minute output rate 211000 bits/sec, 29 packets/sec

3369423 packets input, 3683699165 bytes, 51 no buffer

Received 3165037 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 51 ignored

0 watchdog, 2972034 multicast, 0 pause input

0 input packets with dribble condition detected

584864 packets output, 643426573 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

The following is the configuration:

vlan 11-13,24

!

interface FastEthernet0/1-23

switchport access vlan 13

switchport mode access

interface FastEthernet0/24

switchport mode trunk

!

interface FastEthernet0/25-40

switchport access vlan 24

interface FastEthernet0/41

switchport access vlan 12

!

interface FastEthernet0/42

switchport access vlan 12

!

interface FastEthernet0/43

switchport access vlan 12

!

interface FastEthernet0/44

switchport access vlan 12

!

interface FastEthernet0/45

switchport access vlan 13

switchport mode access

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan11

ip address 10.17.200.63 255.255.255.0

no ip route-cache

New Member

Re: layer 2 multicast packets on the 2950?

Hi, you havent mentioned if you are able to ping the management IP address of 6500 from this access switch or not? You have mentioned that the trunk is dot1q where as to the best of my knowledge if you dont specify encapsulation dot1q it will be ISL trunk. I think you apply the following command on f0/24 "swith trunk encap dot1q" (this should also be done on interface of core connecting to this access switch). I will appreciate if you can also send me the output of sh trunk from both switches. Also please secify if you are able to ping the ip address?

regards,

SJafar

New Member

Re: layer 2 multicast packets on the 2950?

Hi, the management vlan is vlan11, all the switches's management ip address are in the same vlan.

when the video conference devices are working:

1)I can't ping the management ip address of the 6500 from the 2950, but I can ping the 6500 from the other type switches.

2)I can't ping the 2950 from anywhere. I can ping the other type switches from anywhere.

After the video conference devices stop working:

1)I can ping the management ip address of the 6500 from all the switches, including the 2950.

2)I can also ping the 2950 from anywhere.

The 2950 supports the dot1q trunk protocol only, and not isl. The dot1q trunk works well, and the native vlan(vlan 1) is matched between the 2950 and 6500. I'm sorry that now I can't telnet that two devices and get the trunk output information, but I believe there are no problems on the trunk protocol.

What doubt me is that the ping and telnet to the 2950 works badly, but in the same switch, all other traffics from other vlan works well (unicast packetes:http, email, ftp). I have changed the 2950's ios from 12.1(22)EA1 to 12.1(22)EA8a, but that same problem exist there.

New Member

Re: layer 2 multicast packets on the 2950?

Additional informaition:

All the video devices are in the same vlan (vlan 13). All the multicast senderes (video encoders) and receiverer are attached to a cisco catalyst switch (1924,2950,3500 or 3550), respectively. These switches connect to each other via a core switch 6506 by dot1q or isl.

The pim and cgmp protocol are enabled on the "int vlan 13" on the msfc of the 6506.

The igmp snooping on the 6506 is disabled (for administrative polices cause), and igmp snooping or cgmp is opened on the other edge switches. As to the 2950, it is igmp snooping enabled, and I find that 2950 can learn the multicast group ip addresses (show ip igmp snooping group) , but when the video conference is finished, the multicast group ip addresses are not cleared from the 2950 (even I shut down the encoder and decoder), untill I restart the igmp snooping feature (by disable and enable command).

New Member

Re: layer 2 multicast packets on the 2950?

Hallo!

I have the same problem with the 2950 switches - same constellation.

Have you got a soulution for this problem?

New Member

Re: layer 2 multicast packets on the 2950?

Hi,

Which multicast mode are you running ? Can you measure CPU and memory stats while your multicast is on? You mentioned that you can't get to the switch using telnet, the only option you have is to console in to get this info. Do you have any management software in use ? What does the logs record during multicast is on ?

Thanks.

468
Views
0
Helpful
7
Replies
CreatePlease to create content