Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Layer 2 switch as a dhcp server

Can a layer 2 cisco 2950 switch be used as a dhcp server with it's own address pool

5 REPLIES
Gold

Re: Layer 2 switch as a dhcp server

From the config guide:

The DHCP server feature is only available on Catalyst 2955 switches.

Hall of Fame Super Gold

Re: Layer 2 switch as a dhcp server

The 2950 is not capable of being a DHCP server. This feature started with the 2970 and was incorporated to the 2960/2975 series of switches.

New Member

Layer 2 switch as a dhcp server

I know this is a real old post but you can use a 2950 switch as a DHCP Server. You just need to start the service first, then configure it just like a router. I did it on one of my 2950 switches to test after I saw a video on YouTube where someone did it. As he mentions, this could do more harm then good because of the lack of controling broadcasts.

http://www.youtube.com/watch?v=Fa83TCPwOlU

This is from my switch

hostname Switch1

!

!

ip subnet-zero

ip dhcp excluded-address 192.168.50.0 192.168.50.10

!

ip dhcp pool TEST

   network 192.168.50.0 255.255.255.0

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 50

switchport mode access

New Member

I know yours is a real old

I know yours is a real old post but my question now is, How do you associate the DHCP pool with the VLAN 50? I have a different model switch but OS seems similar. 

I found that DHCP service will NOT work unless there is an active layer 3 interface (SVI) on that VLAN

As in you would have to do :

interface vlan50

ip address 192.168.50.x 255.255.255.0

and From this is the only way that the switch can know what VLAN that pool should belong to

Does yours work withou layer 3?

New Member

What's up? Yeah this is an

What's up? Yeah this is an old post! lol Off the top of my head I would say IP addressing is at layer 3. So the DHCP leasing needs to be at the same layer with either a SVI or routed port on the switch. Remember any device looking for a DHCP lease needs to know where to get it. Hence assigning an IP to a SVI or routed port on the switch so it knows where to send the request. Once the port is at the right layer addressing is possible. IMHO this really isn't real world unless it's a smaller network. Hope this clears it up, if not just reply we're you stuck and I'll try to clear it up for you. ;-)

5895
Views
0
Helpful
5
Replies
CreatePlease to create content