Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Layer 2 Switching

I am using a switch(3560X) and a router 7606 for the given setup.

I am doing a simple simulation of attcaching a port (on 7606 router)to the switch and testing it with various speed ,duplex setting.

The switch port is in vlan 2 with ip address x.x.x.234 mask 255.255.255.0

and the attached router port has ip address x.x.x.235 mask 255.255.255.0

The problem is:

The connection is establises for duplex full,speed 1000

      but it does not establish for  duplex full,speed 100

                                        and   duplex half,speed 10.

The ports are 10/100/1000 Ethernet ports.

The output from 3560 is:

3560X#sh int gig 0/10

GigabitEthernet0/10 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is 442b.0389.448a (bia 442b.0389.448a)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Half-duplex, 10Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:35:39, output 00:35:09, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

3560X#sh run int gig 0/10


Current configuration : 129 bytes

!

interface GigabitEthernet0/10

switchport access vlan 2

switchport mode access

speed 10

duplex half

end

################################################    #######################################

3560X#sh int gig 0/10

GigabitEthernet0/10 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 442b.0389.448a (bia 442b.0389.448a)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:03, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

3560X#sh run int gig 0/10


Current configuration : 131 bytes

!

interface GigabitEthernet0/10

switchport access vlan 2

switchport mode access

speed 1000

duplex full

end

And Output from the 7606 link is :


7606-A#sh run int gig 2/10

!

interface GigabitEthernet2/10

ip address 192.168.0.235 255.255.255.0

speed 10

duplex half

end

7606-A#sh int gig 2/10

GigabitEthernet2/10 is down, line protocol is down (notconnect)

  Hardware is C6k 1000Mb 802.3, address is 0011.bbb1.a140 (bia 0011.bbb1.a140)

  Internet address is 192.168.0.235/24

  MTU 1500 bytes, BW 10000 Kbit, DLY 10 usec,

     reliability 255/255, txload 0/255, rxload 0/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Half-duplex, 10Mb/s, media type is 10/100/1000BaseT

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:25:11, output 00:25:10, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/59/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  L2 Switched: ucast: 1619 pkt, 103616 bytes - mcast: 4238 pkt, 311393 bytes

  L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

  L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes

##########################################################################################

7606-A#sh run int gig 2/10


Current configuration : 102 bytes

!

interface GigabitEthernet2/10

ip address 192.168.0.235 255.255.255.0

speed 1000

duplex full

end

7606-A#sh int gig 2/10

GigabitEthernet2/10 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3, address is 0011.bbb1.a140 (bia 0011.bbb1.a140)

  Internet address is 192.168.0.235/24

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseT

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:37, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/59/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  L2 Switched: ucast: 1656 pkt, 105984 bytes - mcast: 4679 pkt, 342779 bytes

  L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

  L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes

Thanks

Girish

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Layer 2 Switching

  Thats because you are not using a crossover cable most likely .  If you are using a straight thru cable the link will only come up if the port settings are set for auto/auto  because the mdix feature will only work if the ports are auto.    Generally leave gig ports as auto . I bet if you change the 3560 side to auto the link will come up .  You can set the 3560 side as auto and restrict the speed to 100 if you want .  USe the "speed auto 100"  or speed auto 10"  commands.

1 REPLY
Purple

Re: Layer 2 Switching

  Thats because you are not using a crossover cable most likely .  If you are using a straight thru cable the link will only come up if the port settings are set for auto/auto  because the mdix feature will only work if the ports are auto.    Generally leave gig ports as auto . I bet if you change the 3560 side to auto the link will come up .  You can set the 3560 side as auto and restrict the speed to 100 if you want .  USe the "speed auto 100"  or speed auto 10"  commands.

387
Views
0
Helpful
1
Replies
CreatePlease login to create content