Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Layer 3 Etherchannel

Good Day.

How do I get Layer 3 etherchannel to communicate with my Management VLAN ?  My etherchannel is Up Up, but my VLAN stays DOWN DOWN.

Any help will be much appreciated......

Here is a sample of my configs

Core 6807 XL

interface Port-channel50
 no switchport
 ip address 10.34.0.2 255.255.255.254
 ip ospf network point-to-point
!

!

interface TenGigabitEthernet1/2/1
 description # Link to Distribution 0 West Wing #####
 no switchport
 no ip address
 ip ospf network point-to-point
 channel-group 50 mode on
!

!
interface Vlan60
 description # Management VLAN #####
 ip address 10.34.1.1 255.255.255.224
 no ip route-cache
!

!
router ospf 100
 router-id 10.34.0.129
 log-adjacency-changes
 nsf
 network 10.34.0.2 0.0.0.1 area 0
 network 10.34.0.129 0.0.0.0 area 0
 network 10.34.1.0 0.0.0.31 area 0

!

Distribution 4900

!
interface Port-channel50
 description # Uplink to Core Switch #####
 ip address 10.34.0.3 255.255.255.254
 ip ospf message-digest-key 10 md5 7 1104391103005A0E577E7C
 ip ospf network point-to-point
 flowcontrol receive on
!

!
interface TenGigabitEthernet1/1
 description # Uplink to Core Switch #####
 no switchport
 no ip address
 ip ospf message-digest-key 10 md5 7 03097B1F121D704E1D5D4E
 ip ospf network point-to-point
 channel-group 50 mode on
!

!
interface Vlan60
 description # Management VLAN #####
 ip address 10.34.1.34 255.255.255.224
 standby 60 ip 10.34.1.33
 standby 60 priority 108
 standby 60 preempt
!

!
router ospf 100
 router-id 10.34.0.133
 log-adjacency-changes
 redistribute static subnets
 passive-interface default
 no passive-interface Port-channel50
 network 10.34.0.2 0.0.0.1 area 0
 network 10.34.0.133 0.0.0.0 area 0
 network 10.34.1.0 0.0.0.31 area 1

 

  • LAN Switching and Routing
2 REPLIES
New Member

Hi,add least one physical

Hi,

add least one physical port on the vlan

An SVI will only come up if

An SVI will only come up if an active Layer 2 ports either exists in than Vlan (i.e an access port) or a Trunk port which carries that Vlan tag.

Your connections to other switches are Layer 3 (i.e they have an IP address) so as far as the switch is concerned, the SVI is not needed as there is no active ports requiring it.

A vlan is a layer 2 entity so it will not be tagged across your Layer 3 link, hence why the SVI believes its not yet needed so stays down.

If you just need an IP address for management of the device then use a Loopback interface as they are virtual also but do not require an active Layer 2 link to come up.

Thanks

91
Views
0
Helpful
2
Replies
This widget could not be displayed.