Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Layer 3 port-channel Up / Up but can't ping across link

I configured the interfaces individually at L3 and could ping across each link

Example:

4500 Switch 2:            6500 Switch 1

int t5/1                    -      int g3/17                    1 Gig fiber link

tore down config

tried second set of interface

int t6/1                    -      int g8/17                    1 Gig fiber link

Ping successful

created a port-channel

PO21                    -          PO217

added int T5/1 and G3/17 to the associated port-channel and ping failed.

int T5/1

no switchport

no ip address

channel-protocol lacp

channel-group 21 mode active

no shut

int G3/17

no swithport

no ip address

channel-protocol lacp

channel-group 217 mode active

no shut

int po21

ip vrf forwarding SITE

ip address 10.10.127.122 255.255.255.252

flowcontrol recieve on

no shut

int po217

ip vrf forwarding SITE

ip address 10.10.127.121 255.255.255.252

no shut

po interface on both sides says up / up

log doesn't show any issues.

sho ip arp vrf SITE on switch 2 (po21) shows

#sho ip arp vrf SITE port-channel 21

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.10.127.122           -   2894.0f29.aaff  ARPA   Port-channel21

Internet  10.10.127.121         134   f866.f26d.0000  ARPA   Port-channel21

sho ip arp vrf SITE on switch 1 (po217) shows

#sho ip arp vrf SITE port-channel 217

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.10.127.121           -   f866.f26d.0000  ARPA   Port-channel217

2 REPLIES
Purple

Layer 3 port-channel Up / Up but can't ping across link

  Try adding "no switchport" to the port channel SVI .

New Member

Layer 3 port-channel Up / Up but can't ping across link

(config)#int po217

switch1(config-if)#nosw

switch1(config-if)#no sw

switch1(config-if)#no switchport

switch1(config-if)#^Z

(config)#int po21
Switch2(config-if)#no sw
Switch2(config-if)#no switchport
Switch2(config-if)#^Z
Switch2#ping vrf SITE 10.10.127.121

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.127.121, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Still fails

1752
Views
0
Helpful
2
Replies