Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Layer 3 routing

Hi,

Can show me the simple example of Layer 3 routing? For example, route host A connect to host B via the switch 3650. What kind of configuration need to  be put on the switch?

7 REPLIES
New Member

Re: Layer 3 routing

I do not think I understand your question. Are you trying to route between two hosts

that are physically conncted on the same switch but on different subnets?

New Member

Re: Layer 3 routing

Bingo. You are correct.

New Member

Re: Layer 3 routing

The L3 switch is L2 by default

if you need the switch come L3 you must enable routing by using this command

switch(config)#ip routing

Now the switch work L2 & L3

Re: Layer 3 routing

Hi,

Can show me the simple example of Layer 3 routing? For example, route host A connect to host B via the switch 3650. What kind of configuration need to  be put on the switch?

Hi,

Cisco 3560 series are L3 switches in order to make communication between vlan just confiogure ip routing in global mode with creating SVI for two vlan and rest will take care by 3560 switch for communication.

But not by default ports in 3560 are in l2 mode in order to make the port in L3 you need configure no switch port under interface level.


Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Blue

Re: Layer 3 routing

Folks:

Hes asked for a sample config.

Enter these commands at privileged exec mode on a L3 capable switch that has both hosts directly connected to the switch.

switch#conf t

switch(config)#

!enter these command lines!

ip routing (may be on by default)

vlan 2

name tax_division

vlan 3

name accounting_division

interface vlan 2

description default gateway for TAX Subnet

ip address 10.10.2.2 255.255.255.0

no shut

interface vlan 3

description default gateway for ACCOUNTING Subnet

ip address 10.10.3.2 255.255.255.0

no shut

interface gigabitethernet 1/0/1

description connection to  server on TAX Subnet

switchport mode access

switchport access vlan 2

no shut

interface gigabitethernet 1/0/2

description connection to server on ACCOUNTING Subnet

switchport mode access

switchport access vlan 3

no shut

You wont need a routing protocol because the hosts are directly connected and the switch is enabled for ip routing.

HTH

Victor

New Member

Re: Layer 3 routing

Thank for your response. If I want to restrict certain ports in between these 2 networks. How it can be done on the access list?

Hall of Fame Super Blue

Re: Layer 3 routing

ssweehinlew wrote:

Thank for your response. If I want to restrict certain ports in between these 2 networks. How it can be done on the access list?

Following on from Victor's post you would use acls ie.

access-list 101 deny tcp host 10.10.2.5 host 10.10.3.10 eq www

access-list 101 deny tcp 10.10.2.0 0.0.0.255 10.10.3.0 0.0.0.255 eq ftp

access-list 101 permit ip 10.10.2.0 0.0.0.255 10.10.3.0 0.0.0.255

int vlan 2

ip access-list 101 in

the above config would -

1)  stop host 10.10.2.5 connecting to the web server on 10.10.3.10

2) stop all ftp intitated traffic from 10.10.2.x to 10.10.3.x

3) allow everything else

Jon

1062
Views
5
Helpful
7
Replies
CreatePlease login to create content