Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

limiting bandwith on a cat 2960

hi,

i have a 2960 switch, on whic i have to limit the bandwith on port fa0/25 to 100kb/s.

i tried the command "srr-queue bandwith limit 10" and defined "bandw 1000" on the fa0/24.

so 10% of 1000kb/s is 100kb/s - but there was no effekt

any idea ?

2 REPLIES

Re: limiting bandwith on a cat 2960

Hi there,

It seems that you might be missing the magic keyword "mls qos" in global config mode.

This then tells the switch to read the qos commands on the interfaces.

Then try popping in the command "show mls qos interface f0/25 queue" and see if it's doing the business.

Let me know how it goes!

Regards

LH

** Please rate all posts **

Community Member

Re: limiting bandwith on a cat 2960

hi out there and thank you for your answer,

i configured the mls qos in global config.

here is the konfig - i am talking about fa0/24

- it should throttle down the traffic to 100kb/s

any idea

switch_zentrale#sh run

Building configuration...

Current configuration : 2065 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch_zentrale

!

!

no aaa new-model

ip subnet-zero

!

!

mls qos srr-queue output cos-map queue 1 threshold 1 6 7

mls qos

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

policy-map 20mega

class class-default

police 20000000 100000 exceed-action drop

policy-map 5mega

class class-default

police 5000000 10000 exceed-action drop

!

!

interface FastEthernet0/1

switchport mode trunk

no logging event link-status

srr-queue bandwidth limit 50

mls qos trust dscp

spanning-tree portfast

!

interface FastEthernet0/2

switchport mode trunk

no logging event link-status

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

no logging event link-status

spanning-tree portfast

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

switchport trunk allowed vlan 1-3,10,1002-1005

switchport mode trunk

bandwidth 1000

load-interval 30

srr-queue bandwidth share 2 3 3 2

srr-queue bandwidth limit 10

priority-queue out

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 1.1.1.1 255.255.255.0

no ip route-cache

!

ip http server

!

control-plane

!

!

line con 0

line vty 0 4

no login

line vty 5 15

no login

!

!

monitor session 1 source interface Fa0/24

monitor session 1 destination interface Fa0/3

!

end

switch_zentrale#show mls qos interface f0/24 queue

FastEthernet0/24

Egress Priority Queue : enabled

Shaped queue weights (absolute) : 25 0 0 0

Shared queue weights : 2 3 3 2

The port bandwidth limit : 10

The port is mapped to qset : 1

switch_zentrale#sh int fa0/24

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0018.b931.8b9a (bia 0018.b931.8b9a)

MTU 1500 bytes, BW 1000 Kbit, DLY 1000 usec,

reliability 255/255, txload 82/255, rxload 82/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:07, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 323000 bits/sec, 331 packets/sec

30 second output rate 324000 bits/sec, 333 packets/sec

268068 packets input, 32671441 bytes, 0 no buffer

Received 1033 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 205 multicast, 0 pause input

0 input packets with dribble condition detected

274864 packets output, 33136266 bytes, 0 underruns

814
Views
5
Helpful
2
Replies