Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Link Status unwanted in the log

Hello all,

I'm hoping you guys/girls can help me out?

I have a 2950 switch in which some ports are used as access ports and fa0/1 is an uplink.

I only want link status messages for the uplink (Fa0/1) to be sent to the log.

I thought that the command that prevents status messages being sent to the log was "no snmp trap link status" but as you can see - this is configured but messages are still being logged for access ports?

Can anybody please advise if this is the right command and if so why it is not working?

Many Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Link Status unwanted in the log

Hi.

The command you give is for avoiding having traps sent via SNMP to a management station.

In order to avoid messages in the log of the switch itself you have to use "no logging event link-status" on the interfaces, whre you do not want the messages.

HTH

4 REPLIES
New Member

Re: Link Status unwanted in the log

!

interface FastEthernet0/1

description LES10 to Crumpsall Clinic SHUK

switchport trunk allowed vlan 1,7,999,1002-4094

switchport mode trunk

speed 10

duplex full

!

interface FastEthernet0/2

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/8

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/9

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/10

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/11

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/12

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/13

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/14

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/15

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/16

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/17

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/18

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/19

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/20

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/21

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/22

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/23

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface FastEthernet0/24

switchport access vlan 7

switchport mode access

no snmp trap link-status

spanning-tree portfast

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

New Member

Re: Link Status unwanted in the log

on Interface FastEthernet0/4, changed s

tate to up

May 7 09:17:26.456: %SYS-5-CONFIG_I: Configured from console by vty0 (172.103.1

8.81)

May 7 09:23:27.130: %SYS-5-CONFIG_I: Configured from console by vty0 (172.103.1

8.81)

May 7 09:24:47.246: %SYS-5-CONFIG_I: Configured from console by vty0 (172.103.1

8.81)

May 7 18:07:00.950: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to down

May 7 18:07:02.946: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to up

May 8 07:48:22.620: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to down

May 8 07:48:23.628: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to

down

May 8 07:48:25.636: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to

up

May 8 07:48:26.636: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to up

May 8 07:48:37.540: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to down

May 8 07:48:39.548: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEtherne

t0/4, changed state to up

Bronze

Re: Link Status unwanted in the log

Hi.

The command you give is for avoiding having traps sent via SNMP to a management station.

In order to avoid messages in the log of the switch itself you have to use "no logging event link-status" on the interfaces, whre you do not want the messages.

HTH

New Member

Re: Link Status unwanted in the log

Thanks!

158
Views
0
Helpful
4
Replies