Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Linking two switches via Gbic problem

Hello,

I am trying to link a 3560 and 2960 switch via fiber. Both switches have 2x gbic ports. I have connected a GLC-SX-MM Gbic adaptor into the Gb0/2 port on both switches and used the appropriate fiber leads to connect to the fiber panel.

The fiber panel was installed by a third party, but they advised which leads to purchase, so I am quite sure they are correct. I have also done what research I could to ensure my Gbic adaptors are correct as per the lead spec and advice.

I have setup about a dozen or so Cisco switches/routers before but never had to configure gbic/fiber, so please bear with me .

So, I have everything plugged in, and I have assigned my Gb0/2 ports on each switch to the same VLAN, assuming they would just 'see' each other, as though I was connecting two switches via a cat5, but it doesn't appear to be working.

Am I forgetting something really basic, or Is there anything special I need to do in order to configure/enable these gbic adaptors? Both switches appear to register the adaptor but report the relevant ports as down:

"

ms-h002306>sh int gigabitEthernet 0/2

GigabitEthernet0/2 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is 7010.5c31.9bb2 (bia 7010.5c31.9bb2)

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP

  input flow-control is off, output flow-control is unsupported

"

Any help or advice would be much appreciated.

Thank you!

Elliot

Everyone's tags (3)
10 REPLIES
VIP Super Bronze

Re: Linking two switches via Gbic problem

Hi Elliot,

GigabitEthernet0/2 is down, line protocol is down (notconnect)

This message indicated that you have no connectivity between the switches.  There is no difference between configuring a copper port vs fiber.

If you are sure that the fiber and optics are good then lets try switching the fiber strands around on one side of the connections and test again. You maybe connecting TX to TX vs TX to RX.

Also, are you using the correct optic with correct fiber:

for 1000BaseSX SFP you need Multimode fiber.

HTH

New Member

Linking two switches via Gbic problem

Hi,

Plz clarify on the below points.

How you're connected the switches ? Is there any patch panel involving inbetween?

Are you using the same  GLC-SX-MM module both the side?

If you're using WS-C3560E, the minimum IOS should be 12.2(40)EX

What's the IOS version running?

Could you post the show running, show version , show inventory and show interfaces XX ?

What's the exact model of the 2960 switch??

I doubt it whether GLC-SX-MM module would support on 2960 switch. However plz chk with the

Cisco Gigabit Ethernet Transceiver Modules Compatibility Matrix by using below link.

http://www.cisco.com/en/US/docs/interfaces_modules/transceiver_modules/compatibility/matrix/OL_6981.html

Regards,

Amir

New Member

Linking two switches via Gbic problem

On one of your switches try reversing the pairs.

New Member

Linking two switches via Gbic problem

Hi all,

Thank you for your replies thus far. I will try and answer all questions:

The 2960 is a WS-C2960-48TC-S with IOS v12.2(53r)SEY3. According to the link you provided it should support my GLC-SX-MM module with its current IOS.

The 3560 is a WS-C3560V2-24TS with IOS v15.0(1)SE.

Yes, the fiber is multi-mode. This was advised to me by the fiber engineer. He also specified the LC to SC 50/125 configuration.

My connectivity is as follows:

3560/Gbic--> multimode fiber lead -> fiber panel <-- multimode fiber lead <-- 2960/Gbic

These are the Gbic modules I am using at both ends: http://www.misco.co.uk/Product/46742/Cisco-GE-SFP-LC-connector-SX-transceiver

And the leads: http://www.misco.co.uk/Product/154824/C2G-1m-Lc-sc-Duplex-50-125-Multimode-Fibre-Patch-Cable

When you suggest switching the fiber strands around, are you implying I physically mess with the work the fiber engineer has done? The fiber leads I have don't appear to be easily reconfigurable, at least without the risk of breaking them.

I will advise additional config info in a second post.

Thank you all for your help!

Elliot

New Member

Linking two switches via Gbic problem

DETAILS FOR 2960

------------------------------------------------------------------------------------------------------------

ms-h002306>sh inventory

NAME: "1", DESCR: "WS-C2960-48TC-S"

PID: WS-C2960-48TC-S   , VID: V06  , SN: FCQ1708Y7UZ

NAME: "GigabitEthernet0/2", DESCR: "1000BaseSX SFP"

PID: Unspecified       , VID:      , SN: AGM1708L1HM

------------------------------------------------------------------------------------------------------------

ms-h002306>sh ver

Cisco IOS Software, C2960 Software (C2960-LANLITEK9-M), Version 12.2(55)SE5, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Thu 09-Feb-12 19:11 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x01400000

ROM: Bootstrap program is C2960 boot loader

BOOTLDR: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(53r)SEY3, RELEASE SOFTWARE (fc1)

ms-h002306 uptime is 2 days, 16 hours, 59 minutes

System returned to ROM by power-on

System image file is "flash:/c2960-lanlitek9-mz.122-55.SE5/c2960-lanlitek9-mz.122-55.SE5.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C2960-48TC-S (PowerPC405) processor (revision M0) with 65536K bytes of memory.

Processor board ID FCQ1708Y7UZ

Last reset from power-on

2 Virtual Ethernet interfaces

48 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

64K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 70:10:5C:31:9B:80

Motherboard assembly number     : 73-12596-06

Power supply part number        : 341-0097-03

Motherboard serial number       : FCQ17080LPR

Power supply serial number      : DCA170486YN

Model revision number           : M0

Motherboard revision number     : A0

Model number                    : WS-C2960-48TC-S

System serial number            : FCQ1708Y7UZ

Top Assembly Part Number        : 800-32804-02

Top Assembly Revision Number    : A0

Version ID                      : V06

CLEI Code Number                : COMSG00ARC

Hardware Board Revision Number  : 0x0B

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 50    WS-C2960-48TC-S    12.2(55)SE5           C2960-LANLITEK9-M

Configuration register is 0xF

------------------------------------------------------------------------------------------------------------

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.07.22 10:21:34 =~=~=~=~=~=~=~=~=~=~=~=

ms-h002306#sh run

Building configuration...

Current configuration : 6937 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ms-h002306

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 xxx

!

username administrator privilege 15 secret 5 xxx

username ccpuser privilege 15 secret 5 xxx

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication enable default enable

aaa authorization exec default local

!

!

!

aaa session-id common

system mtu routing 1500

!

!

ip domain-name hayley-group.local

ip name-server 10.11.1.217

!

!

crypto pki trustpoint TP-self-signed-1546754944

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1546754944

revocation-check none

rsakeypair TP-self-signed-1546754944

!

!

crypto pki certificate chain TP-self-signed-1546754944

certificate self-signed 01

  30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31353436 37353439 3434301E 170D3933 30333031 30303031

  30305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35343637

  35343934 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BC68 78CC6DD2 7F605761 3DC60349 7919949B 51A22D68 940B5FBA 1643A16D

  34B13AB7 775DB5FA EE92A5B8 4409FFDF 4090A30D 86F6ECB3 2783FBEA F6ED3FE2

  675DE132 B0035282 764DE04A D9C0454A 3955A947 8F2D23C2 8790C55C 155C6B8F

  9247EEF4 6569629F E2C9A1DC 18FE5386 CC05688D 84549313 013FBE62 BC575D93

  F5D70203 010001A3 7D307B30 0F060355 1D130101 FF040530 030101FF 30280603

  551D1104 21301F82 1D6D732D 68303032 3330362E 6861796C 65792D67 726F7570

  2E6C6F63 616C301F 0603551D 23041830 168014C5 F35F8450 698A6CA1 7086B952

  5BD3F11B E366BD30 1D060355 1D0E0416 0414C5F3 5F845069 8A6CA170 86B9525B

  D3F11BE3 66BD300D 06092A86 4886F70D 01010405 00038181 005C65E4 6A9B33BD

  34789990 8ED2D13D 9846A04A AF11603C 0DA31E86 97E6B2CB 1AE93E6A 53CC95BC

  D9956E3A E3C5D4A2 C41CA5E9 DD348D2C EB413293 FD29C1C1 FBD137F4 09D19DD2

  8B02A9CE 2408C013 0F8FF339 EFA9A31C 4220D0BF 41DBAFE3 29F1B362 6BBACBBB

  BCD7691D CACA2F4F 4F28C976 35D2E1E1 B9201038 87EAB926 BD

  quit

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/1

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/22

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/23

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/24

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/25

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/26

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/27

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/28

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/29

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/30

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/31

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/32

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/33

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/34

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/35

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/36

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/37

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/38

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/39

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/40

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/41

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/42

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/43

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/44

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/45

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/46

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/47

switchport access vlan 23

switchport mode access

!

interface FastEthernet0/48

switchport access vlan 23

switchport mode access

!

interface GigabitEthernet0/1

switchport access vlan 23

switchport mode access

!

interface GigabitEthernet0/2

switchport access vlan 23

switchport mode access

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan23

ip address 10.11.23.251 255.255.255.0

no ip route-cache

!

ip default-gateway 10.11.23.254

no ip http server

ip http secure-server

snmp-server community hgp-switches RO

snmp-server location Halesowen Unit 2

snmp-server contact Group IT

snmp-server chassis-id ms-h002306

!

line con 0

line vty 0 4

exec-timeout 0 0

privilege level 15

line vty 5 15

exec-timeout 0 0

privilege level 15

!

end

ms-h002306#

New Member

Linking two switches via Gbic problem

DETAILS FOR 3560v2

ms-h001837#sh inv

NAME: "1", DESCR: "WS-C3560V2-24TS"

PID: WS-C3560V2-24TS-E , VID: V05  , SN: FDO1519X2YA

NAME: "GigabitEthernet0/2", DESCR: "1000BaseSX SFP"

PID: Unspecified       , VID:      , SN: AGM1708L1JM

------------------------------------------------------------------------------------------------------------

ms-h001837#sh ver

Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 15.0(1)SE, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Wed 20-Jul-11 06:02 by prod_rel_team

ROM: Bootstrap program is C3560 boot loader

BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(53r)SEY4, RELEASE SOFTWARE (fc1)

ms-h001837 uptime is 9 weeks, 5 days, 17 hours, 37 minutes

System returned to ROM by power-on

System image file is "flash:/c3560-ipservicesk9-mz.150-1.SE/c3560-ipservicesk9-mz.150-1.SE.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C3560V2-24TS (PowerPC405) processor (revision L0) with 131072K bytes of memory.

Processor board ID FDO1519X2YA

Last reset from power-on

4 Virtual Ethernet interfaces

24 FastEthernet interfaces

2 Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : 58:35:D9:53:D1:80

Motherboard assembly number     : 73-12636-01

Power supply part number        : 341-0328-02

Motherboard serial number       : FDO15200CMY

Power supply serial number      : LIT15100FDK

Model revision number           : L0

Motherboard revision number     : B0

Model number                    : WS-C3560V2-24TS-E

System serial number            : FDO1519X2YA

Top Assembly Part Number        : 800-33980-01

Top Assembly Revision Number    : B0

Version ID                      : V05

CLEI Code Number                : COMKZ00DRB

Hardware Board Revision Number  : 0x01

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 26    WS-C3560V2-24TS    15.0(1)SE             C3560-IPSERVICESK9-M

Configuration register is 0xF

------------------------------------------------------------------------------------------------------------

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.07.22 10:35:12 =~=~=~=~=~=~=~=~=~=~=~=

sh run

Building configuration...

Current configuration : 5346 bytes

!

! Last configuration change at 00:47:14 UTC Thu May 6 1993 by administrator

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ms-h001837

!

boot-start-marker

boot-end-marker

!

!

no logging console

enable secret 5 xxx

!

username sas-admin privilege 15 secret 5 xxx

username ejohnson privilege 15 secret 5 xxx

username administrator privilege 15 password 7 xxx

username ccpuser privilege 15 secret 5 xxx

aaa new-model

!

!

aaa authentication login default local

aaa authentication enable default enable

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

system mtu routing 1500

ip routing

ip domain-name hayley-group.local

ip name-server 10.11.1.217

!

!

!

!

!

crypto pki trustpoint TP-self-signed-3646148992

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3646148992

revocation-check none

rsakeypair TP-self-signed-3646148992

!

!

crypto pki certificate chain TP-self-signed-3646148992

certificate self-signed 01

  3082025A 308201C3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363436 31343839 3932301E 170D3933 30333031 30303031

  30335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36343631

  34383939 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CADF 226D3C0F 2E0E8CDA AEFDE358 E34BFF26 C748F190 2BD671C2 557190C5

  6B443BAC B0C54D76 54848149 08349F83 5719CA98 988A274E 3EB6530E C47B7DBF

  9F75DEC2 77082155 47E3B7FD C1794709 2877F647 F3D2F505 FF001B71 9F8E1A94

  360EEB6D 68990C20 1DCA7330 77244BCA 1AA736CE 548949DE 24372BFE E0E4BE85

  02C90203 010001A3 8181307F 300F0603 551D1301 01FF0405 30030101 FF302C06

  03551D11 04253023 82216D73 2D687132 2D683030 31383337 2E686179 6C65792D

  67726F75 702E6C6F 63616C30 1F060355 1D230418 30168014 1E09384B BC4E2824

  F84BDC52 DE6F5D07 09C7D930 301D0603 551D0E04 1604141E 09384BBC 4E2824F8

  4BDC52DE 6F5D0709 C7D93030 0D06092A 864886F7 0D010104 05000381 81007C33

  9CA8126B E91B6657 D0213595 F7D2C79A 966C72E1 50038BB6 1F7BE7C7 077DB6E0

  EDC4E464 515348F9 65D3B963 7174E7FE E3B67C63 4CD4CD38 FC4AA19D 7BF8ABDA

  91F0804E 10D9D977 8C22EEAE B2203B3D 09C9D27E AC8A7A2C 3E8B939E EF7DCCD5

  621B6240 4F45590E BBD2F143 D5EA1A01 B10D4E26 51EEE871 39C86C8F 61F7

            quit

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

!

!

!

interface FastEthernet0/1

description Direct link to LES10

switchport access vlan 21

speed 10

duplex full

!

interface FastEthernet0/2

switchport access vlan 22

!

interface FastEthernet0/3

switchport access vlan 22

!

interface FastEthernet0/4

switchport access vlan 22

!

interface FastEthernet0/5

switchport access vlan 22

!

interface FastEthernet0/6

switchport access vlan 22

!

interface FastEthernet0/7

switchport access vlan 22

!

interface FastEthernet0/8

switchport access vlan 22

!

interface FastEthernet0/9

switchport access vlan 22

!

interface FastEthernet0/10

switchport access vlan 22

!

interface FastEthernet0/11

switchport access vlan 22

!

interface FastEthernet0/12

switchport access vlan 22

!

interface FastEthernet0/13

switchport access vlan 22

!

interface FastEthernet0/14

switchport access vlan 22

!

interface FastEthernet0/15

switchport access vlan 22

!

interface FastEthernet0/16

switchport access vlan 22

!

interface FastEthernet0/17

switchport access vlan 22

!

interface FastEthernet0/18

switchport access vlan 22

!

interface FastEthernet0/19

switchport access vlan 22

!

interface FastEthernet0/20

switchport access vlan 22

!

interface FastEthernet0/21

switchport access vlan 22

!

interface FastEthernet0/22

description test vlan23 port

switchport access vlan 23

!

interface FastEthernet0/23

description Uplink from Nortel BayStack switch

switchport access vlan 22

!

interface FastEthernet0/24

description Direct link to SAS Cisco 1941 router

switchport access vlan 22

!

interface GigabitEthernet0/1

switchport access vlan 23

!

interface GigabitEthernet0/2

description Link to unit 2 switch

switchport access vlan 23

!

interface Vlan1

no ip address

shutdown

!

interface Vlan21

description EIGRP Peering

ip address 10.11.21.2 255.255.255.252

!

interface Vlan22

description VLAN22 (10.11.22.0 subnet)

ip address 10.11.22.246 255.255.255.0

ip helper-address 10.11.200.3

standby 22 ip 10.11.22.254

standby 22 priority 115

standby 22 preempt

!

interface Vlan23

description Unit 2 VLAN

ip address 10.11.23.246 255.255.255.0

ip helper-address 10.11.200.3

standby 23 ip 10.11.23.254

standby 23 priority 115

standby 23 preempt

!

!

router eigrp 11

network 10.11.21.2 0.0.0.0

network 10.11.22.246 0.0.0.0

network 10.11.23.246 0.0.0.0

!

ip default-gateway 10.11.22.254

ip http server

ip http authentication local

ip http secure-server

!

!

!

logging esm config

!

!

!

!

privilege exec level 0 enable

!

line con 0

privilege level 15

line vty 0 4

exec-timeout 15 0

privilege level 15

line vty 5 15

exec-timeout 0 0

privilege level 15

transport input none

!

end

ms-h001837#

New Member

Linking two switches via Gbic problem

Hi all,

I came across this article: http://voices.yahoo.com/configure-vlan-trunks-cisco-switches-1774003.html?cat=15

So have adjusted my 2960's Gb0/2 interface as follows:

interface GigabitEthernet0/2

switchport access vlan 23

switchport trunk native vlan 23

switchport mode trunk

media-type sfp

I also adjusted my 3560's Gb0/2 interface as:

interface GigabitEthernet0/2

description Link to unit 2 switch

switchport access vlan 23

switchport trunk encapsulation dot1q

switchport trunk native vlan 23

switchport mode trunk

Unfortunately, this hasn't made any difference.

Based on the output of "#sh interfaces gigabitEthernet 0/2" (in previous posts), is it the physical link I should be concerned about at this stage, and not the VLAN config etc?

Thanks

New Member

Linking two switches via Gbic problem

Woohoo, I think it's cracked!

Eventually I plucked up the courage to take the fascia off the fiber panel and started working out if it crossed over at any point leading back to the other of the line. It didn't appear to cross-over at all so I decided to fiddle and managed to swap one of the fiber coupling in the panel over.

Both interfaces came up! I started seeing a flashing light on the switches! And my test laptop picked up an IP from across the fiber. Excellent

Thank you all for your help folks, but one last question if I may... shall I keep my "trunk" setup as is now? Or remove the trunk settings to how they were before?

Thanks.

Elliot

New Member

Linking two switches via Gbic problem

Top man!!

New Member

Man,

Man,

You are my hero, you save my night. I made exactly what you did and it works!!!

I owe you a tequila bottle.

3070
Views
5
Helpful
10
Replies