Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Load Balancing with Static Routes

I have two 6506's with VS-S720-10G modules and VSS is implemented. This "device" (two 6506's VSS'ed) has two connections to individual upstream routers. I am routing out of my device with static routes over switchports (trunks), using vlan interfaces. My question is, "will outgoing traffic (from the 10.0.0.0/8 space) be load balanced with the routing shown in the config below, and if so what type of load balancing will be done and how can I change it?"

Thanks, Chad

track 111 interface GigabitEthernet1/6/3 line-protocol

!

track 222 interface GigabitEthernet2/6/3 line-protocol

!

interface GigabitEthernet1/6/3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900

switchport mode trunk

spanning-tree portfast trunk

!

interface GigabitEthernet2/6/3

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 901

switchport mode trunk

spanning-tree portfast trunk

!

interface Vlan10

ip address 10.10.1.1 255.255.255.0

!

interface Vlan20

ip address 10.20.1.1 255.255.255.0

!

interface Vlan30

ip address 10.30.1.1 255.255.255.0

!

interface Vlan900

ip address 172.16.7.2 255.255.255.252

!

interface Vlan901

ip address 172.16.8.2 255.255.255.252

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.7.1 track 111

ip route 0.0.0.0 0.0.0.0 172.16.8.1 track 222

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Gold

Re: Load Balancing with Static Routes

Chad

I am not sure on what basis Ido says that 2 static default routes will not load balance. But in my experience 2 equal static default routes load balance just fine. The output you post of cef exact route confirms that you will get load balancing.

HTH

Rick

Hall of Fame Super Bronze

Re: Load Balancing with Static Routes

Hi Chad,

My question is, "will outgoing traffic (from the 10.0.0.0/8 space) be load balanced with the routing shown in the config below, and if so what type of load balancing will be done and how can I change it?"

Yes, they will be load-balanced and you can manipulate the default behavior with the command illustrated on this link:

http://www.cisco.com/en/US/docs/ios/ipswitch/command/reference/isw_i1.html#wp1011833

HTH,

__

Edison

9 REPLIES
Community Member

Re: Load Balancing with Static Routes

By default you can only have one candidate default route in your routing table (you can have many routes, but only one will be candidate).

If you want to load balance there are a few of ways to do that, you could use GLBP although it will require some changes, also you can use route maps along with any routing protocol you want.

Regards,

Ido.

Community Member

Re: Load Balancing with Static Routes

Are you positive? If i look at my routing table and cef it appears as if it were going to loadbalance. Even with the cef exact-route command it shows it load balancing. Can you help me understand why i am seeing the following if it will not loadblance?

6506vss#show ip ro

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.8.1 to network 0.0.0.0

172.16.0.0/30 is subnetted, 2 subnets

C 172.16.8.0 is directly connected, Vlan901

C 172.16.7.0 is directly connected, Vlan900

S* 0.0.0.0/0 [1/0] via 172.16.8.1

[1/0] via 172.16.7.1

6506vss#show ip cef exact-route 10.10.1.10 76.76.8.96

10.10.1.10 -> 76.76.8.96 => IP adj out of Vlan901, addr 172.16.8.1

6506vss#show ip cef exact-route 10.20.1.10 76.76.8.96

10.20.1.10 -> 76.76.8.96 => IP adj out of Vlan901, addr 172.16.8.1

6506vss#show ip cef exact-route 10.30.1.10 76.76.8.96

10.30.1.10 -> 76.76.8.96 => IP adj out of Vlan900, addr 172.16.7.1

6506vss#show ip cef exact-route 10.30.1.20 76.76.8.96

10.30.1.20 -> 76.76.8.96 => IP adj out of Vlan900, addr 172.16.7.1

6506vss#show ip cef exact-route 10.30.1.30 76.76.8.96

10.30.1.30 -> 76.76.8.96 => IP adj out of Vlan900, addr 172.16.7.1

6506vss#show ip cef exact-route 10.30.1.40 76.76.8.96

10.30.1.40 -> 76.76.8.96 => IP adj out of Vlan901, addr 172.16.8.1

6506vss#show ip cef exact-route 10.30.1.50 76.76.8.96

10.30.1.50 -> 76.76.8.96 => IP adj out of Vlan901, addr 172.16.8.1

6506vss#show ip cef exact-route 10.30.1.60 76.76.8.96

10.30.1.60 -> 76.76.8.96 => IP adj out of Vlan901, addr 172.16.8.1

6506vss#show ip cef exact-route 10.30.1.70 76.76.8.96

10.30.1.70 -> 76.76.8.96 => IP adj out of Vlan900, addr 172.16.7.1

Hall of Fame Super Gold

Re: Load Balancing with Static Routes

Chad

I am not sure on what basis Ido says that 2 static default routes will not load balance. But in my experience 2 equal static default routes load balance just fine. The output you post of cef exact route confirms that you will get load balancing.

HTH

Rick

Community Member

Re: Load Balancing with Static Routes

Thanks Rick, that i what i thought based on what i was seeing. I just had a hard time finding documentation to back it up. Thanks

Hall of Fame Super Bronze

Re: Load Balancing with Static Routes

Hi Chad,

My question is, "will outgoing traffic (from the 10.0.0.0/8 space) be load balanced with the routing shown in the config below, and if so what type of load balancing will be done and how can I change it?"

Yes, they will be load-balanced and you can manipulate the default behavior with the command illustrated on this link:

http://www.cisco.com/en/US/docs/ios/ipswitch/command/reference/isw_i1.html#wp1011833

HTH,

__

Edison

Community Member

Re: Load Balancing with Static Routes

Thanks Edison. I want to do source destination load balancing but don't see the syntax in my IOS to do that. Here is what i see when trying to implement the recommended commands you sent in the previous link.

6506vss(config)#ip cef load-sharing algorithm ?

original Original algorithm

tunnel Algorithm for use in tunnel only environments

universal Algorithm for use in most environments

Is this an IOS limitation. I am running the following image.

s72033-ipservicesk9_wan-mz.122-33.SXH2a.bin

Hall of Fame Super Bronze

Re: Load Balancing with Static Routes

On the 'command history' section from the link I posted, please refer to the details on the 12.2SX.

With that said, I suspect the support on the 6500 can be quite limited. Perhaps trying a different feature set may help or play around with the current options available and see if load-balancing can be improved.

The Universal option provides an additional feature - the 'ID Hash'.

__

Edison.

Community Member

Re: Load Balancing with Static Routes

So now the question lies, is it my current feature set, platform, or hardware that has the limitation? If i can get cef source-destination load balancing with a license upgrade to a new feature set then I would be willing to do that. If it is my hardware then I probably would say I am stuck with what I have.

Hall of Fame Super Bronze

Re: Load Balancing with Static Routes

Reading the command history again, it actually displays the answer right there.

As you see, only 12.4(11)T and later have the options other than the 2 available in the 6500. I'm sorry, you are limited to only 2 options :(

__

Edison.

403
Views
0
Helpful
9
Replies
CreatePlease to create content