Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Load -Balancing

Hi,

I have two switch and 1 portchannel created, this portchannel have associated two interfaces. I need to balance the traffic between the two interfaces.

The configuration is:

Switch 4507R

interface GigabitEthernet3/48 (electrical)

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

interface GigabitEthernet5/6 (optical)

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

Switch 3750G

interface GigabitEthernet1/0/2(Electrical)

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

interface GigabitEthernet1/0/25 (optical)

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

Operation Mode:

4507R

EtherChannel Load-Balancing Operational State (dst-mac)

3750G

EtherChannel Load-Balancing Operational State (src-mac)

that option is not balancing, What can I make about this ?

Sorry but my english is no good.

Regards.

1 REPLY

Re: Load -Balancing

You need to know a little about your traffic and how a channel works. If you have a single system at each end, with a single IP address and a single MAC address running a single connection, you will not get load balancing.

If you gave a router at each end, carrying lots of traffic for many systems, by default it will not balance, but you can get it to. Similarly, if you have a router one end, and server the other, you may not get the balancing you want.

The options are:

port-channel load-balance ?

dst-ip Dst IP Addr

dst-mac Dst Mac Addr

dst-port Dst TCP/UDP Port

src-dst-ip Src XOR Dst IP Addr

src-dst-mac Src XOR Dst Mac Addr

src-dst-port Src XOR Dst TCP/UDP Port

src-ip Src IP Addr

src-mac Src Mac Addr

src-port Src TCP/UDP Port

Giving lots of options. You need to know what the traffic is to pick the most appropriate.

Paul.

378
Views
0
Helpful
1
Replies
CreatePlease to create content