Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Loading newer IOS on 2960 Switch.

I have (2) 2960 switches. One is newer then the other and I wanted to update the other switch with the latest software so that I have the same software on the 2960's.

On SWA the IOS is C2960-lanbase-mz.122-25.SEE2.bin

On SWB the IOS is C2960-lanbase-mz.122-35.SE5.bin

The dir that they are in are C2960-lanbase-mz.122-35.SE5 and C2960-lanbase-mz.122-25.SEE2. I tar the SWB IOS and have it on the tftp server and even xtracted it to flash on SWA. This way I have all the files inside the folder with it.

The problem is when I run the archive download-sw flash: or from tftp I get an error

%Error opening flash:update/info (No such file or directory)

Error: Image is not a valid IOS image archive.

Can I not replace the IOS for some reason?

3 REPLIES
Purple

Re: Loading newer IOS on 2960 Switch.

Are you using a .tar file ? You can't use the archive command on a .bin file . What syntax are you using when trying to download? Can you post the whole command?

New Member

Re: Loading newer IOS on 2960 Switch.

Yes Im using a .tar file. I created it with archive tar /create tftp://ip/save.tar flash:bin file

I have that working. When I run the

archive download-sw /overwrite /reload tftp://192.168.1.199/c2960-lanbase-mz.122-35.SE5.tar

These errors happen with out the 2 options overwrite and reload.

HQ-xdc-swB#$/reload tftp://192.168.1.199/c2960-lanbase-mz.122-35.SE5.tar

Loading c2960-lanbase-mz.122-35.SE5.tar from 192.168.1.199 (via Vlan192): !!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[OK - 8609792 bytes]

Loading c2960-lanbase-mz.122-35.SE5.tar from 192.168.1.199 (via Vlan192): !!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

examining image...

extracting info (476 bytes)

ERROR: Image is not a valid IOS image archive.

HQ-xdc-swB#

I did get it to load by tftping and xtracting the file to a file and changing the boot system. But dont know why it wouldnt work the way it should.

Purple

Re: Loading newer IOS on 2960 Switch.

Unless you need GUI function you don't really need the tar file and could just use the .bin file. I'm not sure if there is enough space in flash on the 2960's for 2 images or not , if not just delete the current .bin or directory and copy or tftp the new one in . Just check to see how much space you have left in flash, "dir flash: and see if the .bin will fit in there if not then delete the old image . Then just do a copy tftp flash: , hit enter it will ask server ip , put that in hit enter and it will ask you the filename at which point you put in the filename like c2960-lanbase-mz.122-35.SE5.bin, hit enter and it should download . Set your boot statement if you have more than 1 image in flash otherwise it will find it without a boot statement if its the only image.

2784
Views
0
Helpful
3
Replies