Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

Bronze

Local Switching via ASR1002

Please see the attached diagram to explain the network.

I'm trying to do a "port-to-port" layer 2 connection on an ASR that will bi-directionally bridge a physical interface to a sub-interface.

I tried using " connect VLAN200 Gig0/1/0 Gig0/0/3.200 interworking ethernet " but I'm not getting traffic through the connection.

Has anyone gotten this to work?  If so, how?  I don't think BDI will work because it requires a Layer 3 point.  I have to make this Layer 2 switching.

Thanks!

Ven

Ven Taylor
Everyone's tags (4)
5 REPLIES
Bronze

Local Switching via ASR1002

In case anyone else runs across a need for this, I figured out a solution.

EVC is the new bridging for the ASR platform.

Configuration is simple enough:

Interface g0/0/1

description first EVC interface

no ip address

service interface 100 ethernet

encapsulation dot1q 100

bridge-domain 100

no shut

!

interface g0/0/3

description first EVC interface

no ip address

service interface 100 ethernet

encapsulation dot1q 100

bridge-domain 100

no shut

!

end

This essentially bridges the two physical interfaces together (bi-directionally) so all ethernet traffic with a dot1q tag of 100 will bridge across the router.

No un-tagged traffic will bridge.

Here's the link:

http://www.cisco.com/en/US/docs/ios-xml/ios/cether/configuration/xe-3s/ce-ether-vc-infra-xe.html

Ven

This also allows you to configure multiple service instances per physical interface, so it's scalable.

Ven Taylor
New Member

Local Switching via ASR1002

Hi Ven,
do you have working config for multiple service instances per interface (like switchport trunk on a switch)?

Local switching works for me when I use one interface per Vlan, single service instance per interface on ASR.
Unable to make it working when I try to add second service instance on interface and make it switchport trunk on the connected switch (N7K).
The config is below, when "service instance 23 ethernet" sits on another phy interface it works.
Once i add it to this interface as second instance, it doesn't work (another int is shut).
Switch sees ASR via cdp, but ASR doesn't see the switch in this case.

interface GigabitEthernet0/1/2
no ip address
negotiation auto
cdp enable
service instance 21 ethernet
  encapsulation dot1q 21
!  rewrite ingress tag translate 1-to-1 dot1q 21 symmetric
  bridge-domain 21
!
service instance 23 ethernet
  encapsulation dot1q 23
  bridge-domain 23

interface BDI21
ip address 192.168.253.209 255.255.255.240
ip nat inside
ip policy route-map PBR-GOOGLE
cdp enable
!
interface BDI23
ip address 10.1.1.1 255.255.255.0
cdp enable
!

Thank you
Alexander Gesse

Bronze

Local Switching via ASR1002

Alexander:

I may be mistaken, but I don't think it will work like that for you.

I couldn't get the ASRs to do BDI's like that.  This is the "old-school" method of doing BDI.

In it's simplest form, the ASR will "bridge" or "locally switch" when two physical interfaces are identified with the same service instance.  Put simply, if two physical interfaces are configured with the same service interface and bridge-domain ID, packets with the proper vlan tag coming into one interface will locally switch out of the other interface.

Can you provide a quickie diagram of what you're trying to accomplish?

Ven

Ven Taylor
New Member

Local Switching via ASR1002

Hi Ven

thank you for taking time. I actually figured out where i was mistaken and was going to update my post so someone may benefit later. The key is to have appropriate "encapsulation" statement on BDI interface as well, matching the bridge-domain and encap numbers in Service Instance part.

I am basically doing a router on stick, having N7K as a switch with trunk going to ASR as a router on stick and doing inter-vlan routing. The BDI interfaces are serving as Interface-Vlan interfaces here. It works.

Thank you

Alexander

Bronze

Local Switching via ASR1002

Can you show me your config so I can see what you changed?  I'd like to have this info too.

Ven

Ven Taylor
1998
Views
0
Helpful
5
Replies
CreatePlease to create content