Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Lock and key problems on 3750-x ?

simple test

PC(172.16.13.1) ---- switch (GW.100) ----- PC (172.16.14.10)

From PC 172.16.14.10, I can ping PC 172.16.13.1 when the dynamic entry has NOT been activated with the autocommand:

> ping from PC 172.16.14.10 to PC 172.16.13.1 WORKS ! WRONG BEHAVIOUR ! WHY IS NOT BLOCKED !

> ping from PC 172.16.14.10 to 172.16.13.100 or 172.16.14.100 fail (RIGHT BEHAVIOUR).

Only traffic to IPs on switch are blocked ... any communication to IPs outside switch is allowed even if the dynamic entry has not been activated!

If I activate the entry also communication to IP on switch (.100) works ...

Switch#sh access-l 101
Extended IP access list 101
    10 Dynamic test permit ip any any
    20 deny ip any any (164 matches)

Switch#sh ip arp vl 10
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.13.1             5   0004.764c.7eb2  ARPA   Vlan10
Internet  172.16.13.100           -   c84c.7585.c341  ARPA   Vlan10
Switch#sh ip arp vl 20
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.14.10            0   0026.9e2c.cbc4  ARPA   Vlan20
Internet  172.16.14.100           -   c84c.7585.c342  ARPA   Vlan20

Config:

---------

username test password test

!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 20
switchport mode access
!

interface Vlan10
ip address 172.16.13.100 255.255.255.0
!
interface Vlan20
ip address 172.16.14.100 255.255.255.0

ip access-group 101 in
!

access-list 101 dynamic test permit ip any any
access-list 101 deny   ip any any

line vty 0 15

login local

autocommand access-enable

3 REPLIES

Re: Lock and key problems on 3750-x ?

Hello,

Let's start with basic issue:

On the switch, do an access-list:

access-list 101 deny ip any any

Apply this ACL to interface to VLAN 20.

Try to ping from PC (172.16.14.10) anything: 172.16.14.100, 172.16.13.100, 172.16.13.1

It is working?

Cheers,

Calin

New Member

Re: Lock and key problems on 3750-x ?

hi,

"normal" access-list works fine. If I configure your ACL to deny all traffic, traffic is blocked.

Dynamic ACL seems not to work correclty on 3750-x. Try my config and you will see !

I opened a TAC today about this issue !

New Member

Re: Lock and key problems on 3750-x ?

I opened a case: dynamic ACL (lock and key) IS NOT SUPPORTED ON 3750, 3750E, 3750X ....

SEE BUG ID : CSCsv63203

no plans to support it >> see doc below !

Configuring IPv4 ACLs

Configuring IP v4ACLs on the switch is the same as configuring IPv4 ACLs on other Cisco switches and routers. The process is briefly described here. For more detailed information on configuring ACLs, see the "Configuring IP Services" section in the "IP Addressing and Services" chapter of the Cisco IOS IP Configuration Guide, Release 12.2. For detailed information about the commands, see the Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2.

The switch does not support these Cisco IOS router ACL-related features:

Non-IP protocol ACLs (see Table 36-1) or bridge-group ACLs

IP accounting

Inbound and outbound rate limiting (except with QoS ACLs)

Reflexive ACLs or dynamic ACLs (except for some specialized dynamic ACLs used by the switch clustering feature)

ACL logging for port ACLs and VLAN maps

522
Views
0
Helpful
3
Replies
CreatePlease login to create content