Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Long cable, EMI and performance.

Hi,

I have two 2600s linked via Uplink. Coping data across the uplink is extremely slow (< 5mbit/s throughput), yet, there are no errors on any interfaces. I'm suspecting that this is EMI and we are replacing the links with Fiber now, but I'm very curious as to why there are no interface errors?

On my CORE switch:

CTN-SWCORE01#sh ru int fa0/17

interface FastEthernet0/17

description Uplink to CTN-SWEDGE04

switchport mode trunk

storm-control broadcast level 90.00 65.00

storm-control multicast level 90.00 65.00

storm-control action shutdown

spanning-tree link-type point-to-point

end

CTN-SWCORE01#sh int fa0/17

FastEthernet0/17 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 001b.54aa.3b11 (bia 001b.54aa.3b11)

Description: Uplink to CTN-SWEDGE04

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:06, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 341000 bits/sec, 186 packets/sec

5 minute output rate 433000 bits/sec, 200 packets/sec

625125921 packets input, 619649107 bytes, 0 no buffer

Received 1098912 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 434604 multicast, 0 pause input

0 input packets with dribble condition detected

933371791 packets output, 3652517704 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

The EDGE switch:

CTN-SWEDGE04#sh ru int fa0/24

interface FastEthernet0/24

switchport mode trunk

spanning-tree link-type point-to-point

end

CTN-SWEDGE04#sh int fa0/24

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 001d.463c.0498 (bia 001d.463c.0498)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:03, output hang never

Last clearing of "show interface" counters 13w2d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 392000 bits/sec, 178 packets/sec

5 minute output rate 299000 bits/sec, 167 packets/sec

925503548 packets input, 3893419558 bytes, 0 no buffer

Received 77326833 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 54694110 multicast, 0 pause input

0 input packets with dribble condition detected

621020130 packets output, 3879067401 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Any ideas as to why the uplink is so slow, why there are no errors being shown, and how to investigate whether this is in fact EMI, and whether replacing the copper link with Fiber will solve my problem?

Thanks,

Chris.

9 REPLIES
Super Bronze

Re: Long cable, EMI and performance.

The less the 5 Mbps, is this just from when you view 5 minute interface usage stats on the switches, or have you also tested with a traffic generator?

Have you verified all other interfaces, end-to-end, also show no interface errors?

Purple

Re: Long cable, EMI and performance.

if you aren't getting any errors on either side its not a line issue . You say these are 2600's ?? Do you have switchcards in these things ? where are you coping the data from ? From a pc and these 2600's to where ?? Probably a little more info on how this is all setup would help .

Community Member

Re: Long cable, EMI and performance.

Hi,

Thank you for the responces and the continued support. I've added a attachment briefly showing the topology we are talking about.

All servers are Windows 2003, nics forced to 100/Full with no errors on the interfaces, what I am experiencing is that

- Coping from Server A to Server B results in approximately 70% to 90% network utilisation (real time) using the Windows Task Manager to monitor the traffic

- Coping from Server A -or- B to Server C -or- D, results in approximately 2% to 5% network utilisation (real time) using the Windows Task Manager to monitor the traffic

- Coping from Server C to Server D results in approximately 70% to 90% network utilisation (real time) using the Windows Task Manager to monitor the traffic

Additionally, on my CORE switch, no ports are running any errors (Attached)

The Po on EDGE04 is currently not in use (Po1-3 on EDGE01/02/03 are however in use and working wonderfully), and not connected seeing as only one copper link is currently available.

Both switches are 2960s (sorry for the wrong information earlier)

Core:

CTN-SWCORE01>sh ver

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)SEE2, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Fri 28-Jul-06 04:33 by yenanh

Image text-base: 0x00003000, data-base: 0x00AA2F34

Edge:

CTN-SWEDGE04#sh ver

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)SEE3, RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Thu 22-Feb-07 13:57 by myl

Image text-base: 0x00003000, data-base: 0x00AA3380

Regards,

Chris.

Purple

Re: Long cable, EMI and performance.

Other things to check . You say you forced the server nics to 100/full , the corresponding switchport "must" also be forced to 100/full or you get a duplex mismatch . I don't know what port f0/5 but that has a mismatch unless you have an odd device that has to run half duplex . Can you explain what the etherchannels are doing , you have 3 on 1 side and only a single one on the other side .

Community Member

Re: Long cable, EMI and performance.

CORE - EDGE01 (200mbit/s PortChannel)

CORE - EDGE02 (200mbit/s PortChannel)

CORE - EDGE03 (200mbit/s PortChannel)

CORE - EDGE04 (100mbit)

I found some QOS values that definately degraded the performance, and since correcting this, the situation has changed drastically. The picture looks like this now...

From any EDGE to any host connected to CORE, we get full speed (100mbit without a problem) From a EDGE -through- the CORE, to a different EDGE, the speed is still degraded to sub 6mbit/s.

QOS has been removed completely on all switches so that definately can't be a issue anymore.

Unless someone has some new suggestions in terms of the change of the problem, I think I should maybe perhaps just post the full configurations for all the switches. I can't get to understand for the life of my why the speeds degrade, SO drastically...

--

Chris.

Community Member

Re: Long cable, EMI and performance.

Hi,

Full configurations for all 5 switches attached.

Community Member

Re: Long cable, EMI and performance.

Last two...

Super Bronze

Re: Long cable, EMI and performance.

Please verify what ports are interconnected.

For instance, in your original post, you have the edge04 uplink as fa0/24 but your config has:

interface FastEthernet0/24

switchport mode trunk

speed 100

duplex full

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/1

description Uplink to CTN-SWCORE01

switchport mode trunk

speed 100

duplex full

channel-group 1 mode desirable

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

description Uplink to CTN-SWCORE01

switchport mode trunk

speed 100

duplex full

channel-group 1 mode desirable

spanning-tree link-type point-to-point

Descriptions for gig interfaces appear to imply they're the uplinks?

Community Member

Re: Long cable, EMI and performance.

Hi,

CORE (fa0/23-24) - EDGE01 (gi0/1-2)

CORE (fa0/21-22) - EDGE02 (gi0/1-2)

CORE (fa0/19-20) - EDGE03 (gi0/1-2)

CORE (fa0/17-18) - EDGE04 (fa0/24)

From the CORE's view I then have:

Po1 - EDGE01

Po2 - EDGE02

Po3 - EDGE03

Po4 - EDGE04 (Not connected / Configured)

EDGE04 has been configured to operate the same as the other EDGE switches (PO over the two Gigabit Ports). Due to the fact that I only have one cable however, the cable has not been moved yet as a Po is useless with one port. Therefore, EDGE04 is the exception and linked only to one port currently - and this is maybe causing the confusion here.

303
Views
0
Helpful
9
Replies
CreatePlease to create content