Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Loopguard block problem

Hi guys,

What could be the problem if I see this logs from my core switches (cisco 6509)

%SPANTREE-SP-2-LOOPGUARD_BLOCK: Loop guard blocking port Port-channel5 on VLAN00021

%SPANTREE-SP-2-LOOPGUARD_UNBLOCK: Loop guard unblocking port Port-channel5 on VLAN00021

*port interface and fiber cable for channeling is OK, we already tested it.

Thanks in advance.

Hall of Fame Super Silver

Re: Loopguard block problem

Hello Irvine,

you are using PVST+ or Rapid-PVST, if the BPDUs for STP instance vlan21 are not received from the designated port STP loopguard puts the port of the local switch in loop inconsistent state for vlan21 instead of promoting the port to forwarding state.

As soon as BPDUs for vlan21 are received again the port is moved to a normal STP state.

We had a similar trouble between a C6500 with linecard 6708 and a C4500.

The link was tengigabit on fiber.

We solved the issue with an IOS upgrade on the C6500 moving from 12.2(18)SXF to 12.2(33)SXH2 because the previuos release was not good in managing that kind of linecard (we had another issue related to the metropolis ASIC in 6708 and TAC suggested us an IOS upgrade that solved also the stp loopguard issue).

Hope to help


Community Member

Re: Loopguard block problem

Thanks a lot Giuseppe.

We are using PVST. I wonder why the BPDU are not recieved from the designated port, what causes this problem?


Re: Loopguard block problem

Possible problems:

- bad quality fiber. Check input and output errors.

- bad SPF. Same, check input and output errors. We once had the same issue: "loop blocking/unblocking". Cause was a bad SFP in the core.

- high CPU on the core (the one that is generating the BPDUs)

- high load on the fiber, possibly dropping the BPDU packets (mostly seen in a broadcast storm situation)



Community Member

Re: Loopguard block problem

Very Interesting, i was searching for this issue and found that these could not be the reason for this issue as out of many vlan's why only one vlan is having loop problem.

Move back to the SSH and start finding the cause. Interesting i found that the root for this vlan is the edge switch, just change the spanning-tree root priority for this vlan at Core (6500) and it fixed the issue.

CreatePlease to create content