Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Losing Connection with Etherchannel

We have a new building where we added 3 network closets with 3750x stacks.We have 2 fiber gig ports connected to 2 microwave units and etherchanneled the to ports

We have the same setup at the corporate office except the connection is 2 fiber gig ports on a 6509. The 6509 is doing the routing

Now the problem is that we lost the connection to the management interface on only one of the three closets after a few days running. But some workstations at the corp office could reach it... others could not. The workstation were on the same VLAN. We solved the problem for a few days by shutting on of the fiber ports on the etherchannel. But is started happening again... now with PCs being installed at the new location.

The PC that was not working on the 3750x side could ping across to the 6509 but no further then that. It seems like an arp issue not routing because some devices are reachable and fully operational throughout the network.

Here is the configuration:

3750x:Cisco IOS Software, Version 12.2(55)SE1

Current configuration : 118 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
no snmp trap link-status
end

!
interface GigabitEthernet1/1/1
description 2gig to STB-6509
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree link-type point-to-point
channel-group 1 mode desirable
end

!
interface GigabitEthernet1/1/2
description 2gig to STB-6509
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree link-type point-to-point
channel-group 1 mode desirable
end

      

6509:IOS Version 12.2(18)SXF9

interface Port-channel7
description Vestal MicroWave
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no snmp trap link-status
end

!
interface GigabitEthernet2/19
description Vestal IDU 1 Microwave
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no snmp trap link-status
channel-group 7 mode desirable
end

!

interface GigabitEthernet2/20
description Vestal IDU 2 Microwave
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no snmp trap link-status
channel-group 7 mode desirable
end

       

Thanks Tom

Everyone's tags (1)
19 REPLIES
New Member

Losing Connection with Etherchannel

hi tom,

did you do show interface on those ports and find anything error?

regards,

New Member

Losing Connection with Etherchannel

Thanks so much for the quick response !!!

Not really...here is sho int:

6509----

GigabitEthernet2/19 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3, address is 001b.5391.497a (bia 001b.5391

  Description: Vestal IDU 1 Microwave

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is SX

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:29, output 00:00:23, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops:

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 19000 bits/sec, 11 packets/sec

  5 minute output rate 4092000 bits/sec, 828 packets/sec

     133098220 packets input, 26043978821 bytes, 0 no buffer

     Received 112359080 broadcasts (54276696 multicasts)

     0 runts, 1 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1313723337 packets output, 1029059317260 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

GigabitEthernet2/20 is up, line protocol is up (connected)

  Hardware is C6k 1000Mb 802.3, address is 001b.5391.497b (bia 001b.5391.497b)

  Description: Vestal IDU 2 Microwave

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is SX

  input flow-control is off, output flow-control is off

  Clock mode is auto

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:02, output 00:00:20, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 43000 bits/sec, 18 packets/sec

  5 minute output rate 3362000 bits/sec, 606 packets/sec

     59696085 packets input, 11419284154 bytes, 0 no buffer

     Received 35762270 broadcasts (34079262 multicasts)

     0 runts, 863 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1396351630 packets output, 1099926164657 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

GigabitEthernet1/1/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 1cdf.0f89.4431 (bia 1cdf.0f89.4431)

  Description: 2gig to STB-6509

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:10, output 00:00:03, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1971000 bits/sec, 419 packets/sec

  5 minute output rate 68000 bits/sec, 21 packets/sec

     345918330 packets input, 122421032467 bytes, 0 no buffer

     Received 103807042 broadcasts (18991280 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 18991280 multicast, 0 pause input

     0 input packets with dribble condition detected

     56984303 packets output, 9735053116 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Vestal-2-10.29.10.11#sho int g1/1/2

GigabitEthernet1/1/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 1cdf.0f89.4432 (bia 1cdf.0f89.4432)

  Description: 2gig to STB-6509

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:04, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 315000 bits/sec, 285 packets/sec

  5 minute output rate 43000 bits/sec, 8 packets/sec

     387260577 packets input, 138074568234 bytes, 0 no buffer

     Received 135437035 broadcasts (62657797 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 62657797 multicast, 0 pause input

     0 input packets with dribble condition detected

     45797091 packets output, 9081865623 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Vestal-2-10.29.10.11#

GigabitEthernet2/19 is up, line protocol is up (connected)
  Hardware is C6k 1000Mb 802.3, address is 001b.5391.497a (bia 001b.5391
  Description: Vestal IDU 1 Microwave
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is SX
  input flow-control is off, output flow-control is off
  Clock mode is auto
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:29, output 00:00:23, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops:
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 19000 bits/sec, 11 packets/sec
  5 minute output rate 4092000 bits/sec, 828 packets/sec
     133098220 packets input, 26043978821 bytes, 0 no buffer
     Received 112359080 broadcasts (54276696 multicasts)
     0 runts, 1 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     1313723337 packets output, 1029059317260 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

GigabitEthernet2/20 is up, line protocol is up (connected)
  Hardware is C6k 1000Mb 802.3, address is 001b.5391.497b (bia 001b.5391.497b)
  Description: Vestal IDU 2 Microwave
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is SX
  input flow-control is off, output flow-control is off
  Clock mode is auto
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:00:20, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 43000 bits/sec, 18 packets/sec
  5 minute output rate 3362000 bits/sec, 606 packets/sec
     59696085 packets input, 11419284154 bytes, 0 no buffer
     Received 35762270 broadcasts (34079262 multicasts)
     0 runts, 863 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     1396351630 packets output, 1099926164657 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

3750 ----

GigabitEthernet1/1/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 1cdf.0f89.4431 (bia 1cdf.0f89.4431)
  Description: 2gig to STB-6509
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1971000 bits/sec, 419 packets/sec
  5 minute output rate 68000 bits/sec, 21 packets/sec
     345918330 packets input, 122421032467 bytes, 0 no buffer
     Received 103807042 broadcasts (18991280 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 18991280 multicast, 0 pause input
     0 input packets with dribble condition detected
     56984303 packets output, 9735053116 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Vestal-2-10.29.10.11#sho int g1/1/2
GigabitEthernet1/1/2 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 1cdf.0f89.4432 (bia 1cdf.0f89.4432)
  Description: 2gig to STB-6509
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseLX SFP
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:04, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 315000 bits/sec, 285 packets/sec
  5 minute output rate 43000 bits/sec, 8 packets/sec
     387260577 packets input, 138074568234 bytes, 0 no buffer
     Received 135437035 broadcasts (62657797 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 62657797 multicast, 0 pause input
     0 input packets with dribble condition detected
     45797091 packets output, 9081865623 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Vestal-2-10.29.10.11#

New Member

Losing Connection with Etherchannel

http://www.cisco.com/en/US/docs/internetworking/troubleshooting/guide/tr1904.html

based on that docs, you are having interface resets.

youre quite sure this is a layer 2 problem, then i think im gonna go with stp behaviour between 6500 and 3750

perhaps we can start from this docs

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml

and could you provide us some of

show interface port-channel

show etherchannel summary

show interface gig xxx status

regards,

New Member

Losing Connection with Etherchannel

Thanks again here is info requested:

6509 ----

Port-channel7 is up, line protocol is up (connected)

  Hardware is EtherChannel, address is 001b.5391.497a (bia 001b.5391.497a)

  Description: Vestal MicroWave

  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s

  input flow-control is off, output flow-control is off

  Members in this channel: Gi2/19 Gi2/20

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 60000 bits/sec, 23 packets/sec

  5 minute output rate 6579000 bits/sec, 1391 packets/sec

     86457636 packets input, 18587384416 bytes, 0 no buffer

     Received 44436638 broadcasts (35496818 multicasts)

     0 runts, 1 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     1816600674 packets output, 1424780612893 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

STB_6509#
STB_6509#sho eth sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
Number of channel-groups in use: 9
Number of aggregators:           9

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------
1      Po1(SU)          -        Gi1/1(P)   Gi1/2(P)   Gi1/3(P)   Gi1/4(P)
2      Po2(SU)          -        Gi1/5(P)   Gi1/6(P)   Gi1/7(P)   Gi1/8(P)
3      Po3(SU)         PAgP      Gi5/1(P)   Gi5/2(P)
4      Po4(SU)         PAgP      Gi2/1(P)   Gi2/2(P)
5      Po5(SD)         PAgP      Gi2/21(D)  Gi2/22(D)
6      Po6(SU)         PAgP      Gi2/4(P)   Gi2/5(P)
7      Po7(SU)         PAgP      Gi2/18(D)  Gi2/19(P)  Gi2/20(P)
283    Po283(SD)        -
284    Po284(SD)        -

STB_6509#sho int g2/20 status

Port    Name               Status       Vlan       Duplex  Speed Type
Gi2/20  Vestal IDU 2 Micro connected    trunk         full   1000 1000BaseSX
STB_6509#sho int g2/19 status

Port    Name               Status       Vlan       Duplex  Speed Type
Gi2/19  Vestal IDU 1 Micro connected    trunk         full   1000 1000BaseSX

 

3750x

Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 1cdf.0f89.4432 (bia 1cdf.0f89.4432)
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/1/1 Gi1/1/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:23, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2433000 bits/sec, 835 packets/sec
  5 minute output rate 63000 bits/sec, 36 packets/sec
     734305230 packets input, 261085957161 bytes, 0 no buffer
     Received 239860957 broadcasts (81809139 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 81809139 multicast, 0 pause input
     0 input packets with dribble condition detected
     75822560 packets output, 14988035108 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Vestal-2-10.29.10.11#sh eth sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Gi1/1/1(P)  Gi1/1/2(P)

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/1/1   2gig to STB-6509   connected    trunk      a-full a-1000 1000BaseLX SF
P
Vestal-2-10.29.10.11#sho int g1/1/2 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/1/2   2gig to STB-6509   connected    trunk      a-full a-1000 1000BaseLX SF

Purple

Losing Connection with Etherchannel

  Do i understand this right you are trying to keep up an etherchannel across a microwave link ?  If so you may want to force the etherchannel "on"  instead of having it negotiate the channel  and see what happens.

New Member

Losing Connection with Etherchannel

hi glen, thanks for joining us here.

@ Tom,

based on your show interface result, there are interface that you set keepalive on, and some of them youre not using keepalive. i think its better if you use on all of them

and do you enable your log system? if no, first try to enable the timestamp, then the log system. the log message is really helping us in troubleshooting the issues here.

regards,

New Member

Losing Connection with Etherchannel

@Handoko,

Thanks for the advice.  Per your suggestion, we just turned on the keepalives on all of the interfaces, but the problem is still the same.

Thanks.

New Member

Losing Connection with Etherchannel

@tom,

- do you think you can manage to give us the log of show tech-support command from the devices?

- have you enable the log messages? if yes, then i think we can try to bring down the etherchannel interface, and then bring that up. after that, we monitor until the problem comes again (hope the log messages can give further info)

- until that log messages comes up, i want to further digging on the stp. how do you design your stp?

- if possible, try to gather the arp table from the client that succed, and the arp table from the client that not succeed going further than 6500 switch

its getting interesting ...

regards,

New Member

Losing Connection with Etherchannel

We did not have the spanning-tree command on the Port-channel1. We added it but it did not fix it... but we did not down the Port-channel. We can power off or down anything at this time cause we are not productional yet

Here is the config as is stands now on the 3750x stack:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

no snmp trap link-status

spanning-tree link-type point-to-point

end

!

interface GigabitEthernet1/1/1

description 2gig to STB-6509

switchport trunk encapsulation dot1q

switchport mode trunk

keepalive 10

spanning-tree link-type point-to-point

channel-group 1 mode desirable

end

!

interface GigabitEthernet1/1/2

description 2gig to STB-6509

switchport trunk encapsulation dot1q

switchport mode trunk

keepalive 10

spanning-tree link-type point-to-point

channel-group 1 mode desirable

end

- Logs are clean... only link up and downs

- Arp info is:

Not Working - Internet  10.29.2.151            12   0024.7e07.43e0  ARPA   Vlan29

Working          Internet  10.29.1.76             13   f80f.4136.4bd1  ARPA   Vlan29

New Member

Losing Connection with Etherchannel

hi tom,

- can you do hardcode on speed and media type?

- im checking the how many packets are in and out, on gig2/19, gig2/20, gig1/1/1 and gig1/1/2 it should be balance. is it possible that one of the link is only one way?

- what was the interface number that you do shut and no shut (that you state it fixed the problem for few days)

@glenn,

do you think the microwave is the issue? im not seeing any frame errors on the show interface.

and based on this docs

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094646.shtml

the suggested etherchannel mode between 3750 and 6500 are desirable and desireable

regards,

New Member

Losing Connection with Etherchannel

hi tom,

perhaps we can check about miswired cable using UDLD

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a008009477b.shtml

regards,

New Member

Losing Connection with Etherchannel

Just to detail things and perhaps answer some of the above questions, here are a few things that we have done:

*  We have validated that the microwave itself works fine by shutting one channel down at a time.  If we shut down one of the two channels (it doesn't matter which one), everything works properly.  This also means that both microwaves work fine independently, just not together over the EtherChannel.

Summary:

Site 1 has the 6509 and Site 2 has the 3750X.  Both sites are connected via two separate TrangoLink Microwaves.

Device A - Located at Site 1 - 10.10.1.1

Device B - Located at Site 1 - 10.10.1.2

Device C - Located at Site 2 - 10.29.1.1

Device D - Located at Site 2 - 10.29.1.2

Device A can ping device C

Device A can't ping device D

Device B can ping device C & D

If we shut down one of the two EtherChanneled ports, then A and B can both ping C & D

If we turn both EtherChanneled ports back on again, the problem immediately comes back.

It seems like it is random which source and destinations work and which ones do not.  It kind of seems like it might be related to the source MAC or something along those lines - where certain PC's can talk to certain devices, but other devices can't.

Thanks for the help.

New Member

Losing Connection with Etherchannel

device c and d, what port it connects to?

perhaps you can provide show mac table on 3750

on 6509 what sup engine and line card are you using?

enable:

service timestamps debug datetime msec

service timestamps log datetime msec

and then debug etherchannel detail, after that try to ping again

dont worry tom, this thing just interest me, so the pleasure is mine

regards,

New Member

Losing Connection with Etherchannel

the radio testing means it rules out layer 1 problem, and miswired cable.

im still thinking that this is stp related.

when there is only one link, no matter which one, everything works normal. one link from 3750 to 6500 means no loop.

when you have two links, means there is loop between the switch. this is where stp should step in.

based  on the amount of packet input and output, im kinda sure that from two  links, only one link is really forwarding packets. in normal condition,  etherchannel would do load balance. means the amount of input packet and  output should be equal. if we do one time ping (4 packets), the packets  amount on the first link should added by two, and the other two packets  should be sent through the second link.

regards,

Hall of Fame Super Gold

Losing Connection with Etherchannel

I would like to see the "sh logs" and the events when the etherchannel would flap.

New Member

Losing Connection with Etherchannel

Leolaohoo,

The Etherchannel does not go down or flap. Here is the real problem:

Summary:

Site 1 has the 6509 and Site 2 has the 3750X.  Both sites are connected via two separate TrangoLink Microwaves.

Device A - Located at Site 1 - 10.10.1.1

Device B - Located at Site 1 - 10.10.1.2

Device C - Located at Site 2 - 10.29.1.1

Device D - Located at Site 2 - 10.29.1.2

Device A can ping device C

Device A can't ping device D

Device B can ping device C & D

If we shut down one of the two EtherChanneled ports, then A and B can both ping C & D

If we turn both EtherChanneled ports back on again, the problem immediately comes back.

It seems like it is random which source and destinations work and which ones do not.  It kind of seems like it might be related to the source MAC or something along those lines - where certain PC's can talk to certain devices, but other devices can't.

New Member

Losing Connection with Etherchannel

hi tom,

any updates on the debug result?

regards,

New Member

Losing Connection with Etherchannel

All,

We forced the Etherchannel Protocol to LACP on all links on both sides of the microwave and now all devices are pinging. Here is the config we used. Can anyone explain why this may have fixed the problem. Would LACP be better suited to work on a microwave then PAgP???

interface GigabitEthernet2/20

description Vestal IDU 2 Microwave

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no snmp trap link-status

channel-protocol lacp

channel-group 8 mode active

end

!

interface GigabitEthernet2/19

description Vestal IDU 1 Microwave

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no snmp trap link-status

channel-protocol lacp

channel-group 8 mode active

end

!

interface Port-channel8

description Vestal MicroWave

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no snmp trap link-status

end

New Member

Losing Connection with Etherchannel

hi Tom,

good to know that the link working fine with lacp.

i dont believe that pagp dont work well on microwave.

anyway, do you want to continue the troubleshooting on pagp, or you will use lacp instead?

regards,

1693
Views
0
Helpful
19
Replies
CreatePlease login to create content