Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

loss of adjacency between isr4451x and 4510r-e

I'm currently having an issue with loss of connectivy between the above mentioned router and switch.

 

After a few hours the directly connected interfaces are unable to ping each other and as a side effect we lose our eigrp adjacency. Only a reload of the sup8e switching to it's failover brings the links back. I have tried the same setup replacing the 4510 with an 3750-e for testing which stays stable. So i need help with the 4510

 

Setup mpls---g0/0/1---4451- g0/0/3 ----  g1/1 ---- 4510-r-e

Router important parts

router bgp 65000
 bgp log-neighbor-changes
 network 10.149.0.0 mask 255.255.0.0
 network 10.150.0.0 mask 255.255.0.0
 network 10.151.0.0 mask 255.255.0.0
 neighbor x.x.x.x remote-as xxxxx

router eigrp 100
 network 10.150.11.0 0.0.0.255
 redistribute bgp 65000 metric 10000 1 255 1 1500
 passive-interface default
 no passive-interface GigabitEthernet0/0/3

interface GigabitEthernet0/0/3
 ip address 10.150.11.10 255.255.255.0
 speed 1000
 no negotiation auto
 vrrp 1 ip 10.150.11.5
 vrrp 1 priority 110
 vrrp 1 track 1 decrement 15

ip route 10.149.0.0 255.255.0.0 Null0
ip route 10.150.0.0 255.255.0.0 Null0
ip route 10.151.0.0 255.255.0.0 Null0

 

Switch

router eigrp 100
 network 10.150.11.0 0.0.0.255
 redistribute connected
 passive-interface default
 no passive-interface Vlan11

interface GigabitEthernet1/1
 switchport access vlan 11
 switchport mode access
 ip device tracking maximum 0
 speed 1000
 nmsp attachment suppress
 spanning-tree portfast

 

as you can see above i have placed commands into g1/1 trying to disable ip device tracking in case this is the culprit.  I havent had it running long enough for the links to go downto see with this addition.

interface Vlan11
 description Wan Vlan
 ip address 10.150.11.1 255.255.255.0

 

all is well for a few hours then all comunication stops between g0/0/3 and g1/1

I have even removed all eigrp and vrrp statements, shut and no shut the interface afterwords but still no ping once it happens. I have to reload a supervisor to get pings back.

 

the only difference between my 3750-e which works and this 4510r-e is this new ip device-tracking

 

anyone think it has to do with g0/0/3 having vrrp on it with a virtual mac address as well as the interface mac connected to g1/1 which has ip device tracking enabled ?

 

 

 

 

 

 

 

 


 

 

 

 


 

 

 


 

 

 

1 REPLY
New Member

Update, so far since

Update, so far since disabling the ip device tracking on the g1/1 port the connection has stayed stable. I'm not sure why device tracking would cause an issue or loss of connection. I have done some reading on device tracking and I hear of wierd issues such as win 7 machines receiving ip address already in use messages from dhcp received from the switch. If anyone has any experiance with device tracking I would love to here some responses. For now I am going to issue those commands across all ports since there is no global way of turning this off.

51
Views
0
Helpful
1
Replies