Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

MAC address generator

Looking for a MAC address generator?

Tks

Frank

I need to VERIFY if the IOS code really performs properly BEFORE I add this setup into my production environment.

I am hoping this config on interface G8/2 will accept up to 10 different MAC addresses. Once G8/2 receives the 11 different MAC address, Interface G8/2 will start ignoring any NEW MAC addresses for 5 minutes while allowing the current MAC addresses to continue passing data frames to/from the switch.

Also the switch will send a trap to the SNMP server to warn of the issue.

I.E. The switch will NOT shutdown the interface when a violation occurs.

interface GigabitEthernet8/2

switchport

switchport access vlan 7

switchport mode access

switchport port-security maximum 10

switchport port-security aging time 5

switchport port-security violation protect

switchport port-security aging type inactivity

load-interval 30

snmp trap link-status permit duplicates

storm-control broadcast level 70.00

storm-control multicast level 70.00

no cdp enable

no mop enabled

no mop sysid

no lldp transmit

no lldp receive

spanning-tree portfast edge

spanning-tree bpdufilter disable

spanning-tree bpduguard enable

spanning-tree guard loop

end

1 REPLY
Hall of Fame Super Silver

Re: MAC address generator

Hello Frank,

some years ago for similar tests I've used dsniff under linux there is a tool called macof.

see

http://linux.wareseeker.com/System/dsniff-2.3.zip/334600

Hope to help

Giuseppe

960
Views
0
Helpful
1
Replies