Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MAC address of IP phone in two vlans

Hi,

do you have any idea about why I see the MAC address of an IP phone in both access vlan and voice vlan? vlan 11 is my access vlan, and vlan 2222 is my voice vlan.

here's the config:

Current configuration : 247 bytes
!
interface FastEthernet1/0/12
switchport access vlan 11
switchport mode access
switchport voice vlan 2222
priority-queue out
mls qos trust cos
spanning-tree portfast
spanning-tree bpduguard enable
end

TNSWACCS01A1#sh mac address-table interface fa1/0/12
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  11    0024.8154.2aca    DYNAMIC     Fa1/0/12
  11    9caf.caff.5a8c    DYNAMIC     Fa1/0/12
2222    9caf.caff.5a8c    DYNAMIC     Fa1/0/12
Total Mac Addresses for this criterion: 3

Everyone's tags (6)
18 REPLIES

Re: MAC address of IP phone in two vlans

It is there permanetly or just for a short time?

Depending on the IP phone brand and configuration, is possible that when this IP phone boot, it has not idea about the configuration (it may get the config over DHCP server , e.g. Siemens IP phones), so in the first phase it will send frames untagged using the data vlan (that's why the mac appear there).

As soon as the IP phone get or read it configuration, it will send the frames tagged with the Voice Vlan, so the mac will be shown into the voice vlan.

A lot depends how your Voice system is configured from the IP perspective.

Community Member

I know I am probably looking

I know I am probably looking in the wrong place and this is an old forum trail but has anyoen ever expereinced issues with connecting a data device to a port that has been set up for a voip handset? i have found a few times that i have had to disabe the voice vlan to get the data device to work off the access vlan on our 3750s that are running IOS v 15

Cisco Employee

Re: MAC address of IP phone in two vlans

Hello,

In some of the Cisco IOS versions, the switch remembered the MAC of the IP

Phone in both data (native) and voice vlans. When the IP Phone boots up, it

initially associates itself to the data vlan just like any other host and

gets an IP in the DATA vlan. Then it will communicate with the TFTP server

to get the configuration file at which point it will realize that it should

be on the Voice VLAN and then change its vlan from the native vlan to voice

vlan (start tagging the packets). In the older code versions (If I remember

it right pre-12.2(44)SE), the switch did not remove the MAC from the data

vlan. Post 12.2(44)SE, they made a change to the code so the switch removes

the MAC from the MAC address table (from data vlan) as soon as the IP Phone

switches to voice vlan. I did see a bug filed for 12.2(50)SE again with the

same symptoms, so not sure if it is completely fixed. But it is not of a big

concern unless you are configuring port-security and trying to tie down the

number of MAC entries per interface.

Hope this helps.

Regards,

NT

Community Member

Re: MAC address of IP phone in two vlans

ok,

My switch has IOS C3750-IPBASEK9-M, Version 12.2(50)SE4. How can I see whether it still has that bug or not?

Also, Nagaraja, it's a good point that you mentioned port-security. That's what I'm going to implement and that's why I had to examine MAC addresses learned on each port. What are your recommendations regarding port-security when I see those multiple MACs on the same port?

Cisco Employee

Re: MAC address of IP phone in two vlans

Hello,

While this bug was originally fixed, I did notice it resurfacing in

12.2(50)SE. What kind of IP Phone you are using on that switch?

Regards,

NT

Community Member

Re: MAC address of IP phone in two vlans

Can you let us know the bugid?  Has this bug been fixed?

We see this mac address in V & D vlans sometimes. We have 12.2.53SE on a C3560.

Thanks.

Community Member

MAC address of IP phone in two vlans

Hi All,

Can anyone provide a Cisco BugID reference for this issue..?

Or

Is this normal behaviour without port-security turned ON.

Thanks

Community Member

MAC address of IP phone in two vlans

Hi,

we have the same behaviour with non Alcatel IP Phone.

According to me, it is not really a bug. There is a trunk between the switch and the phone. For some reasons, the IP phone can send some packets on the data vlan, which make its MAC address seen on the switch on this vlan. But according to me, this behaviour doesn't represent any problem for the network to wrok correctly.

P.

Community Member

Re: MAC address of IP phone in two vlans

I'm using Cisco 7911 ip phones.

Also, you mentioned port-security. That's a feature we deployed on our network. Actually I implemented the following configuration template:

interface XXX

     switchport port-sec

     switchport port-sec maximum 3 ! -- two for voice vlan, one for host

     switchport port-sec max 1 vlan access

     switchport port-sec max 1 vlan voice

     switchport port-sec mac-address sticky

I'm restricting the number of MAC addresses learned on the data vlan to one. So I guess I'm not letting the ip phone associate its MAC to the data vlan?

Community Member

MAC address of IP phone in two vlans

We verified the same issue and also found that configuring Port-Security on 12.2(50)SE5 cleared the extra MAC ADDRESS.  We removed Port-Security and the extra MAC showed up again.  We were planning to move to Port-Security on these switches anyway.

Community Member

MAC address of IP phone in two vlans

"Then it will communicate with the TFTP server

to get the configuration file at which point it will realize that it should

be on the Voice VLAN and then change its vlan from the native vlan to voice

vlan (start tagging the packets)"

I use cisco ip phones 7911 which receive vlan config via CDP. But why do I also have this problem?

My cisco ip phones mac address appears in data vlan.

Community Member

MAC address of IP phone in two vlans

I am seeing the same problem, same setup....7942's get their config via CDP.  I am seeing the phone mac address in both the Data and Voice VLANs.  It appears that it is causing an issue with random connectivity.  When Port Security is applied, I am doing max address 1 access vlan, and it is shutting the port down.  Please help.

Community Member

Re: MAC address of IP phone in two vlans

update: I upgraded IOS to 12.2.58.SE1 and the issue seems solved.

TNSWACCS01A1#sh mac add int fa1/0/20

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

2222    6416.8dbb.8d8a    STATIC      Fa1/0/20

  11    001f.29b2.c70c    STATIC      Fa1/0/20

interface FastEthernet1/0/20

description **** Justin Bieber fan ****

switchport access vlan 11

switchport mode access

switchport voice vlan 2222

switchport port-security maximum 2

switchport port-security

switchport port-security violation restrict

switchport port-security mac-address sticky

Community Member

Re: MAC address of IP phone in two vlans

Hi,

What is the number of this bug?

Community Member

MAC address of IP phone in two vlans

Hello all,

We have the same issue. We have updated the switch WS-C2960S-24TS-L to 12.2(58)SE2 but all of the IP Phones appear in both vlans (Access & voice):

SWTSOROP01#show mac address-table interface gigabitEthernet 1/0/4

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

   1    5cff.3506.ac9d    DYNAMIC     Gi1/0/4

   1    c40a.cb4d.7a9b    DYNAMIC     Gi1/0/4

   2    c40a.cb4d.7a9b    DYNAMIC     Gi1/0/4

SWTSOROP01#show mac address-table interface gigabitEthernet 1/0/1

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

   1    0018.8b67.4a7c    DYNAMIC     Gi1/0/1

   1    a8b1.d4fa.db80    DYNAMIC     Gi1/0/1

   2    a8b1.d4fa.db80    DYNAMIC     Gi1/0/1

... and the problem is that the IP Phones it's learning the access vlan IP.

All of the access ports have this config:

!

interface GigabitEthernet1/0/X

switchport mode access

switchport voice vlan 2

spanning-tree portfast

!

Thanks.

MAC address of IP phone in two vlans

I encountered the same issue.

I already upgraded the IP phone firmware and switch IOS without luck.

Please rate replies and mark question as "answered" if applicable.
Community Member

MAC address of IP phone in two vlans

i have the same issue and tried this soluation and it worked for me

default the interface configuration

shutdown the interface

reconfigure it without assigning the acces vlan meaning put all the config except the access vlan

unshut the interface

wait until the IP phone is registered and its working fine

the add the data vlan configuration

and you will see the mac address table displayed correctly

and here is an Example of the same

interface GigabitEthernet0/3

shut

switchport mode access

switchport voice vlan 118

storm-control broadcast level 1.00

spanning-tree portfast

spanning-tree bpduguard enable

!

! wait until the IP phone is registered and its working fine

!

!

!

! now you add the access vlan command

switchport access vlan 117

end

now you can show interface MAC address table

ASW1#sh mac address-table interface g0/3

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

117    0022.641f.dbf2    DYNAMIC     Gi0/3  # DATA VLAN

118    2893.fe12.1fb3    DYNAMIC     Gi0/3  # VOICE VLAN

HTH

please rate if you find it helpfull

Community Member

MAC address of IP phone in two vlans

I found this same issue.

The Cisco 7942, and 7962 were receving ICMP packets from the router according to wireshark on the phone uplink port. However the pone would not respond on the same port. I put another sniffer on the PC connected to the phone and saw packets from the phone being sent to the PC, or mirroried (The phone did not have the sniffeing feature enabled for the PC, but I was still seeing traffic with the right mac for the router, and IP). I changed arp and vlan settings on the PC and the phone would begin to respond and then stop after awhile. I found that new PC's had been added at this location HP 6305 which appears to be causing the issue, however, Cisco phones should not allow this to happen (According to Cisco). The vlan has been hard coded on the PC to determin if this resolves the issue. I am still in the process of troubleshooting.

I hope this helps.

I have includ a topology

18845
Views
25
Helpful
18
Replies
CreatePlease to create content