Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Mac address table corruption?

We are running Cisco 4500 chassis at the access layer, and have been for a few years without issue. Recently we started to experience issues where a mac address will just randomly "jump" to another port. User will call us and say their computer is not working. We will locate the mac, and its showing on the wrong port. We shut that port, do a no shut, and the mac jumps back to the correct port. In the example below, the mac address jumps to port 3/2, but is physically connected to 2/12.


!--issue before shut/no shut

mdf#show mac address-table | inc 9ebf
 236      782b.cb8c.9ebf    static ip,ipx,assigned,other GigabitEthernet3/2  

!--port security knows the correct info however

mdf#show ip dhcp snooping  binding | inc 9E:BF
78:2B:CB:8C:9E:BF   xxx.xxx.236.193   76145       dhcp-snooping   236   GigabitEthernet2/12

mdf#show mac address-table int gi2/12
Unicast Entries
 vlan     mac address     type        protocols               port
---------+---------------+--------+---------------------+-------------------------
3908      20bb.c021.ae58    static ip,ipx,assigned,other GigabitEthernet2/12   !--ip phone

 

mdf#show mac address-table int gi3/2
Unicast Entries
 vlan     mac address     type        protocols               port
---------+---------------+--------+---------------------+-------------------------
 236      1803.7339.d93d    static ip,ipx,assigned,other GigabitEthernet3/2         
 236      782b.cb8c.9ebf    static ip,ipx,assigned,other GigabitEthernet3/2         !--mac in question
 236      782b.cb8c.c366    static ip,ipx,assigned,other GigabitEthernet3/2         
3908      b414.89a2.2ae0    static ip,ipx,assigned,other GigabitEthernet3/2   

!--fixing issue

mdf(config)#int gi3/2
mdf(config-if)#shut

 

 

!-- issue resolved

mdf#show mac address-table | inc 9ebf
 236      782b.cb8c.9ebf    static ip,ipx,assigned,other GigabitEthernet2/12

 

Switch is running cat4500e-entservicesk9-mz.151-2.SG2.bin , but also happened on cat4500e-entservicesk9-mz.151-2.SG4.bin and cat4500e-entservicesk9-mz.150-2.SG4.bin. Other switches have also had this issue occur.

5 REPLIES
Cisco Employee

Looks to be me like a bug

Looks to be me like a bug.

could you please provide me some more details on this:

1- How often this issue is occurring?

2- Is this occurring to specific ports or specific laptops which are connecting to this ports or is it irrespective of devices?

3- Is there any possibilities that you try rebooting one of the switch if the issue is very often? (I know this is not a feasible solution , I know it is some issue iwth the firmware but in case to avoid high impact you can reboot the switch and update me?

4- Provide me with the logs from the switch?

5- I will do the bug scrub and let you know.

HTH

 

New Member

Issue is occurring daily?

Issue is occurring daily? Kinda tough to tell since we are relying on users to notify us.

We run mostly dells, and as far as i know, they were all dell desktops. Not sure of the model. Some ports have Cisco phones that the computers are connected to, other ports just have the desktops connected directly.

We rebooted the switch in the example this morning, and the issue appeared an hour later. The issue happened with every version of code i listed on this switch. We rebooted a few other switches and the issue re-occurred.

I can provide logs, but what logs to you need?

 

Cisco Employee

Show tech would be good.If

Show tech would be good.

If you think you cant share public send it to me via private.

New Member

pm sent

pm sent

New Member

Just to add to the complexity

Just to add to the complexity, we just had another issue pop up on a switch that hasnt had a problem before. In this case however, I removed the switchport port-security off the port and the computer was able to get an ip instantly. I did not shut/no shut the port.

576
Views
0
Helpful
5
Replies
CreatePlease login to create content